locked
Gadgets RRS feed

  • Question

  • Hi.

    Today i have installed Internet Explorer 11 and after i have restarted my computer i can not longer see my gadgets. I have tryed to get them back but no luck. When i right click in desktop window and click on Gadgets nothing happends.

    How can i get the gadgets?

    I am using Windows 7 Professional.

    Friday, May 16, 2014 1:38 PM

Answers

  • This happens to me on one machine sometimes (just happened then). After booting the system, the gadgets simply fail to appear on the desktop. I am using 100% DPI. The only way to resolve it is to either

    1. Revert to IE10.

    2. If 1. is not possible or you wish to keep IE11, open Task Manager and end the sidebar.exe process, then right click the desktop, select view and click Show Desktop Gadgets. Then once more right click the desktop, select view and click Show Desktop Gadgets.

    3. Since 2. is painful, I keep the following script on the desktop and double click it when needed to restart the sidebar. You can copy what is below and save as "restartSidebar.js"

    function restartSidebar(){
     var wshShell=new ActiveXObject("WScript.Shell");
     wshShell.Run("cmd.exe /q /c taskkill /F /IM sidebar.exe && \"%ProgramFiles%\\Windows Sidebar\\sidebar.exe\"", 0, false);
     wshShell=null;
    }
    restartSidebar();


    • Marked as answer by Roger Lu Tuesday, May 27, 2014 7:54 AM
    Monday, May 19, 2014 11:49 AM
  • Hi,

    You can also check whether option "Windows Garget Platform" is ticked (control panel\programs and features\turn windows features on or off), if not, tick it and restart pc.

    Some users slove this by changing the DPI, if you have a higher DPI like 125%, set it to 100%, test issue again.


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by Roger Lu Tuesday, May 27, 2014 7:54 AM
    Monday, May 19, 2014 3:27 AM

All replies

  • C.f.

    Microsoft Security Advisory: Vulnerabilities in Gadgets could allow remote code execution

    http://support.microsoft.com/kb/2719662/en-us



    Robert Aldwinckle
    ---

    Friday, May 16, 2014 1:41 PM
    Answerer
  • Hi,

    You can also check whether option "Windows Garget Platform" is ticked (control panel\programs and features\turn windows features on or off), if not, tick it and restart pc.

    Some users slove this by changing the DPI, if you have a higher DPI like 125%, set it to 100%, test issue again.


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by Roger Lu Tuesday, May 27, 2014 7:54 AM
    Monday, May 19, 2014 3:27 AM
  • This happens to me on one machine sometimes (just happened then). After booting the system, the gadgets simply fail to appear on the desktop. I am using 100% DPI. The only way to resolve it is to either

    1. Revert to IE10.

    2. If 1. is not possible or you wish to keep IE11, open Task Manager and end the sidebar.exe process, then right click the desktop, select view and click Show Desktop Gadgets. Then once more right click the desktop, select view and click Show Desktop Gadgets.

    3. Since 2. is painful, I keep the following script on the desktop and double click it when needed to restart the sidebar. You can copy what is below and save as "restartSidebar.js"

    function restartSidebar(){
     var wshShell=new ActiveXObject("WScript.Shell");
     wshShell.Run("cmd.exe /q /c taskkill /F /IM sidebar.exe && \"%ProgramFiles%\\Windows Sidebar\\sidebar.exe\"", 0, false);
     wshShell=null;
    }
    restartSidebar();


    • Marked as answer by Roger Lu Tuesday, May 27, 2014 7:54 AM
    Monday, May 19, 2014 11:49 AM