none
Windows 10 start menu problem after joining domain

    Question

  • Hello,I have an issue with my fresh upgrade from windows 7 to windows 10. After adding my PC with Windows 10 PRO to domain, Start Menu, Edge and search stopped working. 

    Even after logging to newly created local account problem persists.

    System genereting two logs after clicking on start button:

    LOG1

    Nazwa aplikacji powodującej błąd: SearchUI.exe, wersja: 10.0.10240.16401, sygnatura czasowa: 0x55b1a665
    Nazwa modułu powodującego błąd: Windows.UI.Xaml.dll, wersja: 10.0.10240.16397, sygnatura czasowa: 0x55af16e7
    Kod wyjątku: 0xc0000005
    Przesunięcie błędu: 0x000000000018a7b9
    Identyfikator procesu powodującego błąd: 0xa8
    Godzina uruchomienia aplikacji powodującej błąd: 0x01d0cab987475b71
    Ścieżka aplikacji powodującej błąd: C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\SearchUI.exe
    Ścieżka modułu powodującego błąd: C:\Windows\System32\Windows.UI.Xaml.dll
    Identyfikator raportu: 87515867-4c37-4f66-bc8f-dba9b75d3080
    Pełna nazwa pakietu powodującego błąd: Microsoft.Windows.Cortana_1.4.8.176_neutral_neutral_cw5n1h2txyewy
    Identyfikator aplikacji względem pakietu powodującego błąd: CortanaUI

    LOG2

    Nazwa aplikacji powodującej błąd: ShellExperienceHost.exe, wersja: 10.0.10240.16401, sygnatura czasowa: 0x55b1a820
    Nazwa modułu powodującego błąd: Windows.UI.Xaml.dll, wersja: 10.0.10240.16397, sygnatura czasowa: 0x55af16e7
    Kod wyjątku: 0xc000027b
    Przesunięcie błędu: 0x0000000000483497
    Identyfikator procesu powodującego błąd: 0x51c
    Godzina uruchomienia aplikacji powodującej błąd: 0x01d0cab9873afd62
    Ścieżka aplikacji powodującej błąd: C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe
    Ścieżka modułu powodującego błąd: C:\Windows\System32\Windows.UI.Xaml.dll
    Identyfikator raportu: 49aab678-7771-4144-82f8-87e7e05e4a1d
    Pełna nazwa pakietu powodującego błąd: Microsoft.Windows.ShellExperienceHost_10.0.10240.16384_neutral_neutral_cw5n1h2txyewy

    I appreciate any suggestion to solve this problem 

    Thursday, July 30, 2015 11:33 AM

All replies

  • Hi,

    Have you tried to logon the domain computer with your local account? Does this issue still happen in local account?

    Regarding current information, it seems that this issues is related to user account, please also try following commands to re-register the system configuration files for modern style app:

    Open powershell and run as admin:

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    Post back if you need further help.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, August 2, 2015 8:16 AM
    Moderator
  • hello!

    i tried Get-AppXPackage and it is not working for me! I add another machine to domain with win10 and its working with no problem. 

    I checked local account and and menu start there also not working with the same error code.

    Tuesday, August 11, 2015 1:09 PM
  • Hi,

    I have a similar problem!

    After joined to the domain all windows 10 computers, start menu, edge etc stop working.
    How can a software be released to enterprise enviroment with these type of issues?!!!!

    The problem afects only domain users.

    Already tested the powershell script.

    Anyone has any clue how about to solve this problem?

    Sincerely,

    AM

    Thursday, August 13, 2015 11:45 AM
  • Hi,

    I have a similar problem!

    After joined to the domain all windows 10 computers, start menu, edge etc stop working.
    How can a software be released to enterprise enviroment with these type of issues?!!!!

    The problem afects only domain users.

    Already tested the powershell script.

    Anyone has any clue how about to solve this problem?

    Sincerely,

    AM

    Using process monitor i verifyed that the ShellExperienceHost.exe and SearchUI.exe were getting a lot of ACCESS DENIED

    On Some windows folders and also in the user home folder and some registry keys.

    Thursday, August 13, 2015 11:58 AM
  • Hi,

    Please check solution here, this may also work for Windows 10:

    Windows 8.1 Store Apps Won’t Open (Or Close Immediately) when logged on as a domain user. Make it stop! (Updated 3/14/2015)
    http://blogs.technet.com/b/ouc1too/archive/2014/07/22/windows-8-1-store-apps-won-t-open-or-close-immediately-when-logged-on-as-a-domain-user-make-it-stop.aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, August 16, 2015 8:13 AM
    Moderator
  • I got this problem on two computers.

    All "menu" (linked to Modern UI) was broken = Search, start menu, notifications, ...

    I tried an sfc /scannow or the Dsim /online /cleanup... without any effect.

    I remember the problem i got with Windows 8 modern UI apps won't lunch... (lunch and immediately reduce).

    Do Simply this :

    Open regedit (with administrator rights)

    Give "read" permission to the "all application package" group on the HKEY_CLASSES_ROOT.

    Worked immediately for the two computers... (after a reboot).

    Thursday, August 27, 2015 9:14 AM
  • I have everywhere "read" premissions and i have still the same problem! Any news here ? Also in process mon i have many access denied results.
    Monday, August 31, 2015 12:13 PM
  • I have everywhere "read" premissions and i have still the same problem! Any news here ? Also in process mon i have many access denied results.

    Hi,

    Please try following suggestion to get ownership of the access denied files and folders to check the results:

    Solving Access Denied Errors Using Process Monitor
    http://improve.dk/solving-access-denied-errors-using-process-monitor/

    If this can work, we can use script or bat file deploy for your domain account to solve this issue


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, September 3, 2015 2:57 AM
    Moderator
  • Hello,

    For information, the problem was solved only for the "main" user (the user was often logged on), but not other's and if i delet this user and create back again, the problem come and never going out.

    For information when i have this problem, after i got the "explorer.exe" doing an error too "this interface is not supported on your system"...  hum....   What can i do now. Only a reinstall.... 

      

    I put the windows 10 DVD and doing an.... (migration ?) and the problem was solved but now the OS is not activated with an 0xC004C003 error code.  The OS saw the previous installation (i can downgrade to old OS). I have an case open in Microsoft. I hope Microsoft find a Solution...

    Maybe it's the Anti-Virus version not made for windows 10(but same version work on 3other Windows10 computer and 2 not work). I continue to investigate.

    • Proposed as answer by BSoares8 Thursday, March 3, 2016 2:01 PM
    Thursday, September 3, 2015 5:24 AM
  • On our domain we disable the firewall service via Group Policy, turning the service back on allowed the Start button to work normally.

    • Proposed as answer by arodtoons Friday, March 11, 2016 3:31 PM
    Thursday, March 3, 2016 2:03 PM
  • If you are a domain user and your are joining your windows 10 to a domain, make sure that your firewall is turned on.  BSoares8 is correct.
    Friday, March 11, 2016 3:31 PM
  • Just curious.  Are you using Windows 10 CB version 1511 or Windows 10 LTSB or the older Windows 10 CB?  There's been problems with the older Windows 10 and Sysprep Copyprofile that might be related.


    • Edited by JS2010 Friday, March 11, 2016 3:49 PM
    Friday, March 11, 2016 3:49 PM
  • I did a clean install of windows 10 pro that is now version 1511 10586.164. I also have a clean install of windows server essentials 2012 r2 (WSE2012R2). I created a local user account on the windows 10 pro and did not allow a Microsoft account to be added. when I tried to join the new client to the WSE2012R2 domain and log-in for the first time the start menu, store, etc.  basically everything on the task bar was unresponsive dead. If you log into your server and go to group policy management >> expand forest >> domain >> (domain name) >> group policy object >> default domain policy >> click on details and select "all setting disabled"  now you well be able to log-into your windows 10 computer.

    A couple of things on this you may not have a forest tab but if you are running WSE2012R2 it is the primary domain controller so by default it is a forest root so don't be thrown of if you open group policy management and you do not see a forest tab.

    This is the default domain policy it only as "authenticated users" which I believe is a pre=2000 group so if your domain is a mixed environment and you are still running windows 2000 you need this account so you would need to add domain computers to the account instead of disabling it or modify in a way that all client can join 

    If you want to make sure this is the offending party you will need to access the windows 10 computer you are trying to join to the domain using a local account open "computer management" (or how ever you get to event viewer)  click on event viewer >> applications and services logs >> Microsoft >> apps >> Microsoft ... windows twinui/operational open it you well see event id 5985 with a task category 5961

    ActivateApplicationForContractByAppIdAsUserWithHost of the app Microsoft.Windows.ShellExperienceHost_cw5n1h2txyewy!App for the Windows.Launch contract failed with Package could not be registered.

    I plan on using a custom GPO so I do not have to deal with this in the feature.

     best of luck


    Mark R Bracking

    Friday, March 18, 2016 5:06 AM
  • This solved my problem.
    Friday, April 15, 2016 8:40 AM
  • Got it , my company disable the firewall service, start it, it's ok.
    Friday, May 13, 2016 8:59 AM
  • What if I would like to not have the windows interferance wall turned on ?
    Wednesday, May 18, 2016 11:10 AM
  • Make sure its not installed in an enterprise environment and take the risk associated with having it off.
    Wednesday, March 1, 2017 5:33 AM
  • Hi, check the Auditing object access policy in AD.

    It must be not configured or no auditing to let the start menu work.

    Reboot needed to apply change.

    Cheers,

    Tim.

    Monday, March 27, 2017 11:13 AM
  • We had this problem too, on brand new Dell Optiplex workstations, factory Windows 10 image. For us, it turned out to be group policy we were deploying that interfered with Task Scheduler during startup. It appears Dell has placed a task to run at system startup named "Dell Cleanup" that runs a script name "startmenufix.vbs" (this is on the factory image). The script was checking for and deleting a registry key if it existed. When that task/script is allowed to run on startup there is no problem with the search bar in Start or Edge while the workstation is joined to the domain. My guess is Dell created this strange workaround to deal with some Windows 10 start menu issue.

    We had to step through all applied GPOs to be certain of the cause. Anyway, just wanted to post our finding in case it helps someone else in a similar scenario.

    Monday, March 27, 2017 5:52 PM
  • What registry key was it deleting if it found it??
    Wednesday, March 29, 2017 5:56 PM
  • Would love to know the answer to this question!
    Thursday, April 6, 2017 7:18 PM
  • I unboxed a Dell AIO with Win10 today - it's doing the same thing when joining a domain. No start menu.

    I'm not sure just yet about my default domain policy interfering with the script running, but here's the key the "startmenufix.vbs" script is looking for: "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModel\StateChange\PackageList\Microsoft.Windows.ShellExperienceHost_10.0.14393.0_neutral_neutral_cw5n1h2txyewy\"

    If this key is present, the script deletes it, and issues a reboot to the OS.

    Tuesday, April 25, 2017 7:44 PM
  • Hi, check the Auditing object access policy in AD.

    It must be not configured or no auditing to let the start menu work.

    Reboot needed to apply change.

    Cheers,

    Tim.


    That seems to have been the ticket for me. I want auditing enabled though, otherwise I can't see what I need to see in Event Viewer. How can I enable auditing without breaking my system? This shouldn't even be a problem... maybe there is a different non-breaky method?
    Thursday, June 8, 2017 10:18 PM
  • Well I had and still having same issue but I found the work around for it. 

    I logged in to the System Change computer Back from Domain to Workgroup Keep in mind the local user should have administrative privileges. and remember the password to log in as local Workgroup Restart the computer after changing it to workgroup. you will notice everything is normal go to device manager delete all the Network adapters don't restart the reboot the computer let it install the drivers automatically.

    once it is done join the domain again. reboot and login as domain users domainname\Username. it will work

    I am not sure why network adapter is causing this issue for users account in Domain environment but it seem to go away but it may or may not comeback next time you reboot the system. it only happens after you install the updates.   

    Tuesday, November 21, 2017 10:21 PM
  • At my side, after doing a Windows 10 to Windows 10 Migration, that's solve the problem.

    Wednesday, November 22, 2017 7:01 AM
  • I don't know about the logs. I had similar issue after I joined the domain and login with domain user, the user profile is not completely built. cannot use anything eg. start menu, whole taskbar, powershell. Then the link below fix my issue, go to the link, click the "Update Now", wait until finish, after reboot, it fixed the profile issues.  https://www.microsoft.com/en-us/software-download/windows10
    Tuesday, December 5, 2017 1:53 AM
  • A possible cause for this behaviour is an Applocker policy that was created for Windows 7, and is not fully compatible with later OS. If this is the case, to resolve the issue you must filter the GPO or add default rules in the Packaged apps section of the GPO. See this: https://donottouchit.wordpress.com/2017/12/20/windows-start-menu-not-working-due-to-applocker/

    Wednesday, December 20, 2017 9:46 AM
  • You could be right because i created an OU and blocked inheritance of Default Domain Policy (which has been modified extensively) and the start menu/cortana - the lot, works.

    Let me try this solution https://donottouchit.wordpress.com/2017/12/20/windows-start-menu-not-working-due-to-applocker/ (you seem to be on to something here) and get back to you. 

    Thursday, April 5, 2018 4:21 PM
  • You're right, it the default domain policy. If i block inheritance to an OU with Computer Objects in it, the Start Menu works for both Windows 10 Pro/Enterprise editions. Question is, which policy is the culprit. We have extensively over the years modeled our Domain GP. It a pain finding which one to omit/enable/disable. Aaargh.

    Friday, April 6, 2018 1:11 PM
  • I strongly advise not modifying the default domain policy.  Create new ones for the things you want to implement.  Then you can block inheritance and apply just the GPOs you want to use for specific OUs.

    I'm dealing with this issue also.  3 different customers, with very different environments.  The only similarity is Windows 10 on Active Directory.  We've been working with Microsoft support for weeks and they can't solve it with a school we are working with.  All Windows 10 machines, when exposed to the domain policies (which they have many of) lose a functional start menu.  I'm working another customer machine.

    Logged into computer with user, black desktop.  Well, no desktop.  CTL-ALT-DEL opens menu and I chose switch user
    Logged in as Domain admin first time, profile created, NO start menu activity (changes color on hover but will do nothing else).

    Log out, log in.  Desktop is black.  CTL-ALT-DEL opens menu and I can open task manager.  Wait a few minutes and desktop finally loads.  Start button is still inactive.

    Review modified domain policy and created two policies, one for drive maps, and one for Shortcuts.
    Executed dcGPOfix on server to restore default domain and default domain controller policy to default.

    Created new Organizational Unit in Active Directory and moved computer to this OU.  OU had inheritance blocked in GPO and drive map/shortcut policies applied.
    Reviewed local security policy to see if there are any custom entries.  Cleaned up some.

    Restarted, same issue.

    Removed computer from domain, local login works as expected.

    Removed old account profiles.  Joined computer to domain and placed it into new OU with inheritance blocked.  Restarted computer and logged in as domain administrator.

    Problem has returned.

    Testing...haha, install Classic Shell.  This works great.  Not a valid test though.

    Restart, back to black desktop

    Going to pull computer back and re-image it.  See what happens when I join it to the domain again.  There is probably something corrupt now that we cannot recover from.

    Here is info from troubleshooting with Microsoft at the other customer site:

    Steps taken to troubleshoot this issue:

    • We tested the Windows 10 VM built for testing of this issue by placing it in a filtered OU and manually linking GPO’s to this container one at a time to test for the failure.  We added most of the low level GPO’s before gave up on this process as it was taking a long time to test each one.  Ultimately, Microsoft support had me move the Windows 10 VM to the normal computers container as a test.  It initially didn’t have any problems but by the next day it developed the same Windows 10 Start Menu problem.
    • Microsoft then wanted to focus on one particular computer to try to resolve the Windows 10 Start Menu problem.  We designated nnnyyyyyxxxx as the computer we would focus on.  They tested things like moving this computer into a filtered OU container, removing it from the domain and adding it back in.  Nothing corrected the Start Menu issue.  We created a test user and logged in with their credentials.  Same Start Menu issue.  The only consistent issue was that a local admin could logon and have use of the Windows 10 Start Menu.
    • The did try a few things with the Windows Firewall GPO as they said there had been issues with that.  They changed the GPO set to “disable” the firewall to “not configured”.   This didn’t correct the issue either.
    • Microsoft support started focusing on event logs and found DCOM issues. They worked to correct the DCOM issues and some of the Start Menu functionality did return but it wasn’t fully corrected.  I questioned this process as being replicable on the rest of the affected Windows 10 computers and the technician said they were only required to fix it on this one computer.  I was told originally, that the fix for one should be replicable for all the systems.  It was at this point that I said we need to speak to a supervisor as that was not what we were told nor how we opened this ticket originally.  I spoke with a supervisor and got the ticket escalated again to focus on the GPO side of things as that seems to be the cause of this issue.
    • I recently noticed that there is a “Folder Redirection” setup in the Default Domain Policy for xxxxxxx.  I’ve read KB’s where this can cause problems with Windows 10 computers.  I am pushing for Microsoft support to focus on this once we get a schedule lined up again.

    It would be Nice if MICROSOFT would FIX their Newest Desktop OS to work properly in an ACTIVE DIRECTORY DOMAIN ENVIRONMENT (yes, I'm shouting).  Really tired of burning time on this stupid issue.  I am at the point of recommending install of Classic Shell and saying to heck with the new stuff.  Customers really want to use their computers.  Funny thing.  Right Microsoft?

    Wednesday, April 18, 2018 9:43 PM
  • @DrSain holly molly this is exactly what I am facing, it is NOT the firewall as others have pointed out. The ONLY fix I've found is to add ".\everyone" to local adminnistrators group on the machine.

    That's a funny "fix" but it tells us that after joining the machine to AD there are local permissions issues that prevent something from working. Event Viewer confirms that hypothesis - ton of access denied errors in system log and application log related to various .exe that seem to be OS related.

    I was under the impression that Windows 10 Pro was supposed to work in an enterprise environment? Or that was a sarcastic comment.

    What I've read is that if the domain is 2008 then the new Windows 10 GPO templates must be downloaded and copied to the DCs - have you tried this? 

    Any progress on your end?
    Thanks

    ~B


    • Edited by Boyan33 Monday, April 30, 2018 4:45 AM read more on the topic
    Sunday, April 29, 2018 2:24 AM
  • This issue has popped up again in 1803

    We did find the fix was to delete the profile for the local administrator and magically everything started to work as it should.

    Thursday, July 12, 2018 2:11 PM
  • I had my way of searching through the possible answers, but all did not work.

    Re-installing the StartMenu AppX package
    DISM cleanup
    Powershell syntaxes
    etcetera...

    As I found out, it was during the domain joining of a machine, but not in every OU, it had to be something GPO related.

    As I want to share (and to be able to find it back once I forget about it), this was my case:

    Within the GPO settings, we had a Registry permission for the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList , and it set some users/groups, but it did not set the "All Application Packages" (a machine local group) which needs READ access to that specific key.

    In my case, add the "APPLICATION PACKAGE AUTHORITY\ALL APPLICATION PACKAGES" with READ access to that key, and try it.

    It works without rebooting.

    Tuesday, September 18, 2018 7:50 AM
  • Hi Did you get some answer from Microsoft Support, I´m in the same boat;

    Everything I do don´t resolve the problem... I appreciate any help.

    Thanks.


    Augusto - Brasil

    Tuesday, October 23, 2018 12:45 AM