none
Cscript application failure - 8456 RRS feed

  • Question

  • Hello fellow MDTers – having an odd issue I cant seem to figure out. Hoping someone has seen this before, not had much luck searching the internet.

    Currently updating about 4 MDT servers to 8456. My plan was to build one to my liking and use Linked Deployment Shares to move content to the other “Blank” MDT Servers. I’ve got my “Master” MDT deployment built and working as expected and created a job to copy the content. For the most part (I think) that all has seemed to work. However, upon testing the second MDT server all of the Applications fail to install. They are all of the CScript.exe "%ScriptRoot%\Install_Application.wsf" /app:"Install.cmd" variety.

    Combing thru the ZTIApplication log I don’t get too much info on why it’s failing and when watching the deployment it’s failing fast. I’ve recreated a few of these and same outcome. What I’ve tried today to my surprise is the applications will install successfully if I use just “Install.cmd”.

    I’ve verified that the bddrun.exe, cscript.exe and install_application.wsf files are all present, all the same version as my “Master” MDT server and can view them all in notepad with the exception of cscript.exe.

    As far as I know there wouldn’t be any hardcoding of server information on any of the scripts that MDT uses, and only thought there could be because all of the folder contents were copied from the “Master” MDT Server.

    If anyone has a idea I’d really appreciate hearing it!

    ZTIApplication Log  (CScript):

    About to run command: \\MDTServer2\MDTBuild$\Tools\X64\bddrun.exe CScript.exe "\\MDTServer2\MDTBuild$\Scripts\Install_Application.wsf" /app:"Install.cmd"

    Command has been started (process ID 2788)

    Return code from command = 1Application VMware Tools 10.3.5.10430147 returned an unexpected return code: 1

    Event 41034 sent: Application VMware Tools 10.3.5.10430147 returned an unexpected return code: 1

    ZTIApplication Log (Install.cmd):

    Using a local or mapped drive, no connection is required

    Change directory: Z:\Applications\VMware Tools 10.3.5.10430147_1.01

    Run Command: \\MDTServer2\MDTBuild$\Tools\X64\bddrun.exe Install.cmd

    ZTI installing application

    Event 41031 sent: ZTI installing application

    About to run command: \\MDTServer2\MDTBuild$\Tools\X64\bddrun.exe Install.cmd

    Command has been started (process ID 2768)

    ZTI Heartbeat: command has been running for 0 minutes (process ID 2768)

    Event 41003 sent: ZTI Heartbeat: command has been running for 0 minutes (process ID 2768)

    Return code from command = 3010

    Application VMware Tools 10.3.5.10430147 installed successfully

    Event 41033 sent: Application VMware Tools 10.3.5.10430147 installed successfully


    Monday, May 13, 2019 7:56 PM