none
Editing the Schedule PDP, at the Page Details Web Part, inserted wrong Project Web App URL. Cannot access Project Schedule Pages. RRS feed

  • Question

  • I need a help. The environment, SharePoint and Project Server 2013 and SQL Server 2012, running on Windows Server 2008. Editing Details Web Part in a Schedule PDP Page, saved invalid Project Web App URL. After that, can display the Project Information and Project Details Pages from the projects accessed, and can display the Project site, too. But, when I access the Project Schedule Page, receive an error page, because of the invalid URL. The message is obvious: "There is no Web named xxxxxxx". I´ve tried to find out how to correct this, but no success, because cannot open the Project Schedule page anymore.

    I would like to know if there is some way to fix it without re-installing the system. Thanks for all. If somebody need more information, have log information and page display available. 

    Friday, December 26, 2014 7:13 PM

Answers

  • Adavi,

    I've fixed the problem. I Create a new web part, copied from another environment. After that, created a PDP, including the new web part and it worked.

    Thanks for all.

    Luis Perez

    Tuesday, January 6, 2015 5:04 PM

All replies

  • Hello,

    Do you get this for all projects? New and existing? Have this ever worked for you? What patch level is Project Server?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, December 29, 2014 6:29 PM
    Moderator
  • Hi Paul,

    Yes, I get this error for new and existing projects. The problem is that I changed the ProjectWebApp URL link, editing the Schedule PDP. It was a mistake...And after that, when I try to open any new or existing project, get the error. When the project displays the Project Detail or Initial page, it opens. The problem is when any project presents the Schedule page.

    Looking at the log, it is clear that the problem is the URL link pointing to an non existing site....I would like to know if there is a chance to correct this field..directly in the Database, or any other place...

    Thank you very much.

    Luis Perez

    Friday, January 2, 2015 10:45 PM
  • Paul,

    I forgot the patch level. The farm was installed on may, 2013, with Service Pack 1. The version is 15.0.4569.1506.

    Thank you.


    Friday, January 2, 2015 11:01 PM
  • Hello,

    What Project Web App URL did you change and where / how?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Saturday, January 3, 2015 4:07 PM
    Moderator
  • Have you tried editing the Project Web App URL web part properties for the web part on the schedule PDP? Can you edit the Schedule PDP from the PWA Settings > Project Details Page > Schedule  then edit the web part on the page (edit the page) then expand the "Project Web App URL" web part property and correct the URL if it is incorrect.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Saturday, January 3, 2015 4:20 PM
    Moderator
  • Paul,

    I changed the Project Web App URL that appears at the Schedule PDP in editing mode. The sequence is:

    Open a project from Project Center.

    Three PDPs links at the left from the project page are presented: Project Info, Project Details and Schedule. 

    Choose Scedule > the system displays the schedule page.

    Click the Page upper tab  > Choose Page edit at the ribbon

    In the Details page, at the upper-right corner there is a down arrow that displays "Web Part Details Menu" when cursor point is above it > Click on it > Choose Edit Web Part > A Details Part appears > Expand Project Web App > the Project Web App URL is there and can be edited. 

    Thanks

    Monday, January 5, 2015 1:59 PM
  • Paul,

    When I click Schedule after PWA Settings > Project Details Page, there comes the error.

    I can download the Schedule Page. But I don't see where to change, because the wrong URL doesn't apper at the page. 

    I'm sending below the page that I can download. The schedule.aspx.

    <%@ Page language="C#" MasterPageFile="~masterurl/default.master" Inherits="Microsoft.SharePoint.WebPartPages.WebPartPage" %>

    <asp:Content ContentPlaceHolderId="PlaceHolderPageTitle" runat="server">
    <SharePoint:ListProperty Property="Title" runat="server"/> - <SharePoint:ListItemProperty Property="BaseName" maxlength="40" runat="server"/>
    </asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderPageTitleInTitleArea" runat="server">
    <WebPartPages:WebPartZone runat="server" title="loc:TitleBar" id="TitleBar" AllowLayoutChange="false" AllowPersonalization="false" />
    </asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderAdditionalPageHead" runat="server">
    <meta name="GENERATOR" content="Microsoft SharePoint" />
    <meta name="ProgId" content="SharePoint.WebPartPage.Document" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta name="CollaborationServer" content="SharePoint Team Web Site" />
    <script type="text/javascript">
    var navBarHelpOverrideKey = "wssmain";
    </script>
    </asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderSearchArea" runat="server" />
    <asp:Content ContentPlaceHolderId="PlaceHolderPageDescription" runat="server">
       <asp:literal id="idPageDescription" runat="server" text="<%$Resources:PWA,PAGE_DESCRIPTION_SCHEDULE%>" />
    </asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderPageImage" runat="server"></asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderLeftNavBar" runat="server"></asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderNavSpacer" runat="server"></asp:Content>
    <asp:Content ContentPlaceHolderId="PlaceHolderMain" runat="server">
    <WebPartPages:WebPartZone runat="server" Title="loc:FullPage" ID="FullPage" FrameType="TitleBarOnly"/>
    </asp:Content>
    <asp:Content ContentPlaceHolderID="PlaceHolderUtilityContent" Runat="server">

    </asp:Content>

    Thanks

    LuisPerez

    Monday, January 5, 2015 2:32 PM
  • Luis,

    I have answered your question in another forum.

    Luis,

    Have you tried this?

    Navigate to the schedule PDP, in the browser address bar, append the string ?Contents=1, like thus:

    https://<your PWA Address>/Project%20Detail%20Pages/Schedule.aspx?Contents=1

    This will open the Webpart Maintenance page. Now, select the Details webpart, and Delete it. Once done, navigate bacjk to the webpart page, edit page, and re-add the Details Webpart to the page.

    This should fix your issue.


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Monday, January 5, 2015 4:20 PM
    Moderator
  • Adavi,

    thank you for your message. I've tried the link you sent, but get an error that I couldn't understand.

    I´ve tried it in two environments, one where the schedule PDP was changed and whre the problem occurs when I try to open the schedule page for any project. The other environment is Ok, we can open the schedule PDP from any project without problem. At this environment, we didn't make any change in the schedule PDP. The link didn´t display the Schedule page on both environments, insted send an error.

    Looking at the log, didn't find something that could indicate the problem. 

    Note: the only change I've had to make to the sample link you sent to me is the https. We don't use it. My user is administrator.

    If you need more information, request it please, that I will send to you.

    Thanks

    Monday, January 5, 2015 7:30 PM
  • Luis,

    The only important piece is my link is the "?Contents=1" piece. Just add it to the end of your PWA URL, which should bring you to the web part maintenance page.

    If you still get an error, please post a screenshot so that we can see what the error is.


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Monday, January 5, 2015 7:55 PM
    Moderator
  • Adavi,

    I added the "?Contents=1" piece to the end of my PWA URL, as I did before. Received same error.

    I added the screenshot you ask to this post, but then received this message: "Body text cannot contain images or links until we are able to verify your account."

    The error message is generic and is in portuguese.

    The content is:

    "Something was wrong. Unexpected error."

    Thanks.


    Luis Perez

    • Edited by LuisCPerez Monday, January 5, 2015 10:03 PM
    Monday, January 5, 2015 9:55 PM
  • Adavi,

    I've fixed the problem. I Create a new web part, copied from another environment. After that, created a PDP, including the new web part and it worked.

    Thanks for all.

    Luis Perez

    Tuesday, January 6, 2015 5:04 PM