locked
After change SQL Aliases with SharePoint but Configuration Wizard doesn't work? RRS feed

  • Question

  • I have moved database to new SQL server, "Server2", and we did SQL Aliases in all SharePoint servers, like this post

    Using SQL Aliases With SharePoint




    It happened almost 1 year ago. Now I am trying to run SharePoint Configuration Wizard giving below error. But application is working fine. 


    What could be the problem?

    Update:
    ---

    Log errors after ran wizard

    `SqlError: 'Cannot open database "SharePoint_Config" requested by the login. The login failed.'    Source: '.Net SqlClient Data Provider' Number: 4060 State: 1 Class: 11 Procedure: '' LineNumber: 65536 Server: 'Server1'   
    07/22/2013 13:25:32.73          OWSTIMER.EXE (0x0724)                             0x073C            Windows SharePoint Services           Database                                  880j     High    SqlError: 'Login failed for user 'Domain\sn_spappprod'.'    Source: '.Net SqlClient Data Provider' Number: 18456 State: 1 Class: 14 Procedure: '' LineNumber: 65536 Server: 'Server1'      
    07/22/2013 13:25:32.73          OWSTIMER.EXE (0x0724)                             0x073C            Windows SharePoint Services           Database                                  6y63    Critical SQL Database 'SharePoint_Config' on SQL Server instance 'Server1' not found. Additional error information from SQL Server is included below.  Cannot open database "SharePoint_Config" requested by the login. The login failed.  Login failed for user 'Domain\sn_spappprod'.   
    07/22/2013 13:25:32.73          OWSTIMER.EXE (0x0724)                             0x073C            Windows SharePoint Services           Database                                  880k    High       at Microsoft.SharePoint.Utilities.SqlSession.ExecuteReader(SqlCommand command, CommandBehavior behavior)     at 
    `

    It suppose to connect alias databases server.


    ItsMeSri MOSS SP2, 3 WEFs, Windows 2008 R2 x64.

    Tuesday, July 23, 2013 1:43 PM

Answers

  • Hi ItsMeSri,

    I understand that after you change SQL Aliases, the Configuration Wizard doesn’t work anymore. Can you browse all the sites and Central Administration successfully in browser? Have you tried to not use the Alias to see whether it fixes this issue?

    Try to log in SQL server using the user 'Domain\sn_spappprod'. Check the status of the SharePoint_Config database(Don’t change anything in the database directly. Just check the status here). I have seen this error once. In my case, the SharePoint_Config database is in a Suspect mode. Then I fixes this issue by running a sql query.

    For more information, please refer to this site:

    How to troubleshoot common errors that occur when you run the SharePoint Products and Technologies Configuration Wizard on a computer that is running Windows SharePoint Services 3.0 or SharePoint Server 2007: http://support.microsoft.com/kb/944267

    SharePoint_Config Database Suspect Mode – Cannot Connect to the Configuration Database Error: http://nikspatel.wordpress.com/2011/03/02/sharepoint_config-suspect-mode-cannot-connect-to-the-configuration-database-error/

    Thanks,

    EnTan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming
    TechNet Community Support

    Wednesday, July 24, 2013 2:38 AM
    Moderator