none
File System Task Editor closes when selecting DestinationVariable RRS feed

  • Question

  • I've set up a File System Task to move a file. I set IsDestinationPathVariable to True. When I click inside the DestinationVariable value column and either click the drop-down arrow or hit the up/down arrow keys on my keyboard, the File System Task Editor window closes immediately. In the same task, I have also set IsSourcePathVariable to True and am able to select SourceVariable without an issue. If I set IsDestinationPathVariable to False, the DestinationConnection drop-down appears to work fine. I've tried restarting Visual Studio, but it had no effect.
    • Moved by Janet Yeilding Tuesday, May 29, 2012 11:46 PM (From:SQL Server Data Tools)
    Friday, May 25, 2012 6:39 PM

All replies

  • I've been able to work around this by directly assigning the values in the Properties window instead of the File System Task Editor, but still curious to know why the editor window isn't working.
    • Edited by D. Ozouf Friday, May 25, 2012 10:19 PM
    Friday, May 25, 2012 10:18 PM
  • Hi D.Ozouf,

    I have tried to use File System Task on my Business Intelligence Development Studio, and all seems ok. Please try to drag another  File System Task to the control flow and see if it has the same issue. If so, plese try to repair install the Business Intelligence Development Studio.

    Thanks,
    Eileen

    • Proposed as answer by BIWORKMVP Friday, June 1, 2012 7:54 AM
    Friday, June 1, 2012 5:24 AM
  • I suggest you can delete this package and test it again, I used a File System Task, it works fine.


    Hope it helps! Vote if it's helpful! Simon MSN:simonlv@live.cn Skype:simonlvpin

    Friday, June 1, 2012 7:55 AM
  • I have this same problem and have tried several alternative ways (like using Expressions to define the Destination) to work around this to no avail. Well, using an expression does help in defining the destination, but still it cannot find the destination defined via Expression. It appears like there is something broken in the DestinationVariable drop-down, or my package file is somehow corrupted.

    Defining the source using the drop-down menu works ok, only the DestinationVariable causes the problems.

    Thursday, September 5, 2013 7:52 AM
  • I have come across this exact issue as well.  Furthermore, when I attempted to circumvent the issue by setting the "destination" in the properties' expression window, I was able to chose a variable. But then when I looked back in the editor window, the Destiantion Variable does not show the name of the variable I assigned, lets name it "MyVariable".  It shows the *value* that the variable holds instead, lets call this "VarValue".  Furthermore, when I attempt to run the package, an error is thrown. The error is that the package can not find the variable "VarValue". What is happening, is that when I set the expression to "MyVariable" the engine looks up the value of "MyVariable" and then sets THAT VALUE as the NAME of the variable, and then looks for a variable named "VarValue" in the dts variables collection. 

    Christopher Obert Solutions Developer

    Thursday, January 30, 2014 7:34 PM
  • Further investigation has shown me that this appears to occur when a Project Parameter has it's sensitivity level set to true.


    Christopher Obert Solutions Developer

    Friday, January 31, 2014 6:13 AM
  • Thanks!  I had the exact same problem, and I have a value called DatasourceUserPW which is a password and sensitivity was set to true, all other params were already false.  

    Setting that sens' to false got it to not force close.  I cant do that forever, but at least during testing its an ok workaround.

    Is this a bug or as intended.  Also I realize this thread is old.

    Monday, February 23, 2015 6:24 PM
  • It's still a problem.  4 years and counting.  It's going to get me canned.
    Monday, June 27, 2016 9:04 PM
  • I have the same issue... Any suggestions for data tools?
    Saturday, September 17, 2016 12:55 AM
  • a year after the previous reply and 5 years after the original post...

    I can confirm that this problem is still occurring.

    I'm seeing the issue in a VS2012 SSDT SSIS package.  Once the error occurs, it happens with the DestinationVariable drop-downs in ALL of the File System Tasks in the package.

    I can also confirm that changing the "Sensitive=True" project parameter to be false provides a temporary workaround.

    Has anyone found a more permanent solution to this problem?

    Tuesday, October 3, 2017 3:41 PM
  • Just found this post thankfully as it helped me determine the WHY.  It also helped me solve the issue, so thanks to all.  I have a more semi-permanent solution??... at least this worked for me:

    I set the sensitivity to "false" for my PW field, then I set the destination value from the drop-down box in the File System Task, then closed the Editor.  I went back to my PW field and set the sensitivity back to "true", Rebuilt, Deployed and Ran it successfully from the server.

    I hope this helps!

    Tuesday, February 12, 2019 8:11 PM