none
Start Menu search causes DCOM timeout and DLLHOST crash events, since 1703 build

    Question

  • Hi all,

    Looking for some insights as to why the Start Menu search is triggering these events.

    From the System events we have this each time I start typing in the Start Menu:

    Log Name:      System
    Source:        Microsoft-Windows-DistributedCOM
    Date:          26/04/2017 10:19:19 AM
    Event ID:      10010
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          GREG-TT\Greg
    Computer:      Greg-TT
    Description:
    The server {7966B4D8-4FDC-4126-A10B-39A3209AD251} did not register with DCOM within the required timeout.

    This GUID appears in my registry to match "WebPlatStorageBroker Class"

    This error seems to coincide with accessing the start menu and typing a search.  The search loses focus after a couple of characters and a few seconds later the cursor returns to the search line.

    I also found that in the Application event log that the following error occurs each time:

    Log Name:      Application
    Source:        Application Error
    Date:          26/04/2017 10:19:00 AM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Greg-TT
    Description:
    Faulting application name: DllHost.exe, version: 10.0.15063.0, time stamp: 0x4f42de92
    Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x000001e9a48812ff
    Faulting process ID: 0x314c
    Faulting application start time: 0x01d2be22b3e3bbbb
    Faulting application path: C:\WINDOWS\system32\DllHost.exe
    Faulting module path: unknown
    Report ID: a9ea3cb6-ee2f-4da2-8400-914e72b59f51
    Faulting package full name: 
    Faulting package-relative application ID: 

    The same errors appear to happen when I type in the Edge address line too.

    This issue seems to me to be linked to how Windows 10 is searching in my opinion.

    Any thoughts or suggestions?


    Wednesday, April 26, 2017 12:47 AM

All replies

  • Hi,

    To explicitly register a DCOM class as a system global, use the following steps:

    1.If it does not exist, create the following registry key:
    HKLM\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Compatibility\CLSID

    2.Create a subkey with {CLSID} as its name, where the CLSID is the class identifier of the DCOM class that is to be a system global. For example, a subkey would be: {7966B4D8-4FDC-4126-A10B-39A3209AD251}

    3.Under the above subkey, create fSystemGlobalClass as the value name with a REG_DWORD type and set its value data to 1.

    Besides that, please also run this command as Admin:

    SFC /SCANNOW

    Afterwards, run the following cmdlet in the PowerShell as Admin:

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 27, 2017 6:30 AM
    Moderator
  • Karen,

    We have many computers experiencing this same error.  On all of them it started immediately following application of the Creator update.  All are running Windows 10 Pro.  I tried the process you outline here with no impact on the issue.  During the powershell, I got 2 errors indicating that the install folder is c:\ and the DCOM did not register error was evoked 7 times.  Once it completed, I clicked the Cortana search box and the error occurred again.

    It seems unlikely that we are alone in having this error given that most of our desktop machines are seeing the symptom.  Is there any information that we can provide that will help you to diagnose this and provide a more effective solution?

    Thursday, April 27, 2017 3:10 PM
  • Hi Prof,

    Let's do a test on one machine.

    Roll back to previous and upgrade again to see if any differences.

    Alternatively, use the Windows 10 1703 official ISO to do In-Place Upgrade for test.

    To obtain the installation file, visit this page:

    Download Windows 10

    https://www.microsoft.com/en-us/software-download/windows10


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 28, 2017 8:38 AM
    Moderator
  • Karen,

    Thank you for the suggestion.  I can't say whether it would help.  One of our folks contacted support and found that the issue seems to be related to McAfee Anti-Virus.  When we uninstalled all of the McAfee endpoint protection, the issue goes away.  Apparently there is something in that DCOM load that is triggering a McAfee OnAccessScan alert of some kind.  We reviewed McAfee Endpoint Protection logs, but there are no related entries.  It is unclear why a block would happen without any log being generated, but that is a McAfee issue, not a Microsoft one.

    Microsoft may be interested in working with McAfee on our behalf to get their signatures to stop this behavior.  That would help us out.  If not, then I leave this explanation behind for the next victim.

    [Update: As a workaround, we are adding dllhost.exe to the McAfee exception list in ePO.]
    Friday, April 28, 2017 5:30 PM
    • Proposed as answer by YPae Wednesday, May 10, 2017 11:03 PM
    Wednesday, May 10, 2017 11:02 PM
  • I am also having this issue after an In Place Upgrade from Win7 to 10 v1703.  We do not use McAfee.  Any other ideas what could be causing this issue?  
    Monday, July 31, 2017 7:20 PM