none
Oracle Management Agent Creation Failure RRS feed

  • Question

  • I know this question has been asked a dozen times already, but I don't know if there has ever been a definitive answer to what is going on aside from the recommendations to use the Generic SQL connector in lieu of the Oracle connector to connect to an Oracle database. Like many I still get the message about the unlinked assembly.

    I have followed about all the recommendations in the serveral threads I have been revisiting like:

     - Oracle Client 11.2.0.4 installed with the administration option;

     - The connection to the database with tnsping works, and I can use sqlplus usename@db_alias without any problem showing the tnsnames.ora file is correctly set up. In fact I have one entry in that file and the entire entry is in one line with no spaces to avoid another potential issue raised in one of the threads;

     - Accounts associated with both FIM Service and FIM Synchronization Service have full rights to the Oracle install folder;

     - Used the .NET installUtil.exe to re-register/re-install  Microsoft.DirectoryServices.MetadirectoryServices.Config.dll;

     - Provided the table name as schema.table_name;

     - I am running MIM 2016 SP1 (4.5.412.0) on Windows 2016 with latest updates

    The connection with the generic SQL connector works, but I would like to get the Oracle connector working as well. Is there anything that needs to be done regarding the Oracle.ManagedDataAccess.dll library? I do use that library with some Powershell scripts to connect to the same database, and I wonder if that is not being loaded if it is even used.

      





    Monday, October 21, 2019 9:53 PM