none
Publishing Feature failed to activate

    Question

  • I activated the SharePoint Server Publishing Infrastructure feature at the site collection level.

    But I'm unable to activate the SharePoint Server Publishing feature at the site level for the main "../sites/home" site.

    I tried activating it through the GUI.  Been researching online, ..tried de-activating the feature at the site collection level, then doing IIS reset, then re-activating at the site collection level.   Still won't activate at the site level.

    Also tried doing Enable-spfeature through powershell.  It still won't activate.

    I get the error "Failed to create the "Documents" library.   A list with the specified title already exists in this web site.

    And the error "Failed to create the "Pages" library.   A list with the specified title already exists in this web site.

    I deleted the Pages library.  still won't activate.

    I don't see any "Documents" library.  only the "Shared Documents" library.

    how frustrating!

    any help would be appreciated.

    thanks!

    Tuesday, May 17, 2016 7:28 PM

Answers

  • Hi lorrdellatorre,

    Please try to do the followings:

    1. Open the site with SharePoint Designer. Go to All files, try to find the library or list which may cause the issue, delete it.

    2. Check Site Contents->recycle bin and delete the list or library.

    3. Go to Site settings->Recycle bin under Site Collection Administration, delete the library from "Delete from end user recycle bin".

    If the above still doesn't work, please check ULS log to find more information about this issue.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 18, 2016 8:43 AM
    Moderator

All replies

  • Hi,

    You can activate the publishing feature using script.

    Add-PSSnapin Microsoft.SharePoint.PowerShell 

    $site = Get-SPSite http://portal

    $site | Get-SPWeb -limit all | ForEach-Object {Enable-SPFeature -Identity "PublishingSite" -Url $_.Url}

    $site.Dispose()

    Or you can use the STSADM command as well

    stsadm –o activatefeature –name publishingsite –url http://yourdomain.com/sites/yourweb -force

     

    stsadm –o activatefeature –name publishingweb –url http://yourdomain.com/sites/yourweb -force


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Tuesday, May 17, 2016 7:42 PM
  • Hi lorrdellatorre,

    Please try to do the followings:

    1. Open the site with SharePoint Designer. Go to All files, try to find the library or list which may cause the issue, delete it.

    2. Check Site Contents->recycle bin and delete the list or library.

    3. Go to Site settings->Recycle bin under Site Collection Administration, delete the library from "Delete from end user recycle bin".

    If the above still doesn't work, please check ULS log to find more information about this issue.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 18, 2016 8:43 AM
    Moderator
  • I tried all of these things.  

    Now in the logs, its saying failed to create the Documents library.

    Thursday, May 19, 2016 3:59 PM
  • ok, now that I deleted the Documents library (as well as the Pages library), it finally allowed me to Activate the Publishing feature

    Thursday, May 19, 2016 4:02 PM
  • Hi lorrdellatorre,

    As your issue is solved, please mark the replies that help you as answer, it will be beneficial to others in this forum who meet the same issue in the future.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, May 20, 2016 1:15 AM
    Moderator
  •  I will after I'm done testing.    I'm currently testing to see if everything is going to work ok after I move all the files from my BackupPages library to the new Pages library (that got created on publishing feature activation), and move all the files from the BackupDocuments to the new "Documents"

    I'm hoping all the links will still be ok, we have many links to these pages and documents.

    Friday, May 20, 2016 1:08 PM
  • one thing I noticed, it won't let me open the "Pages" and "BackupPages" libraries in Windows Explorer view, which would've been the easiest way to move them.  

    But it allowed me to move them through Content and Structure.   There was several so I didn't want to move them by individually downloading them.

    The new Documents library that was created through Publishing feature activation has the http://portal/sites/home/documents URL.   And before the upgrade, this same URL was used by a sub-site called Documents, which contains many folders and files.   Now moving them all over to the new "documents" library.


    Friday, May 20, 2016 1:09 PM