none
Disable FIM provisioning via registry or powershell? RRS feed

  • Question

  • Hi,

    Is there a way to disable FIM provisioning via registry or powershell?

    We are looking to auto disable FIM provisioning in a DR scenario in this way. If not possible, we can simply halt the Run Profiles from running, until someone manually unchecks provisioning and performs manual Joins first.

    Thanks,

    SK

    Wednesday, November 19, 2014 9:23 PM

Answers

  • Hi Shim,

    I have seen how it is realized in some customer's environments. But it requires to use custom code as to use for it.

    Such customers have custom DLL pointed as metaverse rules extension. This DLL has its config file as well. And as a part of scheduled tasks, config file is changed between run profiles, so in a normal situation provisioning is enabled. But scheduled task changes the file to disabled provisioning and, after a couple of profiles, it is re-enabled.

    This is how to change metaverse provisioning.

    To change Synchronization Rule Provisioning there is a query for FIMService that changes FIMSync option:

    Using PowerShell to enable provisioning

    To use this, you need to add the FIM service account to the FIMSyncAdmins group!


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    • Marked as answer by Shim Kwan Tuesday, November 25, 2014 3:45 AM
    Thursday, November 20, 2014 7:26 AM

All replies

  • Hi Shim,

    I have seen how it is realized in some customer's environments. But it requires to use custom code as to use for it.

    Such customers have custom DLL pointed as metaverse rules extension. This DLL has its config file as well. And as a part of scheduled tasks, config file is changed between run profiles, so in a normal situation provisioning is enabled. But scheduled task changes the file to disabled provisioning and, after a couple of profiles, it is re-enabled.

    This is how to change metaverse provisioning.

    To change Synchronization Rule Provisioning there is a query for FIMService that changes FIMSync option:

    Using PowerShell to enable provisioning

    To use this, you need to add the FIM service account to the FIMSyncAdmins group!


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    • Marked as answer by Shim Kwan Tuesday, November 25, 2014 3:45 AM
    Thursday, November 20, 2014 7:26 AM
  • In Addition to what Dominik said. you'll have to change the folowing line 

    $importChange.AttributeValue = "none"
    

    In order to disable the Sync Rule Provisioning.


    Regards Furqan Asghar

    Sunday, November 23, 2014 7:04 AM
  • thank you, I think we will look for an alternate solution. cheers.
    Tuesday, November 25, 2014 3:45 AM