none
TSMBOOTSTRAP.EXE return 2147500037 RRS feed

  • Question

  • Hi Guys, when I deployed win7 on some Fujitsu desktop, I met 2 errors litetouch deployment failed,return code= -2147467259 0x80004005, and In smsts.log. it seems tsmbootstrap.exe failed that caused this failure.

    But this problem only occur on fujitsu desktop.

    Someone who can help on this? Thanks

    Attached smsts log.

    <![LOG[Used smsts.ini to set logging settings.]LOG]!><time="05:16:05.439+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="tslogging.cpp:1457">
    <![LOG[==============================[ TSMBootStrap.exe ]==============================]LOG]!><time="05:16:05.439+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="tsmbootstrap.cpp:1185">
    <![LOG[Command line: "X:\Deploy\Tools\X64\TsmBootstrap.exe"  /env:SAStart]LOG]!><time="05:16:05.439+480" date="04-07-2016" component="TSMBootstrap" context="" type="0" thread="2016" file="tsmbootstrap.cpp:1186">
    <![LOG[Current OS version is 10.0.10586.0]LOG]!><time="05:16:05.486+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="util.cpp:3203">
    <![LOG[Running Task Sequence in standalone.]LOG]!><time="05:16:05.486+480" date="04-07-2016" component="TSMBootstrap" context="" type="0" thread="2016" file="tsmbootstrap.cpp:523">
    <![LOG[Environment scope successfully created: Global\{51A016B6-F0DE-4752-B97C-54E6F386A912}]LOG]!><time="05:16:05.486+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="environmentscope.cpp:623">
    <![LOG[Environment scope successfully created: Global\{BA3A3900-CA6D-4ac1-8C28-5073AFC22B03}]LOG]!><time="05:16:05.486+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="environmentscope.cpp:623">
    <![LOG[Loading the Environment Variables from "X:\Deploy\Tools\X64\variables.dat".]LOG]!><time="05:16:05.548+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="tsmbootstrap.cpp:549">
    <![LOG[D:\_SMSTaskSequence does not exist]LOG]!><time="05:16:05.564+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="utils.cpp:1851">
    <![LOG[Updated security on object D:\_SMSTaskSequence.]LOG]!><time="05:16:05.580+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="utils.cpp:1815">
    <![LOG[Updating the local data path in the Task Sequencing Environment.]LOG]!><time="05:16:05.580+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="tsmbootstrap.cpp:659">
    <![LOG[Reading  logging settings from TS environment to set TS logging]LOG]!><time="05:16:05.580+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="tslogging.cpp:2555">
    <![LOG[Process completed with exit code 2147500037]LOG]!><time="05:20:17.520+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="commandline.cpp:1124">
    <![LOG[Exiting with return code 0x80004005]LOG]!><time="05:20:17.520+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2016" file="tsmbootstrap.cpp:1258">
    <![LOG[Used smsts.ini to set logging settings.]LOG]!><time="05:20:17.614+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2044" file="tslogging.cpp:1457">
    <![LOG[==========[ TsProgressUI started in process 2004 ]==========]LOG]!><time="05:20:17.614+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2044" file="winmain.cpp:330">
    <![LOG[Unregistering COM classes]LOG]!><time="05:20:17.614+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2044" file="winmain.cpp:204">
    <![LOG[Shutdown complete.]LOG]!><time="05:20:17.614+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2044" file="winmain.cpp:512">

     
    Thursday, April 7, 2016 3:52 AM

All replies

  • add more info, there was a file named bcdtest.txt in X:\Windows\temp folder, and its content is:

    The boot configuration data store could not be opened.
    The requested system device cannot be found.
    The boot configuration data store could not be opened.
    The requested system device cannot be found.

    Does it have relationship on tsmbootstrap failure?

    Thursday, April 7, 2016 3:57 AM
  • The error just means that the task sequence failed.  There isn't enough information in that log to tell why it failed.  By chance are you running MDT 2013 Update 1?  The TS engine in that release has problems with logging; those are fixed in MDT 2013 Update 2.  I would suggest upgrading when you get a chance.

    Without any detail in the SMSTS.LOG, you might need to check the BDD.LOG to see if it provides more clues.  If it's a standard MDT step, it should write some entries to that log before the TS fails, but if you've added any custom steps, they wouldn't log to BDD.LOG at all.


    Thanks,
    -Michael Niehaus
    Director of Product Marketing, Windows Deployment, Management, and Store
    http://blogs.technet.com/mniehaus
    mniehaus@microsoft.com

    Thursday, April 7, 2016 4:39 AM
  • Thanks Michael, checked version is update 1, I'll update to see result,thanks

    Thursday, April 7, 2016 6:17 AM
  • After update MDT2013 U2 , error still exist,  attached BDD.Log, smsts log and litetouch.log

    other logs returned success

    failed part of BDD.LOG:

    <![LOG[Property OSDTargetDriveCache is now = C:]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTIWinRE" context="" type="1" thread="" file="ZTIWinRE">
    <![LOG[Property OSDisk is now = C:]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTIWinRE" context="" type="1" thread="" file="ZTIWinRE">
    <![LOG[WinRE is not enabled, Skip.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTIWinRE" context="" type="1" thread="" file="ZTIWinRE">
    <![LOG[ZTIWinRE processing completed successfully.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTIWinRE" context="" type="1" thread="" file="ZTIWinRE">
    <![LOG[Microsoft Deployment Toolkit version: 6.3.8330.1000]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTINextPhase" context="" type="1" thread="" file="ZTINextPhase">
    <![LOG[The task sequencer log is located at X:\WINDOWS\TEMP\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTINextPhase" context="" type="1" thread="" file="ZTINextPhase">
    <![LOG[Property PHASE is now = STATERESTORE]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTINextPhase" context="" type="1" thread="" file="ZTINextPhase">
    <![LOG[ZTINextPhase COMPLETED.  Return Value = 0]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTINextPhase" context="" type="1" thread="" file="ZTINextPhase">
    <![LOG[ZTINextPhase processing completed successfully.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="ZTINextPhase" context="" type="1" thread="" file="ZTINextPhase">
    <![LOG[Property LogPath is now = X:\MININT\SMSOSD\OSDLOGS]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Command completed, return code = -2147467259]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Litetouch deployment failed, Return Code = -2147467259  0x80004005]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="3" thread="" file="LiteTouch">
    <![LOG[For more information, consult the task sequencer log ...\SMSTS.LOG.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Property RetVal is now = -2147467259]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Unable to copy log to the network as no SLShare value was specified.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[CleanStartItems Complete]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[TSCore.dll not found, not unregistering.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[About to run command: wscript.exe "X:\Deploy\Scripts\LTICleanup.wsf"]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Microsoft Deployment Toolkit version: 6.3.8298.1000]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Removing AutoAdminLogon registry entries]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Re-enabling UAC for built-in Administrator account]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[VSSMaxSize not specified using 5% of volume.]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Logs contained 2 errors and 0 warnings.]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[No Windows PE image to delete.]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Checking mapped network drive.]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[testing drive Z: mapped to \\10.166.72.50\DeploymentShare$]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Disconnecting drive Z: mapped to \\10.166.72.50\DeploymentShare$]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Cleaning up X:\MININT directory.]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">
    <![LOG[Cleaning up TOOLS, SCRIPTS, and PACKAGES directories.]LOG]!><time="08:40:55.000+000" date="04-07-2016" component="LTICleanup" context="" type="1" thread="" file="LTICleanup">

    failed part of litetouch.log:

    <![LOG[ResourceDrive = Z:]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Property _SMSTSPackageName is now = Lite Touch Installation]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[SMS Task Sequencer already found on X:\Deploy\Tools\X64]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Copying \\10.166.72.50\DeploymentShare$\Control\WIN7_004\TS.XML to X:\Deploy\Tools\X64]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Copying D:\MININT\SMSOSD\OSDLOGS\VARIABLES.DAT to X:\Deploy\Tools\X64\VARIABLES.DAT]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[LTI beginning deployment]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[About to run command: "X:\Deploy\Tools\X64\TsmBootstrap.exe" /env:SAStart]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Property LTIDirty is now = TRUE]LOG]!><time="08:36:43.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Property LogPath is now = X:\MININT\SMSOSD\OSDLOGS]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Command completed, return code = -2147467259]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Litetouch deployment failed, Return Code = -2147467259  0x80004005]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="3" thread="" file="LiteTouch">
    <![LOG[For more information, consult the task sequencer log ...\SMSTS.LOG.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Property RetVal is now = -2147467259]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[Unable to copy log to the network as no SLShare value was specified.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[CleanStartItems Complete]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[TSCore.dll not found, not unregistering.]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">
    <![LOG[About to run command: wscript.exe "X:\Deploy\Scripts\LTICleanup.wsf"]LOG]!><time="08:40:54.000+000" date="04-07-2016" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">

    SMSTS.LOG:

    <![LOG[Used smsts.ini to set logging settings.]LOG]!><time="08:36:43.443+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="tslogging.cpp:1457">
    <![LOG[==============================[ TSMBootStrap.exe ]==============================]LOG]!><time="08:36:43.443+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="tsmbootstrap.cpp:1185">
    <![LOG[Command line: "X:\Deploy\Tools\X64\TsmBootstrap.exe"  /env:SAStart]LOG]!><time="08:36:43.443+480" date="04-07-2016" component="TSMBootstrap" context="" type="0" thread="2008" file="tsmbootstrap.cpp:1186">
    <![LOG[Current OS version is 10.0.10586.0]LOG]!><time="08:36:43.490+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="util.cpp:3203">
    <![LOG[Running Task Sequence in standalone.]LOG]!><time="08:36:43.506+480" date="04-07-2016" component="TSMBootstrap" context="" type="0" thread="2008" file="tsmbootstrap.cpp:523">
    <![LOG[Environment scope successfully created: Global\{51A016B6-F0DE-4752-B97C-54E6F386A912}]LOG]!><time="08:36:43.506+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="environmentscope.cpp:623">
    <![LOG[Environment scope successfully created: Global\{BA3A3900-CA6D-4ac1-8C28-5073AFC22B03}]LOG]!><time="08:36:43.506+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="environmentscope.cpp:623">
    <![LOG[Loading the Environment Variables from "X:\Deploy\Tools\X64\variables.dat".]LOG]!><time="08:36:43.584+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="tsmbootstrap.cpp:549">
    <![LOG[D:\_SMSTaskSequence does not exist]LOG]!><time="08:36:43.599+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="utils.cpp:1851">
    <![LOG[Updated security on object D:\_SMSTaskSequence.]LOG]!><time="08:36:43.615+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="utils.cpp:1815">
    <![LOG[Updating the local data path in the Task Sequencing Environment.]LOG]!><time="08:36:43.615+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="tsmbootstrap.cpp:659">
    <![LOG[Reading  logging settings from TS environment to set TS logging]LOG]!><time="08:36:43.615+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="tslogging.cpp:2555">
    <![LOG[Process completed with exit code 2147500037]LOG]!><time="08:40:54.375+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="commandline.cpp:1124">
    <![LOG[Exiting with return code 0x80004005]LOG]!><time="08:40:54.375+480" date="04-07-2016" component="TSMBootstrap" context="" type="1" thread="2008" file="tsmbootstrap.cpp:1258">
    <![LOG[Used smsts.ini to set logging settings.]LOG]!><time="08:40:54.438+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2792" file="tslogging.cpp:1457">
    <![LOG[==========[ TsProgressUI started in process 2788 ]==========]LOG]!><time="08:40:54.438+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2792" file="winmain.cpp:330">
    <![LOG[Unregistering COM classes]LOG]!><time="08:40:54.438+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2792" file="winmain.cpp:204">
    <![LOG[Shutdown complete.]LOG]!><time="08:40:54.438+480" date="04-07-2016" component="TsProgressUI" context="" type="1" thread="2792" file="winmain.cpp:512">

     
    Thursday, April 7, 2016 7:07 AM
  • I suspect this failure caused by hardware, can someone give me some clue? thanks!
    Friday, April 8, 2016 10:29 AM