locked
I'm having problems installing my client via group policy. RRS feed

  • Question

  • Hi,

    I'm having problem installing my client via GP.

    I've created a GPO and set CCMSetup.msi to install under the computer software installation.

    When the PC starts I see the startup message saying, Installing managed software ConfigMgr Client Setup Bootstrap.

    But when I login nothing happens.

    I can't see CCMSetup.exe or CCMExec running in Task Manager.

    I've still got the firewall on and I haven't created any exceptions. Neither do I have a client install account setup.

    I take it that CCMSetup.msi installs under the System account.

    What could be wrong?

    Thanks



    • Edited by midi25 Saturday, January 26, 2013 1:49 PM
    Saturday, January 26, 2013 1:42 PM

All replies

  • What is the Event viewer saying?

    If the installation started you should have a logfile in C:\windows\CCMsetup that you could go trough as well 

    Saturday, January 26, 2013 2:39 PM
  • Hi,

    Check if the installation created a log file for ccmsetup.log under c:\windows\ccmsetup. Have you created a boundary and a boundary Group? ccmsetup will download the rest of the binaries from a DP assigned to boundary Group.

    regards,
    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec

    Saturday, January 26, 2013 2:41 PM
  • Hi,

    I can install it by going to my share and manually running CCMSetup.msi.

    eg: \\siteserver\client and running the CCMSetup.msi that I placed in there.

    But for some reason it will not do it by policy.

    I have noticed this message in the Event Log of my workstation.

    The installation of the ConfigMgr Client Setup Bootstrap from policy Client Install failed. The error was : The installation source for this product is not available. Verify that the source exists and that you can access it.

    The source does exist but I don't know why it can't be accessed.  

    Saturday, January 26, 2013 3:51 PM
  • What permission did you give the Files and share?

    Remember that the GPO will use the Computer account to access anything remote from itself.


    http://www.enhansoft.com/

    Saturday, January 26, 2013 4:11 PM
  • Hi Garth,

    I found this article about the problem http://support.microsoft.com/kb/278472

    So I went back to the share and set the following.

    Share permissions - Domain Computers - Full Control

    NTFS permissions - Domain Computers - Full Control

    I'm trying to get this working on XP SP3.

    And it's still not working.

    I keep getting the same error messages in the event lot.

    Application Management Event ID 102.

    Saturday, January 26, 2013 4:57 PM
  • For a test, I would try everyone Full for both the file and share.


    http://www.enhansoft.com/

    Saturday, January 26, 2013 5:21 PM
  • I can't work this out.

    I've applied full control to the domain computers and everyone group.

    At the share and file level.

    Then I got a message about fast user logon so I read up on this http://msdn.microsoft.com/en-gb/library/windows/desktop/aa374350(v=vs.85).aspx

    I enabled the option to always wait for the network at startup or user login.

    And I'm still getting the same Application 108 error event.

    This must work on XP.

    Saturday, January 26, 2013 5:54 PM
  • Personally I don't use GPO deployment, I only use Push or install the client as part of a Task Sequence.

    http://www.enhansoft.com/

    Saturday, January 26, 2013 6:19 PM
  • I,m trying out all the methods.

    I like push but I can't get it to install with Windows Firewall on.

    This could be an XP thing. But seeing as XP will be around in the workplace for some time, I need to figure out how to resolve these issues and get the CCM Client on the machines.  

    My understanding of this problem is.

    Software installation installs in the foreground before the login screen comes up. So one would assume that the network connection is already present for this to happen. Or else it would fail.

    The account that it uses is the local system or computer account of the workstation. So in order to invoke the CCMSetup.msi, that account needs read access to the share on the server.

    I've allowed the domain computer group access to the share and the permission to run the associated files.

    So in theory this should work.

    As suggested, I set the option to wait for a network connection to become present so I think I've covered all the avenues.

    I'm going to try the same method on a Win 7 machine and see how I get on.

    It's frustrating because I want to get it working on XP.

    Thanks

     

    Saturday, January 26, 2013 10:58 PM