none
Task creation error on Windows 2008 Server x64 when "Windows Server 2003, Windows XP, or Windows 2000" was choosed

    Question

  • Hi,

    I want to make a same task for the clients Windows XP SP3,  Windows Vista, Windows 7, Windows 8.1 and Windows 10.
    But I have a problem with Scheduled Task setting in GPO on the Windows 2008 R2 x64 Server.

    In General tab of a Scheduled Task setting, I choosed "Windows Server 2003, Windows XP, or Windows 2000" for "Configuration for" to create the task.
    But the task was not created Windows XP SP3 and any clients after GPO was updated.

    Is this in the specifications?
    Does anyone know the reason?

    Wednesday, December 28, 2016 7:11 AM

Answers

  • >> When I asked this question, I was using security filtering for only the Group which consist of only computers.
    >Just to make sure - the computer is a member of that group? And you rebooted the computer after adding it to the group?

    Yes, the computer is a member of that group and I rebooted the computer.

    >> But the tasks for "Windows Server 2003, Windows XP, or Windows 2000" for "Configuration" was not created.
    >And the computer is running one of these OSes?
    Yes.

    By the way, I found the link below that have a explanation of "Configure for".
    I took "Configure for" meaning the wrong way.
    It means we can restrict the options displayed to those that are also available in previous operating systems.
    ------------------------------------------------------------------------------------------------------------
    [Configure a Scheduled Task Item (At least Windows 7)]
    https://technet.microsoft.com/en-us/library/dd851678(v=ws.11).aspx

    - Configure for -
    For computers that are running Windows Server 2008 R2, Windows 7, Windows Server 2008, or Windows Vista, you can restrict the options displayed to those that are also available in previous operating systems. Doing this does not configure the task or the preference item to run on earlier operating systems.
    ------------------------------------------------------------------------------------------------------------

    Not to be created a task is strange, But I don't pursue the question more.
    In order to cope with this issue, I decided to create two tasks.
    These tasks worked. 

    One is for OSes "Windows XP" and "Windows Vista".
    I use "Scheduled Task" setting in https://technet.microsoft.com/en-us/library/cc725745(v=ws.11).aspx .

    And the other is for OSes "Windows 7 and later".
    I use "Scheduled Task (Windows Vista and later)" 
    which have the setting "Windows Vista or Windows Server 2008" for "Configure for"
    in https://technet.microsoft.com/en-us/library/dd851678(v=ws.11).aspx .

    So, I close this question.
    Martin, thank you very much!

    • Marked as answer by ndevel Friday, January 06, 2017 12:24 PM
    Friday, January 06, 2017 12:23 PM

All replies

  • > Does anyone know the reason?
     
    No, nobody does right now. Is your GPO applied at all? Is it a task in computer or user configuration? Is it security filtered to a group? Is the user/computer in that group? Are you aware of the issues with MS16-072?
     
    Wednesday, December 28, 2016 10:02 AM
  • Hi,
    Good start to troubleshoot as Martin suggested, before we go further, please run gpresult /r command to check if the GPO is applied to clients successfully. If not, you could check the following article for common reasons to try troubleshooting:
    10 Common Problems Causing Group Policy To Not Apply
    http://social.technet.microsoft.com/wiki/contents/articles/22457.10-common-problems-causing-group-policy-to-not-apply.aspx
    And about MS16-072 issue, you could check if MS16-072 is installed on clients and domain controllers which might cause user group policy not working, if that is the case, please use the Group Policy Management Console (GPMC.MSC) and add the Authenticated Users group with Read Permissions on the Group Policy Object (GPO). If you are using security filtering, add the Domain Computers group with read permission. Please see: https://support.microsoft.com/en-sg/kb/3163622
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 29, 2016 2:35 AM
    Moderator
  • Thanks for your reply.

    I'm sorry for not replying sooner.
    Let me confirm.
    Wednesday, January 04, 2017 12:09 AM
  • Thanks for your reply.

    I'm sorry for not replying sooner.
    I will check the details.
    Wednesday, January 04, 2017 12:15 AM
  • The task is in computer configuration.
    I checked gpresult /r and found GPO was applied to clients successfully.

    When I asked this question, I was using security filtering for only the Group which consist of only computers.
    To resolve MS16-072 issue, I added each "Authenticated Users", "Domain Computers" and both with Read Permissions on the GPO.
    But the tasks for "Windows Server 2003, Windows XP, or Windows 2000" for "Configuration" was not created.

    Are there any considerations for this problem?
    Wednesday, January 04, 2017 2:42 AM
  • > When I asked this question, I was using security filtering for only the Group which consist of only computers.
     
    Just to make sure - the computer is a member of that group? And you rebooted the computer after adding it to the group?
     
    > But the tasks for "Windows Server 2003, Windows XP, or Windows 2000" for "Configuration" was not created.
     
    And the computer is running one of these OSes?
     
    • Marked as answer by ndevel Friday, January 06, 2017 12:24 PM
    • Unmarked as answer by ndevel Friday, January 06, 2017 12:24 PM
    Wednesday, January 04, 2017 10:58 AM
  • >> When I asked this question, I was using security filtering for only the Group which consist of only computers.
    >Just to make sure - the computer is a member of that group? And you rebooted the computer after adding it to the group?

    Yes, the computer is a member of that group and I rebooted the computer.

    >> But the tasks for "Windows Server 2003, Windows XP, or Windows 2000" for "Configuration" was not created.
    >And the computer is running one of these OSes?
    Yes.

    By the way, I found the link below that have a explanation of "Configure for".
    I took "Configure for" meaning the wrong way.
    It means we can restrict the options displayed to those that are also available in previous operating systems.
    ------------------------------------------------------------------------------------------------------------
    [Configure a Scheduled Task Item (At least Windows 7)]
    https://technet.microsoft.com/en-us/library/dd851678(v=ws.11).aspx

    - Configure for -
    For computers that are running Windows Server 2008 R2, Windows 7, Windows Server 2008, or Windows Vista, you can restrict the options displayed to those that are also available in previous operating systems. Doing this does not configure the task or the preference item to run on earlier operating systems.
    ------------------------------------------------------------------------------------------------------------

    Not to be created a task is strange, But I don't pursue the question more.
    In order to cope with this issue, I decided to create two tasks.
    These tasks worked. 

    One is for OSes "Windows XP" and "Windows Vista".
    I use "Scheduled Task" setting in https://technet.microsoft.com/en-us/library/cc725745(v=ws.11).aspx .

    And the other is for OSes "Windows 7 and later".
    I use "Scheduled Task (Windows Vista and later)" 
    which have the setting "Windows Vista or Windows Server 2008" for "Configure for"
    in https://technet.microsoft.com/en-us/library/dd851678(v=ws.11).aspx .

    So, I close this question.
    Martin, thank you very much!

    • Marked as answer by ndevel Friday, January 06, 2017 12:24 PM
    Friday, January 06, 2017 12:23 PM