locked
Please help - VerifyWUServerURL() failed with hr=0x80072ee6 RRS feed

  • Question

  • Hello !

    I am having a strange problem on the client side.
    The situation:
    Clean install WSUS 3.2 on Windows 2008 R2
    Clean install SCCM SP R2 Windows 2008 R2

    Clean install client Windows 7

    I get this message on the client: (also tried another machine)
    If I paste  http://TST-WSUSV00/selfupdate/wuident.cab in the explorer, I can download the cab file without any problem.
    While testing all Firewalls are OFF
    See the error and diagnostic output below.


    WARNING: DownloadFileInternal failed for  http://TST-WSUSV00/selfupdate/wuident.cab: error 0x80072ee6
    2010-02-15 10:46:15:945  920 f44 Setup WARNING: SelfUpdate check failed to download package information, error = 0x80072EE6
    2010-02-15 10:46:15:945  920 f44 Setup FATAL: SelfUpdate check failed, err = 0x80072EE6
    2010-02-15 10:46:15:945  920 f44 Agent   * WARNING: Skipping scan, self-update check returned 0x80072EE6
    2010-02-15 10:46:15:945  920 f44 Agent   * WARNING: Exit code = 0x80072EE6




    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is not running. PASS
            Wuaueng.dll version 7.3.7600.16385. . . . . . . . . . . PASS
                    This version is WSUS 2.0

    Checking AU Settings
            AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
                    Option is from Control Panel

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                    User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                    User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
                    WUServer =  http://TST-WSUSV00
                    WUStatusServer =  http://TST-WSUSV00
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    VerifyWUServerURL() failed with hr=0x80072ee6

    The URL does not use a recognized protocol


    Thank you in advance!
    Hanna

    Monday, February 15, 2010 9:51 AM

Answers

  • Hi Bechir,

    I have tried it too, see :
    2010-02-15 12:16:55:658  920 fb8 Misc WARNING: DownloadFileInternal failed for  http://TST-WSUSV00.tst-campus.uvt.nl:80/selfupdate/wuident.cab: error 0x80072ee6

    BUT I HAVE SOLVED IT  :-D

    What I did is :
    1.Unlinked policy
    2.Created local policy with Gpedit with the same settings
    3. IT WORKED

    I wanted to investigate why is this happening.
    I have reverted to prevoius snaphot of my Windows 7 VM. (! the one I wast testing was just a one day old snapshot of the same machine!)
    I have linked the policy again.
    IT WORKED

    In other words I cannot explain what was wrong. With the same GPO settings and the same server settings - it did not work in a clean environment.

    Thank you very much for your support !

    PS. Nou I am going to follow your walkthrough to configure my updates :-)

    Greetings,
    Hanna



    • Marked as answer by Hana_hanna Thursday, August 12, 2010 7:05 AM
    Monday, February 15, 2010 4:06 PM

All replies

  • Hi,

    if you have configured WSUS to use port 8530 use must declare it on WSUS GPO, for exemple : http://TST-WSUSV00:8531

    But If you will use ConfigMgr to update machines, so you don't need to configure WSUS & GPO : http://www.windows-noob.com/forums/index.php?/topic/624-configuring-software-update-point-within-sccm/ 


    Thank's.
    Bechir Gharbi. MCP, MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront
    Monday, February 15, 2010 10:30 AM
  • Hi Bechir,

    The WSUS server is installed on the other machine than SCCM server therefore I can use port 80.
    As I have mentioned this is not a question of mistyping because it works perfectly when typed in the browser.

    What I actually want is to install SCCM client accordingly to MS article:
    How to Install Configuration Manager Clients Using Software Update Point Based Installation<!---->
    http://technet.microsoft.com/en-us/library/bb633194.aspx

    I do not deploy updates yet.

    Any idea???

    Thank you!

    Hanna

    Monday, February 15, 2010 10:38 AM
  • Hi,

    in WSUS GPO you must enter the FQDN WSUS Name, for exemple : http://MYWSUS.MyDomain.com


    You can also see these link :

    http://www.wsus.info/index.php?showtopic=6112
    http://social.technet.microsoft.com/Forums/en/configmgrsum/thread/2d751e0a-ddc7-489e-9318-05bda29ad7d1

    Thank's.



    Bechir Gharbi. MCP, MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront
    Monday, February 15, 2010 11:47 AM
  • Hi Bechir,

    I have tried it too.....  :-(

    : WinHttp: WinHttpCrackUrl failed. error 0x80072ee6
    2010-02-15 12:16:55:658  920 fb8 Misc WARNING: WinHttp: Initialize failed with 0x80072ee6
    2010-02-15 12:16:55:658  920 fb8 Misc WARNING: DownloadFileInternal failed for  http://TST-WSUSV00.tst-campus.uvt.nl:80/selfupdate/wuident.cab: error 0x80072ee6
    2010-02-15 12:16:55:658  920 fb8 Setup WARNING: SelfUpdate check failed to download package information, error = 0x80072EE6
    2010-02-15 12:16:55:658  920 fb8 Setup FATAL: SelfUpdate check failed, err = 0x80072EE6
    2010-02-15 12:16:55:658  920 fb8 Agent   * WARNING: Skipping scan, self-update check returned 0x80072EE6
    2010-02-15 12:16:55:658  920 fb8 Agent   * WARNING: Exit code = 0x80072EE6
    Monday, February 15, 2010 11:57 AM

  • The most of error hr=0x80072ee6 are caused by misconfigured URL setting.


    WUServer =  http://TST-WSUSV00
    WUStatusServer =  http://TST-WSUSV00

    The url should be FQDN of your WSUS server with port number on GPO
    Bechir Gharbi. MCP, MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront
    Monday, February 15, 2010 12:40 PM
  • Hi Bechir,

    I have red almost all postings available concerning this issue.

    No it is not misconfiguration since I can paste the URL in the browser and it works without any problems.
    I am sure the URL is configured properly.

    see in my previous post:
     http://TST-WSUSV00.tst-campus.uvt.nl:80/selfupdate/wuident.cab
    does'n work either.

    I have tried everything, IP adresses, FQDN, port number - any possible syntax.
    All of it works in the browser !

    Hanna

    Monday, February 15, 2010 1:02 PM
  • Hi,

    Please, on WSUS GPO try to use FQDN Name of WSUS with port number http://TST-WSUSV00.tst-campus.uvt.nl:80
    Force GPO and give me the result of WSUS Client Diagnostics Tool and WindowsUpdate.log










    Bechir Gharbi. MCP, MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront
    Monday, February 15, 2010 3:56 PM
  • Hi Bechir,

    I have tried it too, see :
    2010-02-15 12:16:55:658  920 fb8 Misc WARNING: DownloadFileInternal failed for  http://TST-WSUSV00.tst-campus.uvt.nl:80/selfupdate/wuident.cab: error 0x80072ee6

    BUT I HAVE SOLVED IT  :-D

    What I did is :
    1.Unlinked policy
    2.Created local policy with Gpedit with the same settings
    3. IT WORKED

    I wanted to investigate why is this happening.
    I have reverted to prevoius snaphot of my Windows 7 VM. (! the one I wast testing was just a one day old snapshot of the same machine!)
    I have linked the policy again.
    IT WORKED

    In other words I cannot explain what was wrong. With the same GPO settings and the same server settings - it did not work in a clean environment.

    Thank you very much for your support !

    PS. Nou I am going to follow your walkthrough to configure my updates :-)

    Greetings,
    Hanna



    • Marked as answer by Hana_hanna Thursday, August 12, 2010 7:05 AM
    Monday, February 15, 2010 4:06 PM