locked
WSUS post-installation fails Access Denied to Update Services RRS feed

  • General discussion

  • We are experiencing the exact same error as this site posted here: https://social.technet.microsoft.com/Forums/windowsserver/en-US/46cb543a-20b8-4741-9ee5-b734b3524cb2/wsus-unable-to-complete-post-installation?forum=winserverwsus

    FixSubscriptionCategories failed. Exception: System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.TypeInitializationException: The type initializer for 'Microsoft.UpdateServices.Internal.ApiRemoting' threw an exception. ---> System.UnauthorizedAccessException: Access to the path 'Update Services' is denied.

    I have tried multiple times to uninstall WSUS, IIS, WID, Folder structure, remove WSUS administration site, etc... nothing has worked so far. Also getting BPA analyzer warning about SelfHelp folder is not configured properly. Please help!!

    Windows Server 2012 R2, SCCM 2012 R2, WSUS 6.9.6300 ? 

    Sunday, August 2, 2015 7:28 PM

All replies

  • Has it ever worked correctly?
    Was there some kind of event (crash or server,or, installation of some other software) which led to this?
    Are there other health issue with the server?

    Have you tried dism /online /checkhealth etc ?


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Sunday, August 2, 2015 9:24 PM
  • I did struggle when i tried to update the SCCM version from SP1 to R2. At one point had to recover from a backup. I was thinking of trying the DISM but have not yet.
    Wednesday, August 5, 2015 12:58 PM