locked
MOSS 2007 IIS logs. RRS feed

  • Question

  • Hi,

    My IIS logs getting deleted automatically, only 7 days logs are getting saved, remaining logs getting deleted automatically. Could someone help me on IIS logs to save before 3 months to today's date.

    Thanks


    Badri

    Wednesday, January 7, 2015 9:11 AM

Answers

  • Hi,

    There was an script scheduled and account used was expired. that was the malfunction happened and job was failing continuously. After changing the account, it was working as expected.

    Thanks


    Badri

    • Marked as answer by Badrinarayana Monday, January 12, 2015 4:44 AM
    Monday, January 12, 2015 4:44 AM

All replies

  • Hi Badri,

    IIS Logs can be cleaned up in different ways. As you said it is deleting automaitcally older than 7 days, it means one among the below options was configured already in your server. You need find out which it is and change the respective settings accordingly.

    1) Check if any  script is running in the server at scheduled interval.

    To check this option Login to  the corresponding Server and check any script is scheduled in the "Task Scheduler" to delete the logs.If yes, check the command written to delete the logs at specific interval and change per your requirement.

    2) Check if any a log cleaner tool is configured in the server

    For example, IIS Log Cleaner Tool. If this was configured already in the server then change duration in the 'settings' file.

    You can refer below link to get more information on the above process.

    http://www.iis.net/learn/manage/provisioning-and-managing-iis/managing-iis-log-file-storage

    **************************

    Please remember to mark your question as answered & Vote helpful,if this solves/helps your problem.

    Best Regards,

    Pavan Kumar Sapara


    s p kumar

    Thursday, January 8, 2015 6:44 AM
  • Hi,

    There was an script scheduled and account used was expired. that was the malfunction happened and job was failing continuously. After changing the account, it was working as expected.

    Thanks


    Badri

    • Marked as answer by Badrinarayana Monday, January 12, 2015 4:44 AM
    Monday, January 12, 2015 4:44 AM