locked
I found a bug with Vista and pre-Vista DirectX program RRS feed

  • Question

  • Yep.  I just found a bug.  Vista now allocated Shard Video Memory to increase the total available memory to the graphic card.  I just add 2 GB of memory yesterday in my computer, bringing it to 4 GB.  The shared video memory is now 1535 MB and my video card has 640 MB (it's a nVidia 8800 GTS), making a total of 2175MB of total video memory.

     

    Now, some software first verifies how much memory your graphic card has before starting, to ensure there is plenty for what they are supposed to do.  Now if you take 2175 MB and transform it into byte, you have 2 280 652 800 bytes available.  Now the maximum value of a signed 32 bits integer is 2 127 483 648.  Higher number goes into negative.  So now, when a software receives 2 280 652 800 bytes available of memory, it's understood has a negative number (it's an integer overflow).  The software now reports that there is not enough memory and stops.

     

    Obviously, DirectX 10 does not take that into account when handling DirectX 9 title.  The total memory value should never exceed the maximum value of a 32bits integer, which in my case happens.

     

    Microsoft needs to patch this to allow old software to continue to work.

     

    Eric.

    Thursday, January 24, 2008 2:42 AM

Answers

  • Hi Eric,

     

    Thanks for your post!

     

    I agree that the memory address space may be limited by 32-bit hardware environment in some scenarios. Please enable PAE to see if this feature makes any difference:

     

    Right-click Command Prompt and select Run as administrator, and then type the following command and press Enter:

     

    BCDEDIT /SET PAE ForceEnable

     

    For more information about enabling PAE, please refer to the KB article below:

     

    (KB929580) Windows Vista or Windows Server 2003 may report less memory than you expect

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;929580

     

    Please let me know the result. Thanks!

     

    Besides, please help us know more about this issue. Making some screenshots to clarify it is much preferred. For your convenience, I have created a workspace for you. You can upload the information files to the following link.  (Please choose "Send Files to Microsoft")

     

    Workspace URL: (https://sftasia.one.microsoft.com/choosetransfer.aspx?key=801d5e23-8cdd-407c-baaf-67d89984e826)

    Password: $#Aq!ebG98l+Q6

     

    Note: Due to differences in text formatting with various email clients, the workspace link above may appear to be broken.  Please be sure to include all text between '(' and ')' when typing or copying the workspace link into your browser.

     

    Thanks for your cooperation again, Eric!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Monday, January 28, 2008 9:06 AM