none
DPM 2012 SP1 agent upgrade RRS feed

  • Question

  • ok so we have two backup boxes. A 2010 DPM and a 2012 SP1 DPM.

    We are migrating our backups from 2010 to 2012. On a client i uninstalled the agent and tried to manually install the 2012 SP1 agent and i get the error

    "Microsoft System Center 2012 SP1 DPM Protection Ag..."

    "Protection Agent cannot be Installed on a machine where DPM is installed"

    What is going one here?

    i have uninstalled the 2010 agent.

    Friday, January 18, 2013 4:19 PM

All replies

  • Info from MSDPMAgentInstall

    Action ended 10:54:55: WindowsFolder.88BD42D4_8EBE_4E98_B407_81775C1F7E9C. Return value 1.
    MSI (c) (40:DC) [10:54:55:393]: Doing action: AppSearch
    MSI (c) (40:DC) [10:54:55:393]: Note: 1: 2205 2:  3: ActionText 
    Action 10:54:55: AppSearch. Searching for installed applications
    Action start 10:54:55: AppSearch.
    AppSearch: Property: NET20INSTALLVALUE, Signature: NET20Install
    MSI (c) (40:DC) [10:54:55:393]: Note: 1: 2262 2: Signature 3: -2147287038 
    MSI (c) (40:DC) [10:54:55:393]: PROPERTY CHANGE: Adding NET20INSTALLVALUE property. Its value is '#1'.
    Action ended 10:54:55: AppSearch. Return value 1.
    MSI (c) (40:DC) [10:54:55:393]: Doing action: LaunchConditions
    MSI (c) (40:DC) [10:54:55:393]: Note: 1: 2205 2:  3: ActionText 
    Action 10:54:55: LaunchConditions. Evaluating launch conditions
    Action start 10:54:55: LaunchConditions.
    MSI (c) (40:98) [10:54:55:408]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

    Protection Agent cannot be Installed on machine where DPM is installed
    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 2205 2:  3: Error 
    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
    MSI (c) (40:DC) [10:54:58:033]: Product: Microsoft System Center 2012 SP1 DPM Protection Agent -- Protection Agent cannot be Installed on machine where DPM is installed

    === Logging stopped: 1/18/2013  10:54:58 ===
    MSI (c) (40:DC) [10:54:58:033]: Product: Microsoft System Center 2012 SP1 DPM Protection Agent - Update 'Microsoft System Center DPM Protection Agent Update - KB2791508' could not be installed. Error code 1603. Additional information is available in the log file C:\Windows\Temp\MSDPMAgentInstall.LOG.

    MSI (c) (40:DC) [10:54:58:033]: Windows Installer installed an update. Product Name: Microsoft System Center 2012 SP1 DPM Protection Agent. Product Version: 4.1.3322.0. Product Language: 1033. Manufacturer: Microsoft Corporation. Update Name: Microsoft System Center DPM Protection Agent Update - KB2791508. Installation success or error status: 1603.

    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 1708 
    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 2205 2:  3: Error 
    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1708 
    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 2205 2:  3: Error 
    MSI (c) (40:DC) [10:54:58:033]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
    MSI (c) (40:DC) [10:54:58:033]: Product: Microsoft System Center 2012 SP1 DPM Protection Agent -- Installation failed.

    MSI (c) (40:DC) [10:54:58:033]: Windows Installer installed the product. Product Name: Microsoft System Center 2012 SP1 DPM Protection Agent. Product Version: 4.1.3322.0. Product Language: 1033. Manufacturer: Microsoft Corporation. Installation success or error status: 1603.

    MSI (c) (40:DC) [10:54:58:096]: Grabbed execution mutex.
    MSI (c) (40:DC) [10:54:58:096]: Cleaning up uninstalled install packages, if any exist
    MSI (c) (40:DC) [10:54:58:096]: MainEngineThread is returning 1603
    === Verbose logging stopped: 1/18/2013  10:54:58 ===


    Friday, January 18, 2013 4:56 PM
  • Hi

    Did you reboot after you uninstalled the Agent? You can check that the windows installer service is set to manual and not disabled.

    You can also look at the steps on the top of this page below:

    http://systemscenter.ru/dpm_help.en/html/c45b26da-997f-4d14-81a3-39f3ddadd68c.htm

    Friday, January 18, 2013 7:20 PM
  • Yes several times. The services is set to manual. I have done this a lot with 2007 and 2010. I am stumped here. I must be do something silly.

    *EDIT*

    I can re-install the old agent just fine(2010) from the old server.


    • Edited by JustusIV Friday, January 18, 2013 8:28 PM
    Friday, January 18, 2013 8:21 PM
  • Just a thought...

    I had a problem with one computer. I ended up uninstalling the agent and then deleting the folder out of the Program Files directory (there were still some files hanging around in there), Rebooted and the install completed fine.

    Friday, January 18, 2013 8:30 PM
  • Just a thought...

    I had a problem with one computer. I ended up uninstalling the agent and then deleting the folder out of the Program Files directory (there were still some files hanging around in there), Rebooted and the install completed fine.

    I have not tried this but all that was left from the uninstall was some log files.
    • Proposed as answer by Nicklas. _ Friday, August 16, 2013 2:42 PM
    Friday, January 18, 2013 11:02 PM
  • Ok i tried your suggestion same result.

    "Protection Agent cannot be Installed on machine where DPM is installed"

    Can someone maybe explain upgrade procedures here?

    I have "ServerDPM2010" which is the old server. Then i have "ServerDPM2012sp1" and my "ClientA"

    I am wanting to move from the ServerDPM2010 to ServerDPM2012sp1 but just uninstalling and trying to install the 2012 agent is where i am having problems.

    *EDIT*

    Oh I am trying to install by hand doing this.

    Mapping to \\ServerDPM2012sp1\c$

    and installing the agent from the mapped drive.

    *EDIT2*

    So i decided to try it through the gui and get this message

    Install protection agent on CODWEBDEV.xyz.medforest.org failed:
    Error 337: You cannot install the protection agent on CODWEBDEV.xyz.medforest.org because access to the computer has been denied.
    Recommended action: Do the following to troubleshoot this issue: 
    1) If another DPM server is currently protecting CODWEBDEV.xyz.medforest.org use that DPM server to uninstall the protection agent from CODWEBDEV.xyz.medforest.org. Then, use this DPM server to install the protection agent on CODWEBDEV.xyz.medforest.org.
    2) Verify that the time on the DPM server and the selected computer is synchronized with the domain controller. At a command prompt, type "net time /set" to synchronize the time with the domain controller.
    3) If the computer is a domain controller, verify that the primary domain controller (the PDC Emulator) is running Windows Server 2003 with Service Pack 1 (SP1), and that Active Directory has completed replication between the domain controllers since the Windows Server 2003 SP1 installation.

    *EDIT3*

    OMG i got it to work so after i got that message i did what WSampson suggested. Deleting the old folder and rebooting and it worked. This has to be a bug of some sort

    *EDIT4*

    Ok so i can pull this off now without the reboot, however when i have to delete the folder it says DPMRA has a lock on a file that clears itself after a while. Or at least it did on the last machine i did.

    *EDIT5*

    Ok just compiling information, you don't have to delete the folder but you do have to wait till the DPMRA goes away :)

    So pretty much i was having the issues i was because i was trying to manually do this. Not sure what the difference is. 


    • Edited by JustusIV Tuesday, March 26, 2013 8:13 PM
    Tuesday, January 22, 2013 2:46 PM