none
System Center 2012 R2 DPM - SMTP Issue - Reporting Services Server cannot connect to the DPM database. ID: 3001 RRS feed

  • Question

  • Getting the following message when attempting to setup E-mail alerts for DPM 2012 R2 reports:

    "Reporting Services Server cannot connect tot he DPM database.

    To repair the configuration, follow steps for repairing DPM from DPM Setup Help.

    ID: 3001"

    Each of the SRS reports work when they are executed.  The error only appears when attempting to set the E-Mail alerts via the DPM 2012 R2 console.

    Sunday, October 27, 2013 4:38 PM

All replies

  • I have the same problem. At the same version of the MSSQL 2012SP1 CU2 version of DPM 2012 SP1  everything  work fine . Not help install CU6 on MSSQL 2012SP1. I think the problem is in DPM2012R2. In this case, I have a clean installation.
    • Edited by p.harlamov Wednesday, November 6, 2013 2:54 PM
    Wednesday, November 6, 2013 2:52 PM
  • I have the same problem. At the same version of the MSSQL 2012 SP1 version of DPM 2012 R2  everything  work fine .  I think the problem is in DPM2012R2.
    Thursday, November 7, 2013 1:18 PM
  • I'm also seeing this exact same issue.

    In previous upgrades I've seen the email reporting break so wasn't too surprised. Previously though it's been because the upgrade process has spawned a new SQL instance / DB (can't remember which) for the specific version, so it was simply a case of updating reporting services to point to the new db and resetting the email settings in there, but not in this case.

    It would be nice if the error at least linked to "DPM Setup Help" as well, since thus far I've failed to find it (most articles seem to relate to 2010 or 2012), or at least find anything that looked vaguely useful. 

    Thursday, November 7, 2013 4:26 PM
  • I am having the same issue since upgrading to from SP1 to R2. It to me it is a bug in R2. I past upgrades it was normal to have to reschedule reports or re-enter the smtp service info, but I am not able to do this in this release. Hopefully a solution can be found soon.

    This is also happening in a fresh/clean install of DPM 2012 R2 that I setup in a VM just for testing this. 

    I can run the reports manually, just can't schedule them.

    • Edited by JohnnyGun Friday, November 8, 2013 4:32 PM
    Friday, November 8, 2013 4:28 PM
  • I have the same problem! Any help from DPM developer team?

    • Edited by PRND Monday, November 18, 2013 9:51 AM
    Monday, November 18, 2013 9:51 AM
  • Same problem here - where are you at Microsoft. Please stop releasing half baked products on us like this!
    Wednesday, November 20, 2013 12:34 AM
  • Hi all,

    yes this is a Problem in R2 if the SQL Server are local installed. To Resolve the Problem follow the steps:

    1: Open the Report Manager URL page and Login like http://ServerName/Reports

    2: Open the Folder DPMReports_......

    3: Open the DPMReporterDataSource

    4: Change the Connect using to

     (x) Credentials stored securely in the Report Server, and specific a user and pw that have DPM DB Access on the SQL Server.

     (x) Use as Windows credentials when connectin to the data source

    5: Test connection

    6: Apply

    After this you can schedule Repots in DPM 2012 R2 sucessfully.

    Regards Steven

    • Proposed as answer by Stivie Thursday, November 28, 2013 12:25 PM
    Thursday, November 28, 2013 12:23 PM
  • I think that's not the only bug. I have documented the issue I'm having with SMTP notifications here:

    http://social.technet.microsoft.com/Forums/en-US/ad8756ed-abe9-4f25-bfa3-22fd48dda9ae/setting-up-notifications-on-dpm-2012-r2?forum=dpmsetup

    If you have any ideas, would be much appreciated.

    Thank you,


    MCITP, MCSE, MCTS

    Friday, November 29, 2013 4:16 PM
  • Hi In my situation SQL also locally installed. Having the same problem. Tried the above resolution by following below mention article.

    http://blogs.technet.com/b/dpm/archive/2013/12/05/attempts-to-schedule-a-mailed-report-in-dpm-2012-fail-with-reporting-services-server-cannot-connect-to-the-dpm-database.aspx

    Only one report received after that same problem. This is really frustration since this is the second time of DPM setup @ customer site. All are fresh installations of DPM 2012 R2 with SQL 2012 SP1.

    According to the above mention article there we have to carry out significant changes and now worries reverting back will break the system. Seems like this is a known issue only with a workaround which has no gurantee either. DPM Team we need little bit more support than this!

    Regards,
    Susantha

    Wednesday, February 12, 2014 1:38 AM
  • I realize this is an old thread, but I'm having the same problem after upgrading from DPM 2012 SP1, using the existing local DB. I've tried the fixes in the linked articles above, but when I open the Reporting Services Manager URL, it says "There are no items in Home.  Click Help for more information about this page."

    Any suggestions would be appreciated.

    Thanks,

    John

    Tuesday, December 29, 2015 5:07 PM
  • From time to time the DPM install won't setup the Report service correct.

    The user/group (static user or group with "Logged in user") that you want to use for connecting to the HTTP service (SSRS), could be that you are missing to setup the SSRS (For this you have to use "Reporting Service Configuration Manager") to add the user and/or group with the correct permissions, before your setting up the Reports under http://localhost/reports (the correct URL is located in your IIS).
    After the config of SSRS (SQL Server Reporting Service), then you have to configure the DataSource.

    Use this guide:
    http://www.ms4u.info/2014/01/reporting-services-server-cannot.html 

    Have a nise day y'all :)


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Saturday, January 9, 2016 12:30 PM