locked
App-V 5.0 Beta publishing server RRS feed

  • Question


  • App-V 5.0 Beta publishing server


    I'm currently testing App-V 5.0 beta Server  and I have an issue with the publishing server.
    I cannot not sync my client to it.In Client system not loading the app v packages. On the server itself I get the following event log errors:

    I have configured sever Management port is 81 and Server Publishing port is 82.I have disabled firewall.

    In Sever Management logs: 1 log

    1.An error was encountered while trying to add the initial administrators from the file
     C:\programfiles\microsoft application virtualization server\managementservice\admingroup.xnl.
    reason:'thread was being aborted.

    In Server Publishing logs: 2logs

    1:Failed to pre-load publishing metadata. The message:

    The remote server returned an error: (401) Internal Unauthorized.

    2:Failed to refresh publishing metadata. The message:

    The remote server returned an error: (500) Internal Server Error.

    Thanks,

    Nuni


    N R Raju

    Thursday, June 21, 2012 10:34 AM

Answers

  • Hi,

    I have uninstalled and reinstalled APP V 5 server . I have configured  Publishing Server  name is  http://localhost:8889.

    Management server http://appvsrv01.contoso.local:8889

    Publishing server http://appvsrv01.contoso.local:50537

    I have imported the APP V  packages in to the server.But still can not sync my client with the server.In Client system not loading the app v packages.

    Let me know in client system do i need  add  appv 5 server Details.

    I have checked the registry setings. i am not find appv 5 server details.

    Note: I have installed Management & Publishing server and SQL Data base is installed on the same server. I have disabled firewall in server and clietn system.

    Thanks,

    Nuni


    N R Raju

    _____________________________________________________________________

    After APPV 5 client installation. we need enter the follwing  poweshell commands in APP V 5 Client system.

    1)Get-ExecutionPolicy

    2)Set-ExecutionPolicy remotesigned

    3)import-module appvclient

    4) Add-AppVpublishingserver  -name appvserver -URL http://appvsrv.appv.local:50537

    5) Sync-appvpublishingserver

    Then resfres the APP V 5 client. It will load the published packages in the client system.

    Thursday, June 28, 2012 6:25 AM

All replies

  • Hello,

    I suggest you file a bug on Connect

    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, June 24, 2012 9:45 AM
  • Did you install the App-V 5.0 management server and the publishing server on the same server ? If so then you need to configure in the setup of the app-v not to use the app-v netbios name but rather localhost for example

    Management server http://appvsrv01.contoso.local:81

    Publishing server http://appvsrv01.contoso.local:82

    when you configure the publishing server use http://localhost:81 for the management server.

    This is a bug in App-V 5.0 beta, you can check out my first video tutorial on my blog http://appvid.blogspot.com/2012/06/app-v-50-beta-server-install-tutorial.html there is an example how to do it. Notice the message at the top when configuring the server.


    • Edited by Geekman Monday, June 25, 2012 10:05 PM
    • Proposed as answer by Geekman Tuesday, June 26, 2012 12:30 AM
    Monday, June 25, 2012 10:04 PM
  • I forgot that I also posted an blog article about this bug

    http://appvid.blogspot.com/2012/05/problems-app-v-server-50-beta.html

    Monday, June 25, 2012 10:14 PM
  • I"m having the same 401 error.

    I changed the reg key to use localhost:8889 and rebooted but its still not working.

    Wednesday, June 27, 2012 1:00 AM
  • try removing the app-v 5.0 beta and install it again, you should have the http://localhost:8889 in the configuration for the publishing server as seen in the screenshot. Btw, remember to open the port in Firewall and try to telnet to the app-v server, and please make sure you have configured exactly IIS as mentioned in the video if you don´t it will cause some issues that you don´t want.

    Wednesday, June 27, 2012 10:40 PM
  • The SQL is on another box, do I need to remove that and install it again or is uninstalling the management and publishing and re-installing those parts enough?
    Wednesday, June 27, 2012 11:26 PM
  • I have not tried installing it again on preinstalled appv environment, I have always uninstalled the SQL database first and the client, it takes only a few seconds. Well I´m doing this on a vm machines and using snapshots, that makes things very quick.
    Wednesday, June 27, 2012 11:43 PM
  • Hi,

    I have uninstalled and reinstalled APP V 5 server . I have configured  Publishing Server  name is  http://localhost:8889.

    Management server http://appvsrv01.contoso.local:8889

    Publishing server http://appvsrv01.contoso.local:50537

    I have imported the APP V  packages in to the server.But still can not sync my client with the server.In Client system not loading the app v packages.

    Let me know in client system do i need  add  appv 5 server Details.

    I have checked the registry setings. i am not find appv 5 server details.

    Note: I have installed Management & Publishing server and SQL Data base is installed on the same server. I have disabled firewall in server and clietn system.

    Thanks,

    Nuni


    N R Raju

    _____________________________________________________________________

    After APPV 5 client installation. we need enter the follwing  poweshell commands in APP V 5 Client system.

    1)Get-ExecutionPolicy

    2)Set-ExecutionPolicy remotesigned

    3)import-module appvclient

    4) Add-AppVpublishingserver  -name appvserver -URL http://appvsrv.appv.local:50537

    5) Sync-appvpublishingserver

    Then resfres the APP V 5 client. It will load the published packages in the client system.

    Thursday, June 28, 2012 6:25 AM
  • Yes you need to configure the client, check out this video how to configure the client

    http://appvid.blogspot.com/2012/06/application-virtualization-50-beta.html

    basically to to Powershell using "Run as Administrator"


    1. Import-Module AppvClient

    2. Add-AppVPublishingServer -Name AppVPubServer -url http://%servername.domain.local%:%publisherport%

    I have noticed here that I need to restart and or wait for a few minutes until it finishes to do something, then I´m able to sync the publishing server, through the client or through powershell. To do it in powershell you can do.

    3. As you do in 1.

    4. Sync-AppvPublishingServer

    5. Hit enter and press 1 and press enter again, the one is because the publishing server is the first one that was configured.

    If you have disabled the firewall as you say, try to access the management server by typing in from the client http://%yourservername%:%managementportnumber% in Internet Explorer and see if you can access the website. You can also use telnet from the client and see if your server is responding to the ports.


    • Edited by Geekman Thursday, June 28, 2012 8:46 AM
    Thursday, June 28, 2012 8:40 AM