FIM Portal is suddenly not accessible RRS feed

  • Question

  • Up until recently our FIM portal has been working well. However, when I went to use it today I was presented with the IE message "the web page could not be displayed". I took a look at the windows logs and noticed the error “The database WSS_Content on ComputerName\Microsoft##SSEE is not accessible to missing Windows Internal Database signatures”. I then followed the instructions from this page in hopes that the issue would be resolved. The 'fix' didn't fix the issue but it did improve the situation in the fact that I now got an error message in IE indicating some dlls could not be found ( 'Microsoft.IdentityManagement.WebUI.Controls and Microsoft.IdentityManagement.WFExtensionInterfaces). I located these and placed them in a folder that SharePoint (FIM portal) could find. I now get the error “The resource object with key 'JavaScriptDisabledErrorText' was not found.”. I feel like I am going further and further down a rabbit hole. There has got to be a better way to fix this issue. Has anyone else experienced a problem like this before and/or have suggestions on how to get the FIM portal back up and running? Cheers
    Thursday, November 22, 2012 6:57 AM


All replies

  • How about try a FIM portal repair in adding/removing programs?

    Tracy YU

    Sunday, November 25, 2012 5:41 AM
  • Hi Tracy,

    Thanks for the response.  Your solution sounds simple enough.  However, would the repair process cause any of  my FIM Portal configurations to be lost?

    Monday, November 26, 2012 10:27 PM
  • No, repair won't change your esiting configuration.

    Tracy | Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Woggi Tuesday, November 27, 2012 11:38 PM
    • Unmarked as answer by Woggi Tuesday, November 27, 2012 11:39 PM
    Tuesday, November 27, 2012 1:07 AM
  • I tried doing a uninstall/repair but get the error "The web application or web site at http://localhost could not be found.  Please create the web application and web site in http://localhost...".  

    When I try to access http://localhost from IE I get a 403 error.  I am pretty sure that I use to be able to see the default SharePoint site, but not anymore.  Any thoughts I how to get it back?

    • Edited by Woggi Tuesday, November 27, 2012 7:57 PM
    Tuesday, November 27, 2012 7:55 PM
  • I was able to resolve the issue I was having but it required the retraction and removal of microsoftidentitymanagement.wsp, ilmpasswordportal.wsp and microsoftilmportalcommondlls.wsp via SharePoint Central Admin. I also needed to deactivate some hidden features using the deactivatefeature command.  Once this was all done I was able to run the FIM Portal Repair.  I should note that the repair did not complete successfully and reported that a fatal error had occured.  None the less the FIM Portal was once again usable.
    Tuesday, November 27, 2012 11:38 PM
  • I had the same issue. After trying the uninstall / reinstall - which did not work - i tried to run the Sharepoint configuration wizard and it came up with an error that there was an upgrade job in progress.

    Under the timer jobs there was an "Upgrade Job" that was hanging at "initializing".

    After deleting the job in the timer definitions and restarting the Sharepoint timer service everything worked.

    • Proposed as answer by Mr. Moris Tuesday, January 28, 2014 10:23 AM
    • Unproposed as answer by Mr. Moris Tuesday, January 28, 2014 10:23 AM
    Friday, January 24, 2014 3:03 PM