BlackBerry Print To Go Compatibility RRS feed

  • Question

  • Following up on a suggestion from the Microsoft Answers forum, I'm re-posting this question.  RIM/BlackBerry has an updated version of their Print To Go program for the BlackBerry Playbook 2.0 upgrade.  On my W7/64-bit (Toshiba Portege R705, Intel Core i3) installation, the BlackBerry Playbook Print To Go application is generating an immediate error as soon as I attempt a "Print Test Page".  It works perfectly fine on a different W7/32-bit installation (older Lenovo with clean W7 install).  It hasn't generated a BlackBerry event log, I believe indicating the program is faulting immediately on initiation.  I worked with BB Support for over two hours, and using the W7 detailed troubleshooting capabilities (Event Viewer, etc.), we couldn't figure out the nature of the problem.  However, when we raised the Print Priority to its highest level, it did work once.  If you're not familiar with this program, Print To Go creates a PDF from a document file, opens a connection from the computer to the Playbook via a BlackBerry account, and then after verifying a security code, transfers the file to the Playbook.  Print To Go does not show up as compatible on either the 32-bit or 64-bit Microsoft Compatibility list, but other posts on various forums indicate it does work on a 32-bit computer (including mine), and after some installations difficulties related to AVG (which I don't have), also on 64-bit machines.  Any suggestions would be appreciated.
    Tuesday, March 6, 2012 8:03 PM

All replies

  • I have the exact same issue, except I run W7/32-bit so it is not specific to 64 bit operation. I could find no other information about this online. I have never had it work, on two different networks (laptop at home, and at work - desktop at home works fine).
    Tuesday, March 6, 2012 10:03 PM
  • If the following helps, here are some tips I learned from other forums to fix W7/32-bit problems:

    1. Make sure both computers are on the same WiFi network, and not a corporate LAN (apparently, the IP address must be the same for it to work);
    2. Before installing PTG, turn off any anti-virus and firewall program;
    3. Some have uninstalled and reinstalled, and it worked successfully;
    4. Some people report problems with D-Link routers.

    Hope this may help - I pretty sure my issue on the 64-bit isn't the router - it's not getting that far.

    BTW, here are some error codes from BlackBerry, in case you get to that point:


    Tuesday, March 6, 2012 10:55 PM
  • Nope - tried all those with no success. And I am having the exact same issue as you, which seems uncommon (most of those solutions seem to relate to people who get to the sign in screen - same as you I have an immediate fail before ever getting there).
    Wednesday, March 7, 2012 8:23 PM
  • Hi,

    Please try the following steps for a test.

    1. Create a new user account with administrator privileges.
    2. Disable UAC temporarily for a test.
    3. Test the issue in clean boot.
    4. Check if .NET Framework 4 is installed properly.

    Meanwhile, I think you could get more insights from BlackBerry support.

    Niki Han

    TechNet Community Support

    • Edited by Niki Han Thursday, March 8, 2012 6:36 AM
    Thursday, March 8, 2012 6:36 AM
  • Thanks Niki, I'll try the things you suggested and report back.  Pbowman is having the exact same problem, so perhaps s/he will do the same.  FYI, I've had two separate sessions with BlackBerry support, one of almost two hours, where they tested everything they could think of, and took screen shots.  It doesn't appear the print request is even getting to their logging system.  But they still have the case open, and have referred it to their development team.
    Thursday, March 8, 2012 4:49 PM
  • I did step 4 first - it was already there but did a repair. No go.

    Then I did step 1 (new account was local, not on the domain) and was able to print fine from that account. My original account still can't print, but at least now I have the basis to start some sleuthing (your step 3). Thank you - I will keep you posted.

    Thursday, March 8, 2012 6:43 PM
  • Curiouser and curiouser. I stated down step 3 with my normal domain account (which has administrator privileges). Got all startup items and all non-Microsoft services turned off - no go. So I started to wonder if it was the domain account versus local. I logged in as a local account and it worked again. Then I logged in as another domain user and it worked. Then I turned back on the services and startup items and logged back in as another domain user and it worked. 

    So - it doesn't like me!. As another user (even a domain user), with everything turned on, it works fine. As me, even with every startup item and all non-Microsoft services turned off, it won't work. 

    Thursday, March 8, 2012 7:30 PM
  • I really appreciate the effort you're putting into this!  It was going to be a weekend project for me, but now maybe tomorrow...

    I'll ask the fellow who helps us on our networking if he has any ideas.  I had surmised on a CrackBerry forum it might be related to domains.  Or maybe it is domain-related and tied to networking security (which might explain why as "you" it won't work, but as "new domain" it will).  I'll also let the BB support group know of what you've discovered.  Thanks again.

    Thursday, March 8, 2012 7:52 PM
  • It wasn't a "new domain" I tried, just a different user on the same domain - that worked. Its all about the user for some reason.
    Thursday, March 8, 2012 7:57 PM
  • Thanks - I should have said "domain new user".  I'll try the same and talk with my tech fellow. 

    Thursday, March 8, 2012 8:02 PM
  • Hi,

    Please delete the problematic domain user profile for a test.

    1. Login with local admin account, use Win+R to open run window, type sysdm.cpl in the run box.
    2. On Advanced tab, under User profiles catalog, click settings.
    3. In the list, delete your domain user profile.
    4. Restart the computer and login with that domain user for a test.

    Niki Han

    TechNet Community Support

    Friday, March 9, 2012 3:22 AM
  • Ouch - seriously? Won't I lose everything that I have done to make my user account work for me? (settings, desktop, synced files, etc.)? Or will this only temporarily disable it?
    Friday, March 9, 2012 5:06 PM
  • Niki - that was my concern too.  Is there any way to protect or save the existing domain user account?  One thought I had might be to do as you suggest, test the PTG program, but then do a system restore to recover the old user account.   But I didn't know if that would recover the settings, desktop, synced files, etc.
    Friday, March 9, 2012 5:14 PM
  • I've had the same experience as pbowman when using my local Administrator account - everything works fine.  I'm hesitant to try Niki's last suggestion until I know I can recover my domain settings.  But I did just discover that when "sideloading" Android apps on the work laptop, the sideloading program can't find my IP address automatically, but works fine if I enter it manually.  But it does find it automatically on the home laptop.  Could there be some security feature in the domain set-up that is blocking access to the Print To Go program? 
    Saturday, March 10, 2012 8:33 PM
  • I have also encountered the exact same issue as described here.  I have a Win7x64 system and PTG prints fine from a local administrator account but not from my domain account (also admin) on the same machine.  It errors immediately as soon as it is called, without processing the print request or communicating with the PlayBook.  It works perfectly from my domain account on an old WinXP system, and on a separate Win7x32 system using a local account.  It seems very strange that pbowman observed that it will function with another domain user logged in on the machine, but not his account (I haven't verified this yet on my PC).  I am also hesitant to delete my domain account profile as there is a lot of time invested in customization and file sync.  Have any of you made any more progress?  I didn't find any threads matching this subject yet at any of the BB specific community sites or on BB's support site.
    Wednesday, March 28, 2012 2:01 PM
  • Chris - the Microsoft folks haven't followed up, but the BB Support Team did about a week ago.  They were extremely interested to hear about the domain problem, as if it was an "ahh haa" kind of thing.  I gave them a copy of this forum discussion, and they said they'd follow-up.
    Wednesday, March 28, 2012 2:24 PM
  • Great, thanks Stephen.  I hope they pinpoint the issue as I find PTG very convenient.  Is there a thread somewhere else that I can follow, or is this in private communication between you and BB Support?
    Wednesday, March 28, 2012 8:09 PM
  • No other thread Chris...I  called the BB PlayBook support number 3-4 weeks ago right after the 2.0 upgrade when I discovered the problem.  They first tried to de-bug with me one evening for almost an hour, then escalated it to a technical specialist who spent almost two hours testing things with me a few days later.  They followed up again by phone, coincidentally right after pbowman had first posted, so I told them about Microsoft's input and his domain suspicions.  I have a running Incident Report with them, so I forwarded your comments this morning.  They immediately followed up, saying they were going to escalate to the development team and would follow-up when they knew more.  I'll do the same for this thread.  BB could not be more supportive.  I just hope they can find the problem.
    Wednesday, March 28, 2012 8:30 PM
  • Any solution from RIM on this yet?
    Tuesday, April 17, 2012 6:21 PM
  • No, I haven't heard back from them in the last few weeks.  But I have seen rumors that BB is apparently close to releasing a 2.1 upgrade to the PlayBook software, so I'm wondering if the fix may be contained in that release.  I'll follow-up with my contact there.

    Tuesday, April 17, 2012 6:27 PM
  • I still have never gotten this working. Have given up for now. Will just have to try again next year when I get a new laptop, I guess.

    Thursday, June 14, 2012 3:09 AM
  • Sorry I haven't followed up. RIM Support has been keeping in touch, including an update phone message last week.  They do now recognize it as a problem related to domains.  They didn't expect the last minor update to 2.0 would fix it (and didn't), but I got the clear indication the upcoming 2.1 update might have the fix.  It's actually out in Beta right now, but I don't want to load it until the official release.  I'd like it fixed too...I'm finding increasing uses for the PTG capability.
    Thursday, June 14, 2012 1:48 PM
  • Just another update - RIM Support reached out again yesterday asking me to provide a specific log file to help them continue to de-bug what appears to be a domain problem.  Coincidentally, because of the installation of a new server, I'm now working in a new domain, but still have the same problem.
    Wednesday, July 11, 2012 2:44 PM
  • Another update - I had hoped that the PlayBook 2.01.668 update might fix the problem, but it didn't, and RIM Support has confirmed that they didn't expect it would.  They do believe it's related to user-specific domain security settings, which seem to interfere with the BBID servers.  According to my contact in RIM Support (not necessarily a technician), if the future PlayBook OS 2.1 update communicates diferently with those servers, it may fix the problem. 
    Friday, August 10, 2012 2:57 PM
  • Thanks for the updates.  Still hoping this will be resolved; annoying having to log out of the domain and log in as a local admin to print to the PB.
    Monday, August 13, 2012 12:19 PM
  • Another update - neither the PlayBook's Beta 2.1 OS or the now released Public 2.1 OS have fixed the problem.  And RIM has appeared to have closed the case.  I've followed up on their PlayBook Beta site as they're asking for input on the new release.  If I receive any additional input, I'll post it.  Chirs - I'm with you - it's tedious to have to log in as a local admin, but PTG does work through that method.
    Thursday, October 4, 2012 9:44 PM