none
Change font in Explorer Preview pane RRS feed

  • Question

  • The preview pane in Explorer renders text files in Times NR, which really clashes with the rest of the window. The functionality looks like that of WDS, where the formatting of the preview was drawn from a template which was easily editable (if you knew where to find it).

    Does anyone know where to find the template used to render previews of text files in Explorer?


    Noel
    Saturday, August 7, 2010 12:53 AM

Answers

  • Just for the record, and to wrap this thread up: after installing both SP1 and IE9, the Explorer preview pane now uses the IE font to display files that use the MIME preview handler. It can be changed at Control Panel > Internet Options > General > Fonts.
    Noel
    • Marked as answer by iFiredogMVP Thursday, March 31, 2011 1:31 PM
    Thursday, March 31, 2011 1:31 PM

All replies

  • Hi Noel,

     

    This is by design which cannot be changed based on my test. You can save the files as .doc as a workaround.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, August 9, 2010 9:22 AM
  • It seems that the preview pane always uses the current Notepad font. Try the following (it works on my machine):

       - launch Notepad

       - select Format --> Font... from the menu bar

       - Change the font and close Notepad

    Now text files should be rendered in the font you just selected.

    I hope this helps.

    • Proposed as answer by Rashed Tuhin Wednesday, March 18, 2015 8:09 PM
    Monday, August 9, 2010 4:55 PM
  • Thanks. I can see that the preview handler is embedded in msoeres.dll, which hasn't changed much since OE days and still in Win7 lives on disguised as a Windows Mail file. Perhaps someone will write a handler that's more visually in keeping with the programs and OS it services.


    Noel
    Monday, August 9, 2010 10:30 PM
  • Thanks - you're quite right, of course. 

    The salient bit of my OP got edited out in a rush; the files I'm looking to smarten up the preview of are indeed plain text files, but they are of type .eml and .nws. The preview handler, buried inside msoeres.dll (-7496), adds a dreary grey header bar with the MIME headers in Arial. Then the body of a plain text message is displayed in Times New Roman. It all looks unattractive and not particularly workmanlike alongside the rest of the neat SegoeUI Explorer page. 

    If you've any bright ideas how to change this, I'd be delighted to hear them.


    Noel
    Tuesday, August 10, 2010 12:48 AM
  • THANK YOU!
    Sunday, August 22, 2010 1:55 AM
  • Just for the record, and to wrap this thread up: after installing both SP1 and IE9, the Explorer preview pane now uses the IE font to display files that use the MIME preview handler. It can be changed at Control Panel > Internet Options > General > Fonts.
    Noel
    • Marked as answer by iFiredogMVP Thursday, March 31, 2011 1:31 PM
    Thursday, March 31, 2011 1:31 PM
  • It seems that the preview pane always uses the current Notepad font. Try the following (it works on my machine):

       - launch Notepad

       - select Format --> Font... from the menu bar

       - Change the font and close Notepad

    Now text files should be rendered in the font you just selected.

    I hope this helps.


    You can also hold the Ctrl key on your keyboard, and use the roll on you mouse to resize immediately the display font size of the Windows Explorer preview pane...

    Sylvain

    Friday, December 23, 2011 8:05 PM
  • Dear .Firedog,

     

    I have a problem with my email-account and I was wondering if you could help me. Everybody seem to receive my emails except for my father. Can you imagine what is wrong? Is it my address or is it his?

     

    Best regards 

    Sunnefa

    Saturday, January 28, 2012 4:14 PM
  • This is the answer that worked for me.
    Tuesday, September 4, 2018 10:12 PM
  • It's been 9+ years since you posted this, and it was exactly what I needed to know this morning.

    Thanks :-)

    Thursday, December 5, 2019 10:34 AM