none
Problem with MDT task RRS feed

  • Question

  • Hi we are looking at using MDT to deploy to around 1000s machines across the school and have been tasked with testing it. I have got our image captured and deploy-able but not quite how we need it yet. 

    We want to be able to deploy the image to a system that currently as windows installed but also format the drive in the process. I have setup a domain account that maps the deployment share and runs the vbs script. That all works fine the machine reboots in to the WIN PE formats the drive and then errors out saying no drive to install to check drivers.

    The other way we want to install is by network boot I cant test this yet. To get round it I have uploaded the boot wim on to a usb stick. When I boot from that the task runs through start to finish no issue. Formats the drive installs runs through and I end up with a fully installed machine ready for naming and domain joining. 

    I can't understand why when they both run the exact same task with both boot wim being exactly the same that one works and one doesn't.

    Any advice much apprenticed Andrew Hoy

    Thursday, November 27, 2014 12:29 PM

All replies

  • That's because you're not allowing MDT to format the device.  When you omit the MDT diskpart solution, you often run into OS target drive issues because you're not configuring the proper MDT variables with target partition information. ZTIDiskpart along with ZTIGather handle this information. I recommend you create a format step in your image sequence and use the MDT construct to format the devices. This will handle all of the variable dependencies that MDT relies on for deployment.  Good luck.

    Ryan

    • Proposed as answer by MrBrooks Tuesday, December 2, 2014 3:51 PM
    Monday, December 1, 2014 4:04 PM
  • I don't fully understand what's going on here with the failure case, there is something lost in the steps here. If you are still having problems, please upload your bdd.log file to a public site like OneDrive, and share the link.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Thursday, December 4, 2014 1:30 AM
    Moderator