Unable to install MS SQL Azure Data Sync (Preview)


  • Hi,

    I am Unable to install MS SQL Azure Data Sync (Preview).
    I have Win 7 Ultimate - I am logged in with Administrator account.
    During Installation it asks for User ID with proper network access - so I tried this admin account by entering its ID and pwd and also tried by left the text boxes blank - but it failed. I then also created another User ID on my machine made it Admin and also give it various privileges by NTRights utility ( and by GPEdit - (we do not have Domain but workgroup) - And it still fails.

    I got this error message: 
    Service 'SQL Azure Data Sync Preview' could not be installed. Verify that you have sufficient privileges to install system services.
    And when I did not type any ID - I got this error message:
    failed to grant 'logont as service' rights to user -2147023564 account with network access

    Any assistance?



    Monday, October 17, 2011 4:12 PM


  • had the same problem.

    if its a local user account you're entering in the User Id, try using MACHINENAME\UserName format (e.g., MyPC\AdminUser)

    Tuesday, October 18, 2011 2:18 AM

All replies

  • Checkout the troubleshooting section here.

    SDE, Sync Framework -
    Monday, October 17, 2011 4:31 PM
  • Thanks for the quick response, I tried but with same errors - and tried 3 ways to install - all fail.
    -entering Admin ID during installation (Running setup as admin)
    -entering another Admin ID (with lot of other privileges) during installation (Running setup as admin) 
    -enter no ID during installation (Running setup as admin)  
    Monday, October 17, 2011 4:49 PM
  • Hi

    Are you installing as Local Administrator or Domain Administrator ?

    If you are installing as Local Administrator, you have to specify the username as .\Administrator

    Hope this helps !!!

    Arunraj Chandrasekaran, MCTS, Author:
    If you found this post useful, Please "Mark as Answer" or "Vote as Helpful"
    Monday, October 17, 2011 5:58 PM
  • Hello Habibcs

    As Arunraj suggested, try using the local administrator as .\Administrator or I would recommend using the domain account which has sufficient Privileges to install local agent.

    You can also enable detailed logging for local agent to see more information.

    Open LocalAgentHost.exe.config in notepad. This file should be present in your installation directory.

    a) Uncomment the section that is currently commented
    <add name="SyncAgentTracer" value="4" />
    <trace autoflush="true" indentsize="4">
    <add name="myListener" type="Microsoft.SqlAzureDataSync.ClientLogging.DSSClientTraceListener, Microsoft.SqlAzureDataSync.ClientLogging, Version=" initializeData="DSSAgentOutput.log" />
    <remove name="Default" />

    b) Stop and restart SQL Azure Data Sync Preview Windows Service.
    Now you would find the detailed logs in files named DSSAgentOutput*.log. Logs in this file are more detailed than log entries in the Event Viewer.

    Monday, October 17, 2011 7:58 PM
  • had the same problem.

    if its a local user account you're entering in the User Id, try using MACHINENAME\UserName format (e.g., MyPC\AdminUser)

    Tuesday, October 18, 2011 2:18 AM
  • Thank you very much!
    This thing worked: 
    MACHINENAME\UserName  Plus I gave AdminUser the rights to LogOnAsService from the LPC (not Group Policy)
    This file was not there: 
    Tuesday, October 18, 2011 7:32 AM
  • the LocalAgentHost.exe.config  isn't there because you havent successfully installed the agent yet.

    Once you've successfully installed the agent, you can find the config file in the directory where you installed the agent.

    Tuesday, October 18, 2011 7:49 AM
  • had the same problem.

    if its a local user account you're entering in the User Id, try using MACHINENAME\UserName format (e.g., MyPC\AdminUser)

    That turned out to be my problem as well.  The installer claims that you can use "DOMAIN\domainuser" or ".\localuser", but for the local user case it fails unless you specify "MACHINENAME\localuser".

    I would have filed a bug report on Connect, but SQL Azure Data Sync is not listed there yet from what I could find.

    Lars Kemmann
    Wednesday, October 19, 2011 4:30 AM
  • they're already aware of this issue and is tracking it already.

    Sql Azure Data Sync is in Sql Server's connect site.

    To log a bug in this release, use the following steps:

    1. Navigate to
    2. You will be prompted to search our existing feedback to verify your issue has not already been submitted.
    3. Once you verify that your issue has not been submitted, scroll down the page and click on the orange Submit Feedback button in the left-hand navigation bar.
    4. On the Select Feedback form, click SQL Server Bug Form.
    5. On the bug form, select Version = SQL Azure Data Sync Preview
    6. On the bug form, select Category = SQL Azure Data Sync
    7. Complete your request.
    8. Click Submit to send the form to Microsoft.
    Wednesday, October 19, 2011 5:07 AM
  • .\userId causes the agent install to fail.

    See the warning below figure 10 at - it describes the problem and solution.

    Wednesday, October 19, 2011 6:16 PM
  • please use your machinename\Administrator for successfull installation.
    Monday, January 23, 2012 11:36 PM
  • I had exactly this problem. It turned out that my machine name was longer than 15 characters (Nicks-Big-Laptop\DataSynUser).

    When I used 'Nicks-Big-Lapto\DataSyncUser' it all worked.

    By that stage I had already granted 'LogOnAsService' rights to that account, but the installer should do that for you if you haven't.

    Thursday, May 31, 2012 2:40 PM
  • Thank you, this resolved my problem. I tried a hundred times using .\Username instead of using the full PC name like MYPC\Username

    Thanks @JuneT

    Wednesday, August 19, 2015 10:56 AM
  • Thanks, Very useful. That worked for me.
    Friday, June 16, 2017 7:59 AM