locked
Desktop Composition not returning to Aero after shutting down games. RRS feed

  • Question

  •  Just like the title says , i have tiger woods 08 and had to set it to Vista compatibility and disable desktop composition to get it to work right in the menus , but when i exit the game the desktop stays in windows basic instead of returning to Aero , this NEVER happened to me in vista 64. also , if i ttry to reset my theme to my saved one it still stays in win basic till reboot.

    anyone eles seeing this or am I just screwed.

    M4N82 Deluxe ; AMD X4 940 Black Edition ; EVGA GTX285 1GB/XFX 9600GT PhysX ,  ; ASUS Xonar D2 ; OCZ Reaper HPC SLI 4GB (2 x 2GB)DDR2 SDRAM DDR2 1066 ; 750gig WD SATA/System installed with Windows 7 64bit Ultimate ; 350gig WD Games ; 160Gig Seagate/storage and video ; ASUS My Cinema-EHD3-100 PCI-e TV card ; PC P&C 860Watt PSU (powerful single 12volt rail) ; Samsung SyncMaster 2233SW ; ThermalTake SHARK case 
    Tall , dark....chubby...and handsome.
    Monday, November 23, 2009 4:37 AM

Answers

  • Hi JimBeamBlack,

     

    Some games require a massive amount of memory and resources to run which takes too many resources to keep up Aero. Also, since some older games might be incompatible with Aero, please contact the game manufacturer to confirm about this.

     

    In addition, please make sure you have installed the latest display card driver which are compatible with Windows 7.

     

    If the issue persists, please right click on the game's executive file and then click Properties. On the Compatibility tab, check "Disable desktop composition" and then click OK.

     

    Hope this helps.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Monday, November 30, 2009 2:06 AM
    Tuesday, November 24, 2009 5:52 AM

All replies

  • Hi JimBeamBlack,

     

    Some games require a massive amount of memory and resources to run which takes too many resources to keep up Aero. Also, since some older games might be incompatible with Aero, please contact the game manufacturer to confirm about this.

     

    In addition, please make sure you have installed the latest display card driver which are compatible with Windows 7.

     

    If the issue persists, please right click on the game's executive file and then click Properties. On the Compatibility tab, check "Disable desktop composition" and then click OK.

     

    Hope this helps.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Monday, November 30, 2009 2:06 AM
    Tuesday, November 24, 2009 5:52 AM
  • yes , its working going into the game thats not a problem , its coming back out of the game the desktop composition does NOT re enable back to Aero and forces me to reboot to get it back.

    thanks

    PS: all latest drivers , updates and BIOS installed.


    Tall , dark....chubby...and handsome.
    Monday, November 30, 2009 2:40 AM
  • Rather than a reboot, have you tried right-clicking on the desktop, choosing Personalize, than clicking on your Aero theme?

    -Noel
    Monday, November 30, 2009 2:52 AM
  • Yes I have , and I also tried clickin on any new AERO theme , it changes the theme but Aero will not re enable until rebooted , and it only happens with certain games that seem to need the Aero interface to be disabled , I'm thinking that its games that are not win 7 64 compatible and are not shutting down correctly therefore the system thinks the game is still running. because it enables Aero as its shutting down and rebooting.
    Tall , dark....chubby...and handsome.
    Monday, November 30, 2009 3:07 AM
  • For those games are you running them with the [ ] Disable desktop composition setting enabled?

    If so, is it possible there is still some remnant process from the game running after you stop it?  You'll want to carefully watch the Task Manager process list before and after the game runs to determine this.  At the worst, you may have to stop the process by hand from within Task Manager to recover Aero.  I could imagine a licensing manager starting, for example, but not exiting.

    If you are NOT using that setting, try checking it:  Right-click the shortcut to the game, choose Properties, click on the Compatibility tab, then check [ ] Disable desktop composition.  This will cause windows to shut down Aero while you're running that program, and bring it back up afterwards automatically.

    -Noel
    Monday, November 30, 2009 3:17 AM
  •  yep I am using it as enabled , I tried checking the TaskManager but I did it after the game was shut down so I had no idea what was there and what wasn't.

    I bet your right ,  I will try shutting down the game with the TM running and see if I can track that sucker down and find out what process it is.

    thanks mate!!
    Tall , dark....chubby...and handsome.
    Monday, November 30, 2009 3:29 AM
  • Hi!
    sorry to just bulge in, but i know exactly what your problem is, since google just landed me here, looking for solution to a problem exactly like yours.
    Without pointing fingers, or blaming the developer, (perhaps this is a problem nuisance, that DOES need to be fixed) i have come up with a quick, and easy solution. (it is somewhat better than restarting windows)

    -Start task manager

    -look for explorer.exe 

    kill the process

    now with task manager still in foreground, click file, run, and type in explorer.exe
    (this restarts explorer.exe and desktop composition will resume as normal)

    • Proposed as answer by bobalazs Friday, September 13, 2013 8:48 PM
    Friday, September 13, 2013 8:47 PM