none
DPM 2010 error ID 3040 RRS feed

  • Question

  • Im having difficulty with configuring the STMP server settings.  It seems to be a two fold issue.  We need to use the smtp relay for Microsoft BPOS which Ive followed the following directions:

    smtp server name: smtp.mail.microsoftonline.com

    smtp server port: 587

    From address: using a mail enable bpos account (mailrelay@domain.com)

    Authenticated SMTP server

    Username: mailrelay@domain.com

    password: correct password

    When we click Send Test email and type a valid email address in we get an error message pop up that states

    "ID: 2013

    Details: Logon failure: unknown user name or bad password"

    I've verified the username and password are correct. The second issue is when I click Ok to close the SMTP Server window the following error pops up.

    "DPM Setup is unable to update the report server configuration to configure e-mail settings (ID 3040) Log on to ServerName. On the start menu, oint to All Programs, point to Microsoft SQL Server 2008, point to Configuration Tools, and then click Reporting Services Configuration.  In Configure Report Server, update the e-mail settings."

    If we click the OK button to clear the error message and then click the OK button on the SMTP Server window it closes.  Following the error message instructions we verified that the e-mail settings are identical to those set in the DPM SMTP Server window.

    Also looking at the registry at HKLM\Software\Microsoft\Microsoft Data Protection Manager\Notification shows two entries

    SmtpPassword with a value that I would assume is supposed to be the hashed password

    and

    SmtpUserName with a value of mailrelay@domain.com

    The server is running Windows 2008 R2 sp1 and the SQL instance is running on SQL Server 2008 sp2.  Our Data Protection Groups, reporting and all other parts of DPM appear to be working correctly.  Just can't seem to get this email notifications to work.

    Please help!


    Jeff Miotke, MCITP:EA RightClick Networks, LLC
    Tuesday, April 5, 2011 7:50 PM

Answers

  • I was able to get the smtp relay working based on putting together information from some of the threads here on the forums.

    Here is how I configured the SMTP Server settings:

    smtp server name: mail.global.frontbridge.com

    smtp server port: 25

    From address: mailrelay@domain.com

    Authenticated SMTP Server

    username: Local administrator account on the DPM server

    The Event id 3040 error persists though. It seems as long as I hit Ok twice to this window the first always pops the error and the second time it accepts it and does indeed update the settings.


    Jeff Miotke, MCITP:EA RightClick Networks, LLC
    Thursday, April 7, 2011 12:41 PM

All replies

  • Hi Jeff,

    Can you confirm the username you are using (mailrelay@domain.com) has administrator privileges on the DPM server?

    Thanks,

    Marc

    Wednesday, April 6, 2011 5:17 PM
    Moderator
  • Thanks Marc.

    This account exists on the Microsoft Bpos servers so I Don't think it's Possible to add it as administrator to the DPM Server.

    I Did see a post that mentioned having to run IIS with Smtp to use BPOS for relay. Not sure why or how this would be configured.


    Jeff Miotke, MCITP:EA RightClick Networks, LLC
    Thursday, April 7, 2011 1:32 AM
  • Cant you allow anonymous relay on your mail server just from your DPM servers ip address?

     

    • Proposed as answer by Wharf FC Thursday, April 7, 2011 10:09 AM
    Thursday, April 7, 2011 10:09 AM
  • I dont believe so as its Microsoft Exchange Online.


    Jeff Miotke, MCITP:EA RightClick Networks, LLC
    Thursday, April 7, 2011 12:13 PM
  • I was able to get the smtp relay working based on putting together information from some of the threads here on the forums.

    Here is how I configured the SMTP Server settings:

    smtp server name: mail.global.frontbridge.com

    smtp server port: 25

    From address: mailrelay@domain.com

    Authenticated SMTP Server

    username: Local administrator account on the DPM server

    The Event id 3040 error persists though. It seems as long as I hit Ok twice to this window the first always pops the error and the second time it accepts it and does indeed update the settings.


    Jeff Miotke, MCITP:EA RightClick Networks, LLC
    Thursday, April 7, 2011 12:41 PM
  • Thank you Jeff for your post. That worked for me. I'm not using BPOS but this should work for any SMTP mail server destination. Although your solution limits me to only sending notifications to email address' that exist on the mail server I specified in "SMTP server name:"

    I got confused like the other people on this post. From the description on the "SMTP Server" tab, it appears as though you are supposed to be setting up the mail server that DPM will be using to send email. I think this is misleading for those of us who aren't using a mail server that runs on the Windows Domain.

    For those that don't use local windows domain SMTP, unless your external SMTP server allows relay without  authentication (big no-no), it appears we should be putting in the mail server that is the DESTINATION of the notification email. (i.e. if we want to send notification to billy@mydomain.com, then your smtp server should be the ip or FQDN that points to the mail server hosting mydomain.com, like mail.mydomain.com).

    The "Authenticated SMTP Server" section needs to be your domain or local administrator account. It appears to have nothing to do with actual SMTP based authentication, but is actually asking for Windows Authentication:

    user: "MYWINDOWSDOMAIN\Administrator"

    Unless my setup is considered obscure (external SMTP server), MS should update that Tab to be more descriptive and give you the ability to use an external SMTP server w/ SMTP Authentication (not windows authentication).

    Definitely think "Authenticated SMTP Server" should be re-labled to something that more accurately shows it's related to windows authentication. Most people who use external SMTP servers use username/password for their SMTP server when they see that description.

     





    Thursday, August 4, 2011 6:42 PM
  • Jeff, thanks for the info. Just for the record I just deleted the two registry entries for HKLM\Software\Microsoft\Microsoft Data Protection Manager\Notification and it started working again. It seems that once you've entered *anything* into the Options\SMTP Server\Authenticated SMTP Server settings then they can never be deleted.
    Thursday, August 27, 2015 7:13 AM
  • Hello Andy. I am trying to setup an smtp server (smtp.gmail.com) on DPM 2012 R2 but i am having the same problem. I was wondering if you could help me with this. The way I've configured the fields is the next:

    SMTP SERVER: ssl://smtp.gmail.com

    port: 465

    notification email: monitoreo@crefal.edu.mx

    username: monitoreo@crefal.edu.mx

    password: The password from the email address above...

    I am logged in the DPM server with an AD account which is ssinformatica. I has local administrator rights.

    Thursday, August 18, 2016 3:29 PM
  • Hi JoelM7,

    Only two observations:

    1. I don't use that port in my config as all my emails get sent to a local mail server on port 25. Are you sure you can reach that Gmail port from the server? Try a telnet to the port and see if it responds.
    2. The only other difference is that I use the server's local administrator account for SMTP authentication. I have to admit I don't know why I configured it that way, but I do remember fighting with a lot of permutations on this screen.

    Hope that helps,

    Andy.

    Monday, August 22, 2016 7:39 AM