none
Problemi richiesta password per leggere allegati con explorer

    Question

  • Buongiorno.

    Mi chiamo Marco e mi occupo del sito della scuola in cui lavoro.

    Utilizzo sharepoint 3.0

    il sito è ben strutturato e visibile e accessibile per tutti. Ci sono alcuni sottositi con accesso riservato con password per i docenti.  Nella home page ci sono le news che a volte hanno un file allegato e ci sono raccolte documenti (di tipo word) con contenuti pubblici.<o:p></o:p>

    Quando l'utente anonimo clicca su una news, la legge ma quando clicca sul file allegato gli viene richiesta la password e il nome utente. Questo succede anche cliccando sui file contenuti nella raccolta documenti.<o:p></o:p>

    Questo non deve succedere ma ancora più strano è che cliccando su "annulla" nella finestra di autenticazione per circa 6 o 7 volte, la finestra sparisce e si può procedere leggendo l'allegato o aprendo il file word.<o:p></o:p>

    la stessa cosa succede se accedo al sito autenticandomi come docente. Se dopo leggo una news, quando tento di aprire l'allegato succede la stessa cosa che ho descritto poco fa. Idem per i documenti word.<o:p></o:p>

    Concludo dicendoti che tutto questo succede solo se uso explorer. Con Mozilla e google chrome funziona tutto come deve. Cioè niente richieste di password (naturalmente quando non è necessario)<o:p></o:p>

    Spero nei consigli di qualcuno.

    <o:p>Marco</o:p>

    Tuesday, September 11, 2012 12:07 PM

Answers

  • Ho provato a riprodurre il problema sulla mia FARM 2007, sembra che il problema sia circoscritto ai file "Office", se alleghi pdf txt o altro sembra funzioni normalmente.

    Una volta configurato l'acccesso anonimo,

    I passi per risolvere il problema dovrebbero essere i seguenti 2:

      • Disable 'Client Integration' for the web application under Central Admin Home Page >> Application Management >> Authentication Providers
      • Remove the OPTIONS verb from the <HTTPHandlers> registration line in web.config file

    Prima di modificare il web.config fai una copia di backup :-)

    ciao Alessandro


    Alessandro Galanti MCITP Sharepoint 2010 - MCTS Sharepoint 2007 - MCP

    Friday, October 5, 2012 12:37 PM
  • Allora aggiungiamo due tasselli:

    il primo anticipato da Alessandro riguarda il comportamento delle applicazioni Office, cioè la Client Integration:

    il secondo è il risultato della mia analisi tcpip del traffico di accesso al tuo server: mentre apro il file word, dopo aver annullo la dialo  di auth riesco ad aprire il files

    Client integration

    You can disable client integration, which removes features that start client applications. This is the optimal configuration for some scenarios, such as publishing read-only content to the Web for anonymous access. Additionally, if you select ASP.NET forms authentication or Web Single Sign-On (SSO) authentication, client integration is set to No by default.

    Expected behaviors when client integration is disabled

    When client integration is disabled, sites behave in the following ways:

    • Links that start client applications are not visible.

    • Documents are opened in the browser. Documents cannot be opened by client applications.

    • Users cannot edit documents on the site directly from the client applications. However, users can download the document, edit the document locally, and then upload the document.

    ANALISI DEL TRAFFICO TCP/IP DURANTE L'APERTURA DI UN FILE WORD PUBLIC SU SHAREPOINT

    Dopo il mio Click sul file, il server Sharepoint Mi risponde con una serie di datagrammi

    tra cui il primo

    X-MSDAVEXT_Error: 1966082; Accesso%20negato%2e\r\n....
    ....<p>Autorizzazione non disponibile per l'esecuzione di questa operazione o per l'accesso a questa risorsa.</p>\n

    poi più in là...

    Expert Info (Chat/Sequence): HTTP/1.1 401 Access denied\r\n

    Sunday, October 7, 2012 10:12 PM

All replies

  • Ciao Marco,

    Non sono sicura se la tua richiesta fosse ancora di attualità, intanto vorrei chiederti, per il caso fortunato in cui riesci a trovare la soluzione, di condividerla con la community, in modo che possa essere trovata e utilizzata dagli altri membri che riscontranno scenari simili.

    Se questa problematica è urgente per il tuo lavoro, per analisi approfondite puoi anche valutare di aprire un incident preso il supporto di Microsoft (ritieni che questo tipo di assistenza potrebbe essere a pagamento).

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    Tuesday, September 18, 2012 7:11 AM
    Owner
  • Quindi dipende da Internet Explorer?....Uhmmm ti richiede autenticazione quando in realtà dovrebbe usare trusted...film già visto...ho recuperato degli appunti

    "Internet Explorer / internet options -/Security Tab /
    "internet, Local Intranet, Trusted sites, Restricted sites -

    ATTENZIONE

    Se non selezioni Trusted Sites/Custom Level/User Authentication set to; "Automatic
    logon only in Intranet zone" - riappare un pop up logon ogni volta che apri sharepoint o ...un
    documento nella Document Library.

    Ciao e buon film

    Tuesday, October 2, 2012 9:33 PM
  • Ciao Ti ringrazio per la risposta. Se capisco bene però la selezione che mi consigli la faccio sul mio pc e infatti funziona.

    Il problema è che tutti quelli che utilizzano il sito dovrebbero modificare le impostazioni di internet sul proprio pc. Dovrei invece intervenire sul server web quindi a monte del problema in modo che agli utenti non venga chiesta la password più volte ma solo una. Spero di aver capito altrimenti fammi sapere.

    Ciao.

    Friday, October 5, 2012 6:14 AM
  • Ho provato a riprodurre il problema sulla mia FARM 2007, sembra che il problema sia circoscritto ai file "Office", se alleghi pdf txt o altro sembra funzioni normalmente.

    Una volta configurato l'acccesso anonimo,

    I passi per risolvere il problema dovrebbero essere i seguenti 2:

      • Disable 'Client Integration' for the web application under Central Admin Home Page >> Application Management >> Authentication Providers
      • Remove the OPTIONS verb from the <HTTPHandlers> registration line in web.config file

    Prima di modificare il web.config fai una copia di backup :-)

    ciao Alessandro


    Alessandro Galanti MCITP Sharepoint 2010 - MCTS Sharepoint 2007 - MCP

    Friday, October 5, 2012 12:37 PM
  • Ciao MArco

    hai fatto intanto un test per vedere se siamo nello scenario ipotizzato?

    poi per il deploy ti spiego come si fa.

    Ciao

    Sunday, October 7, 2012 8:30 AM
  • Ciao Robert,

    sul mio pc "Automatic logon only in Intranet zone" nelle opzioni internet è già di default, non ho dovuto selezionarlo. Con questa impostazione ogni volta che apro un documento in area riservata mi viene chiesta la password. In area pubblica viene chiesta la password ma cliccando su annulla il pop up logon sparisce e il documento si apre. Se vuoi puoi provare tu stesso a questa url

    http://www.portaleboselli.it/programmazione/Programmazione%20del%20Consiglio%20di%20classe/Forms/AllItems.aspx?RootFolder=%2fprogrammazione%2fProgrammazione%20del%20Consiglio%20di%20classe%2fProgrammazione%202011%20%2d%202012&FolderCTID=&View=%7b4ABC8269%2d75D0%2d4569%2dA540%2dD287B4ED723C%7d

    Se invece nelle impost. di internet seleziono "accesso automatico con nome utente e password correnti" allora dopo la prima volta l'autenticazione non viene più richiesta.

    Ma chiaramente questo avviene sul mio pc e basta, quindi non risolvo il problema.

    Forse sul server web in amministrazione centrale, nella pagina "modifica autenticazione" ci sono dei settaggi sbagliati?

    Ti dico come sono: tipo di autnticazione: windows  -  accesso anonimo: consentito  -  impostazioni di autenticazione IIS: Negozia(kerberos) e autenticazione di base  -  integrazione client: attiva. Un'altro comportamento strano che mi fa pensare che qualcosa non va è questo:

    in altri siti sharepoint, quando si clicca su un documento word, il doc si apre ma non in ambiente word, ma in ambiente sharepoint (sola lettura) senza richiesta di password.(esempio all'URL  http://www.itismajo.it/intranet/Circolari%20Docenti/Circ.%2003%20scrutini%20settembrei.doc  )

    Sul nostro sito invece i doc si aprono solo in ambiente word. Magari da ciò nasce il problema.

    Lunedì proverò anche la soluzione prospettata da Alessandro Galanti nella risposta che mi ha scritto sopra, che avrai sicuramente letto.

    Grazie a te e a lui per l'interessamento.

    Sunday, October 7, 2012 10:24 AM
  • Allora aggiungiamo due tasselli:

    il primo anticipato da Alessandro riguarda il comportamento delle applicazioni Office, cioè la Client Integration:

    il secondo è il risultato della mia analisi tcpip del traffico di accesso al tuo server: mentre apro il file word, dopo aver annullo la dialo  di auth riesco ad aprire il files

    Client integration

    You can disable client integration, which removes features that start client applications. This is the optimal configuration for some scenarios, such as publishing read-only content to the Web for anonymous access. Additionally, if you select ASP.NET forms authentication or Web Single Sign-On (SSO) authentication, client integration is set to No by default.

    Expected behaviors when client integration is disabled

    When client integration is disabled, sites behave in the following ways:

    • Links that start client applications are not visible.

    • Documents are opened in the browser. Documents cannot be opened by client applications.

    • Users cannot edit documents on the site directly from the client applications. However, users can download the document, edit the document locally, and then upload the document.

    ANALISI DEL TRAFFICO TCP/IP DURANTE L'APERTURA DI UN FILE WORD PUBLIC SU SHAREPOINT

    Dopo il mio Click sul file, il server Sharepoint Mi risponde con una serie di datagrammi

    tra cui il primo

    X-MSDAVEXT_Error: 1966082; Accesso%20negato%2e\r\n....
    ....<p>Autorizzazione non disponibile per l'esecuzione di questa operazione o per l'accesso a questa risorsa.</p>\n

    poi più in là...

    Expert Info (Chat/Sequence): HTTP/1.1 401 Access denied\r\n

    Sunday, October 7, 2012 10:12 PM
  • Cari Robert e Alessandro, vi ringrazio perchè credo di aver risolto il problema seguendo i vostri consigli.

    Con client integration settata su "no" il sito non chiede ulteriori autenticazioni, anche se per modificare un file è necessario farlo in locale e poi reinserirlo. Va benissimo così.

    Risolto questo, ho esposto un'altra questione nel forum. Se volete leggere, l'url è questa:

    http://social.technet.microsoft.com/Forums/it-it/sharepointitproit/thread/37a02b68-74b9-440e-b8db-72e46ccd82ed

    Grazie ancora.

    Marco

    Wednesday, October 10, 2012 8:21 AM
  • Grazie a Te.

    Ciao Robert

    Wednesday, October 10, 2012 11:29 AM
  • Ciao, volevo aggiungere un dettaglio al comportamento del sito con client integration disattivato.

    Correttamente i file word o excel presenti fisicamente sul server non sono modificabili e se lavoro da casa devo sostituirli con un nuovo file che ho modificato sul mio pc. Se voglio lavorare sulle pagine del sito con sharepoint designer sempre da casa, non posso farlo. La pagina si apre anche senza digitare la password ma in un formato strano (le web part sono tutte tabelle editabili e quindi ci si può scrivere dentro il che è assurdo) e quindi non è l'ambiente giusto. Per aprire la pagina con sharepoint designer e modificarla come ho sempre fatto, devo attivare "client integration".

    Vi chiedo se tutto questo è normale o forse c'è ancora qualcosa che non va nelle impostazioni.

    P:S.  come si attiva il servizio di  ricerca dei file nel sito? (vi ricordo che utilizzo windows server 2008 e sharepoint 3.0) devo installare qualche programma? Nell'amministrazione centrale di sharepoint non ho trovato voci che fanno riferimento al servizio di ricerca.

    Grazie

    Sunday, October 14, 2012 1:24 PM
  • Ciao

    visto che sei in accesso anonimo per default suppongo che tu abbia effettuato il login come site collection administrator prima di aprire Designer. Senza client integration effettivamente dovresti avere qualche limitazione, http://support.microsoft.com/kb/970197 dovresti quindi riabilitarlo, eseguire le modifiche e poi disabilitarlo di nuovo.

    per configurare il serach puoi trovare uno step by step qui (configurazione dalla central administration)

    http://it.toolbox.com/blogs/wss-search/configure-search-in-wss-30-38703


    Alessandro Galanti MCITP Sharepoint 2010 - MCTS Sharepoint 2007 - MCP

    Monday, October 15, 2012 6:46 AM
  • Ciao Ti rispondo per Designer 2010:

    "per modificare il contenuto SharePoint devi essere membro ai almeno uno dei seguent a livello site collection:
    -Site Collection Administrators group,
    -Designers group 
    -Owners group.

    Ciao

    R

    Monday, October 15, 2012 7:42 AM
  • Ciao Robert e ciao Andrea, ho risolto quasi completamente il problema delle continue richieste di autenticazione ma manca ancora un tassello e quindi approfitto della vostra disponibilità:

    ho riattivato la client integration (perchè ho bisogno di intervenire da casa sul sito con sharepoint designer) ma nella pagina dove si settano le diverse operazioni che possono effettuare gli utenti sia nelle raccolte che nel sito ho tolto il flag dove si parla di "gli utenti possono modificare file o documenti etc.." ed ecco che non essendo più possibile modificare i file sul sito non viene più richiesta l'autenticazione. Purtroppo però non succede sempre ma dipende dai casi:

    1) se apro un file excel, tutto va bene, nessuna richiesta di password

    2) se apro un file word, si apre e lo leggo e poi quando per tornare  indietro alla pagina precedente, clicco sulla freccia, mi appare la finestra di autenticazione, clicco su annulla, la finestra scompare e poi procedo. Quindi non sono costretto ad autenticarmi (se annullo vado avanti lo stesso) però perchè me la chiede?

    Se volete potete provare voi stessi a questo link del nostro sito (usando però explorer)

    http://www.portaleboselli.it/modulistica/Modulistica%20Studenti/Forms/AllItems.aspx

    Ci sono altri siti sharepoint 3.0 dove questo non succede minimamente, allora non mi spiego questo strano comportamento.

    esempio questi

    http://www.romagnosi.it/aspx/programmcdc1.aspx

    http://www.scuolaisas.it/pagine/modulistica.aspx

    Grazie.

    Vi saluto.

    Marco

    Sunday, October 21, 2012 3:03 PM