none
Can't rename folders in Outlook

    Question

  • I am using Outlook 2010 beta on Windows Vista. I am using a shared Exchange mailbox for which I have 'Owner' permissions. I can do everything I like including sending mail from this address and creating and removing folders. Under the 'Inbox' there is an extensive folder structure, up to 2 levels deep. Although there are more people authorized to use this mailbox, and may have it included in their active Outlook profile, as far as I know I am the only one who is actively using it.

    I can rename a folder under the Inbox and move mail in and out. When I read the mailbox name in Visual Basic I see the new name. However, after a few minutes the mailbox will always revert to its old name. There is no way to rename a folder, the only solution I can think of is to make a new folder and move all mail and delete the old folder. But this is very annoying...

    This problem also occured when I was using Outlook 2007 on the same computer.

    Does anyone have any idea what is happening?

    Thanks,
    Lucas

    Tuesday, November 24, 2009 8:13 AM

Answers

  • Disable the setting

    Tools - account settings - change - more settings - advanced - download shared folders (excluded mail folders)

    It is  a known issue in 2007.

    Regards,
    Peter

    Friday, December 04, 2009 8:49 AM

All replies

  • This is a pretty common occurance for an Exchange mailbox with shared folders. Even though you may have "ownership", it's likely just for the client, or for very limited functions for that mailbox. There are likely additional overriding permissions on the Exchange server, and when your client syncs with the server, the mailbox is overridden to the old, or default name. If other folks have this folder structure on their client as well, the server won't allow your change to trickle out to other clients, it has to be done on the server.

    Have you asked your Exchange admin to rename the mailbox for you? Basically, you're renaming the mailbox, but when it syncs with Exchange, the overriding permissions are changing it back.
    Tuesday, November 24, 2009 10:57 PM
  • Disable the setting

    Tools - account settings - change - more settings - advanced - download shared folders (excluded mail folders)

    It is  a known issue in 2007.

    Regards,
    Peter

    Friday, December 04, 2009 8:49 AM
  • Peter Kerkhofs - thanks very much - this worked perfectly!

    I'm not sure what the disadvantage of not downloading shared folders is, but it doesn't seem to have any effect on my experience using Outlook.

    Monday, April 19, 2010 5:56 PM
  • I'm not sure what the disadvantage of not downloading shared folders is, but it doesn't seem to have any effect on my experience using Outlook.


    This setting caches shared folders locally. You won't notice anything, except maybe slower access, unless you are working offline. Then they won't be accessible.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Tuesday, April 20, 2010 11:42 AM