locked
Export to Excel RRS feed

  • Question

  • Hi,

    I have a business requirement where the users want the option to export a SSRS report to excel using the standard export Excel option and also an option to export to excel with no headers. Both these options should be available from the export drop down box in report manager.

    I have updated the rsreportserver.config file to overrider the Excel extension and set the SimplePageHeaders to TRUE as per the code below.

    <Extension Name="EXCEL" Type="Microsoft.ReportingServices.Rendering.ExcelRenderer.ExcelRenderer,Microsoft.ReportingServices.ExcelRendering">
     <OverrideNames>
      <Name Language="en-US">EXCEL NO Headers</Name>
     </OverrideNames>
     <Configuration>
      <DeviceInfo>
       <SimplePageHeaders>True</SimplePageHeaders>
      </DeviceInfo>
     </Configuration>
    </Extension>

    This works as expected, however I need to also show a second Excel option with the default settings. When I include the original excel extension line in the rsreportserver.config file it is not recognised. It only appears to display the first Excel Extension entry in the XML.

    Is it possible to add multiple entries for the same export extension in the rsreportserver.config file with different names? i.e.

    Excel
    Excel No Headers


    Any help with this would be greatly appreciated

    Thanks
    Kevin
    Friday, January 29, 2010 1:07 AM

Answers

  • Hi Kevin,

    Yes, it is possible. In fact, names have to be unique, so you do need to use different name for the “No Headers” mode.
    You can simply use <Extension Name=”EXCELNOHEADER”

    Hope this helps,
    Krisztian

    • Marked as answer by Kev_Wilson Monday, February 1, 2010 2:46 AM
    Friday, January 29, 2010 9:20 PM
    Answerer

All replies

  • Hi Kevin,

    Yes, it is possible. In fact, names have to be unique, so you do need to use different name for the “No Headers” mode.
    You can simply use <Extension Name=”EXCELNOHEADER”

    Hope this helps,
    Krisztian

    • Marked as answer by Kev_Wilson Monday, February 1, 2010 2:46 AM
    Friday, January 29, 2010 9:20 PM
    Answerer
  • Thanks Krisztian, that worked a treat.
    Monday, February 1, 2010 2:47 AM