locked
Deploying to VHD - No network connection on VM RRS feed

  • Question

  • Hi,

    I'm experimenting with creating a VHD with our standard desktop build on it. I have created a task sequence to build the VHD, however if I watch the VM be built, SCCM is not connecting a network adapter and so the VM doesn't connect to the domain and download any of the applications.


    Any ideas as to how I can create the network connection?


    MCP, MCDST, MCTS x 6, MCITP x 3

    Please don't forget to mark this post as an answer if it is the solution to your problem!

    If you like trance music, please subscribe to my podcast Trancendance Podcast

    View my MCP Certifications

    Follow me on Twitter

    Monday, April 28, 2014 2:38 PM

All replies

  • What virtual platform are you using? Usually you don't need NIC drivers for virtual labs but obviously in this case you do. You need to identify the required NIC driver - look at another VM. Add it to a driver package and incorporate the driver package into your task sequence.


    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Monday, April 28, 2014 2:47 PM
  • Thanks Gerry,

    its hyper-v as this is required for R2's build to a vhd functionality.

    SCCM automatically creates the vm, but when it creates the settings, it doesn't add a Nic, and it doesn't attach to the virtual switch.


    <p>MCP, MCDST, MCTS x 6, MCITP x 3</p> <p>Please don't forget to mark this post as an answer if it is the solution to your problem!</p> <p>If you like trance music, please subscribe to my podcast <a href="http://feeds.feedburner.com/trancendanceuk"> Trancendance Podcast</a></p> <p><a href="https://www.mcpvirtualbusinesscard.com/VBCServer/trancendance/profile">View my MCP Certifications</a></p> <p><a href="http://www.twitter.com/brianjonesdj">Follow me on Twitter</p> </a>

    Monday, April 28, 2014 3:31 PM
  • Use Powershell for this. Add Add-VMNetworkAdapter to your task sequence.

    See here for the Hyper-V cmdlets

    http://technet.microsoft.com/en-us/library/hh848559.aspx



    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Monday, April 28, 2014 3:34 PM
  • Gerry can you provide any more information about how to add this?

    I have the same issue.

    I have a task sequence that I'm using to directly create a VHD file.

    What SCCM Does:

    1. It creates a Virtual Machine in Hyper-V Manager (on the computer where I'm running the SCCM console).

    The VM Doesn't have a NIC Attached (but the New-CMVhd powershell cmdlet that SCCM uses don't have any parameters to enable NIC, it automatically creates the VM)

    2. It applies the image that I specified in the tasks sequence and goes over all of the Task Sequence steps (It usually fails on the "Apply Network Settings" step because there's no NIC where it can apply the settings.

    The VM is created with a Random Name on my Windows 8.1's Hyper-V.

    I believe it's some kind of a bug with SCCM 2012 R2... but I have all the current updates installed.

    Regards,

    Kiril

    Tuesday, November 25, 2014 3:20 PM