none
Core parking not working after upgrade

    Question

  • hello,

    i have a Dell Optiplex 390 with a core i3-2100 CPU,. this platform fully supports core parking and in Win 7 pro(which was the os used) it successfully showed the 2nd physical core being parked (it left active core 0 which is logical cpu 0 and 2).

    After upgrading to 10 pro, with all window updates and verifying no system drivers missing, core parking is disabled, checked the power policy and min state is 5%(As before), changed it to 0% and also changed the profile from balance to low power/high perf to no avail, cores don't park.

    any ideas?

    Wednesday, August 05, 2015 3:02 PM

Answers

  • Here is the definitive answer. Windows 10 Pro has CPU Core Parking disabled by default.

    To enable the Core Parking settings in GUI in Windows 10 Control Panel - Power Options - Change Plan Settings - Change advanced power settings you have to modify the following value in the Registry - Run As Administrator:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\0cc5b647-c1df-4637-891a-dec35c318583]
    "Attributes"=dword:00000000

    The default value is 1 which makes the related settings invisible in GUI, but still operational.

    The same Registry value works with Windows 7 and I believe, although not tested, with 8/8.1/2008R2/2012/2012R2 and very likely with Windows Server 2016.

    After making the setting visible, the setting mentioned is under Processor power management - Processor performance core parking min cores and you will find it as 100% in Windows 10 under all default plans.

    To enable Core Parking and reduce the temperature of the CPU, the mentioned setting above should be set to 10%, which was the configuration of the Balanced Plan in Windows 7.

    The High Performance Plan in Windows 7 has the same value as 100% which means Core Parking is disabled for that plan.

    Sunday, September 20, 2015 8:28 AM

All replies

  • Hi,

    So far I didn’t find similar case about core parking feature from Windows 10 IT pro database,  insider preview forum or online. Since we do have limitation in our environment, we cannot test this issue on Windows 10, read following article to set it enable via power management scheme, if this issue still persists, please feedback to us by using Windows 10 build in feedback tool.

    In the other hand, Keep eyes on your device manufacturer’s website, they will release firmware/driver program successively.

    Enabling core parking is set via the power management scheme. Core Parking can be enabled by change the Power Options to Balanced. For more information about enable Core Parking, please refer to the following link:

    http://www.windowsitpro.com/article/john-savills-windows-faqs/q-how-do-i-enable-core-parking-in-windows-7-and-windows-server-2008-r2-.aspx

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Enabling Core Parking Technology in Windows 7 (try it under Windows 10)

    https://social.technet.microsoft.com/Forums/en-US/4f3d89c1-82c8-43cd-b688-3419eb0f935d/enabling-core-parking-technology-in-windows-7?forum=w7itproperf

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 10, 2015 3:30 AM
    Moderator
  • Deason,

    balanced power policy is already in use with default values, i'm checking those links and there's something odd(checked the japanese article)..

    MY current settings are 100 for "valuemax" which is the max number of parked cores and0 for valuemin.

    After checking the article i changed them to 50% min cores (i3 is a dual core w/HT):

    Now i get *SOME* parking on CPU2 and 3 which should not happen unless win 10 changed logical core grouping (0+1 physical cores, 2+3 HT ones) as it should put an entire core to sleep(wither 0+2 or 1+3) like it was happening on win7. Also i need to set it to "lightest performance state" to get some meaningful parking, with "deepest state" i get a couple seconds and then they go back to active (i'm not running anything in the background save this browser)

    Core throttling is also behaving very erratically, even with nothing open i get the clockspeeds moving up for no reason(CPU usage is well below 10%) and practically never staying in the lowest multiplier(for example right now i'm at 1% usage and 80% max clock.

    Checking with cpuz and tmonitor the values shown in performance monitor appear to be wrong, it's showing 80% max clock yet the cores are at max multiplier(16-31x)

    Only if i force "power saver" then it tries to stay at the lowest multiplier(50% clock in this CPU model) as it should be doing in balanced.

    i'll use the feedback tool

    Monday, August 10, 2015 12:08 PM
  • Here is the definitive answer. Windows 10 Pro has CPU Core Parking disabled by default.

    To enable the Core Parking settings in GUI in Windows 10 Control Panel - Power Options - Change Plan Settings - Change advanced power settings you have to modify the following value in the Registry - Run As Administrator:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\0cc5b647-c1df-4637-891a-dec35c318583]
    "Attributes"=dword:00000000

    The default value is 1 which makes the related settings invisible in GUI, but still operational.

    The same Registry value works with Windows 7 and I believe, although not tested, with 8/8.1/2008R2/2012/2012R2 and very likely with Windows Server 2016.

    After making the setting visible, the setting mentioned is under Processor power management - Processor performance core parking min cores and you will find it as 100% in Windows 10 under all default plans.

    To enable Core Parking and reduce the temperature of the CPU, the mentioned setting above should be set to 10%, which was the configuration of the Balanced Plan in Windows 7.

    The High Performance Plan in Windows 7 has the same value as 100% which means Core Parking is disabled for that plan.

    Sunday, September 20, 2015 8:28 AM
  • Any idea why is it disabled by default?
    Saturday, November 19, 2016 5:30 AM
  • You could achieve the same result in previous OS by setting the Power Scheme to Maximum Performance.

    I suppose this was done because a lot of people (gamers) requested it, or for marketing purpose to look like the computer is more responsive, or simply as effect of a bug. Or to get into conspiracy theories, to have old computers worn off quicker, so the hardware manufacturers can sell more new equipment.

    Both configurations with or without Core Parking are valid, only that without Core Parking on normal laptops, the fan tends to be active a little bit too much and this may impact the life of the motherboard and/or CPU.

    Saturday, November 19, 2016 7:45 AM