none
Project Pro 2013 VBA proc is lost RRS feed

  • Question

  • Hi,

    I created a VBA procedure in a Project 2013 file. I created also a button in a custom tab to run the procedure. I tested everything : OK

    I want to demo my project : the proc has gone. I just have the button, without the VBA code. :-(

    What did I miss?

    Thanks for your help

    Saturday, April 12, 2014 12:14 PM

All replies

  • Where did you save the VBA to - was it just that project, or in the global?

    Ben Howard [MVP] | web | blog | book

    Saturday, April 12, 2014 2:38 PM
    Moderator
  • It was in the project file.

    Saturday, April 12, 2014 2:58 PM
  • Well, if you press ALT-F11 and it's not in any of the modules, then it hasn't been saved with the project file. 

    Ben Howard [MVP] | web | blog | book

    Saturday, April 12, 2014 3:44 PM
    Moderator
  • I saved the VBA module more than 10 times... :-(

    Saturday, April 12, 2014 3:59 PM
  • WLID1966,

    This is a shot in the dark but did you check your Global file to see if the module is there? Is it a normal macro or an event based macro?

    Also, do you have SP1 installed?

    John

    Saturday, April 12, 2014 4:14 PM
  • John,

    There is nothing in the GLobal.mpt : no VBA module (It'a a normal macro)

    I don't have SP1 installed...

    Thanks


    • Edited by WLID1966 Saturday, April 12, 2014 5:11 PM
    Saturday, April 12, 2014 5:11 PM
  • WLID1966,

    Definitely install SP1. You might want also to check each cumulative update since SP1 to see if there is anything relating to VBA.

    You say you saved the VBA module more than 10 times. Exactly how did you "save"? I don't suppose you have a backup of your file?

    John

    Saturday, April 12, 2014 8:42 PM