none
Application installation error "Access is denied to HKCR" RRS feed

  • Question

  • Hello Techies,

     I am working on Metadata Assistant Application packaging on Windows 10 OS. Initially it installed without any issues. After one month it started to throw an exception kind error saying " access to 'HKCR\Photoviewer.fileassoc.tiff\shell\Check Metadata...\Command' is denied"

    I don't see any issues on windows 7 machine, where there is no key like the above. I tried to change the file association for photoviewer but no luck.

    Tried to install with system account it doesn't show any message like that but the application process runs in the background. And one weird thing is it throw the error and in log says app installed successfully exit code 0.

    App Vendor was saying that I don't have admin rights if that is the case it shouldn't be installing windows 7 machines as well. But I think it is caused by some different setting on windows 10 environment.

    Can any one please help me with troubleshooting and fixing the issue.

    Please do find the attachment.

    Thanks in advance

    Monday, February 19, 2018 3:43 PM

All replies

  • I see that the application is trying to create some sub-keys and fails with the access denied error. You have mentioned above that the key does not exist which might the cause of your issue as the application may be trying to create sub-keys without success given that the key itself does not exist. You may want to check with the vendor what are the keys needed to be able to proceed with the proper installation.

    In general, you can run the executable using an elevated prompt to make sure that it is not a permission issue.


    This posting is provided AS IS with no warranties or guarantees , and confers no rights.

    Ahmed MALEK

    My Website Link

    My Linkedin Profile

    My MVP Profile

    Monday, February 19, 2018 4:46 PM
  • Hi,

    Firstly, restart explorer.exe.

    Your user account does not have access to get into the registry. You must have admin rights to modify/access the registry on your user account.

    Log in with administrative privilegies, run regedt32, open required key, click right mouse button, select Permission and set required permissions for this key.

    Restart explorer.exe.

    Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 20, 2018 7:34 AM
    Moderator