locked
MMC cannot open the file C:\WINDOWS\system32\p3server.msc RRS feed

  • Question

  • Hello,

    My server is Windows Server 2003 R2 Standard SP2. I successfully install the SMTP/POP service and can open the SMTP console under IIS. But When I open the POP3Service console, I get the error:

    MMC cannot open the file C:\WINDOWS\system32\p3server.msc.
    This may be because the file does not exist, is not the MMC console, or was created by a later version of MMC. This may also be because you do not have sufficient access rights to the file.

    I try to regsvr32 msxml<x>.dll following the KB http://support.microsoft.com/?scid=kb;en-us;914231&x=12&y=9. But the error still exists.

    Any tips are appreciated.

    Xiaofeng

    Xiaofeng Wang | http://www.leoworks.net | Beijing P.R.C
    Friday, September 25, 2009 9:15 AM

Answers

All replies

  • Have you verified that p3server.msc is infact in C:\WINDOWS\System32 directory?

    Have you checked that the reg key path is correct for p3server.msc (HKLM\SOFTWARE\Microsoft\Pop3 Service\)

    Can you open the console by doing a start -> run -> p3server.msc ?

    HTH,

    Mark
    The post is provided AS IS and confers no warranties.
    Friday, September 25, 2009 3:54 PM
  • Hello Mark,

    - Yes. p3server.msc is really existing there.
    - Yes. HKLM\SOFTWARE\Microsoft\Pop3 Service\ is really existing. But I do not know which key and which value you're meaning.
    - NO. WIN + R > p3server.msc to give the same error dialog.

    Thanks.

    Xiaofeng Wang | http://www.leoworks.net | Beijing P.R.C
    Saturday, September 26, 2009 1:54 PM
  • I figure this out by myself.  Thanks for Tim Huffam's great post: Error: MMC cannot open the file C:\Program Files\Microsoft SQL Server\80\Tools\BINN\SQL Server Enterprise Manager.MSC. 
    In my case, my original p3server.msc is miraculously crashed. when I open it with notepad, it's actually fully empty. (as known, .msc is in the xml format).  So, 

    WIN + R > mmc > File > Add/Remove snap-in > Add > Locate the POP3 Service > Add > Close > Save as > overwrite C:/WINDOWS/system32/p3server.msc

    Hope this helpful for the concerning guys.

    Thanks.

    Xiaofeng Wang | http://www.leoworks.net | Beijing P.R.C
    • Marked as answer by Xiaofeng Wang Saturday, September 26, 2009 2:55 PM
    Saturday, September 26, 2009 2:54 PM
  • Folks,

    I had this problem for weeks and tried everything.  It was also happening with multiple different snap-ins (Kaspersky and wsus).  In the end I solved it by deleting and having the snap in recreate the reference file stored in the users profile.

    See the following article that I wrote on my blog which I have documented step by step for all to read:

    http://www.proposedsolution.com/solutions/mmc-open-file/

    Hope this helps.

    Rosco
    Thursday, January 7, 2010 7:15 PM