locked
Samsung SH-S162L DVDRW Incompatible with Vista? RRS feed

  • General discussion

  • Hello all,
    I just wanted to let everyone know of a possible problem with Samsung SH-S162L DVDRW drives and Vista.  I experienced this problem tonight and it took me a while to figure out what was the root of my issue.

    In my Vista upgrade experience (from an MSDN subscription) I ran into problem after problem.
    It's actually quite discouraging, I still actually working on getting VISTA installed now - seven hours after I started - NON-stop troubleshooting.

    First, upgrading Vista from Win XP was an interesting experience.  Occasionally when the Vista Business Upgrade DVD was inserted into the drive the system would just hang (or explorer crash, etc.) when it attempted to access the DVD drive - eject the disk and the system recovers.

    Additionally when the system was restarted with the Vista Upgrade disk in the drive, my Intel 975XBX motherboard would not finish POST.  It did initial POST, went to the first SATA array, went through the second SATA array (this board has eight SATA ports) and then went back to the finishing POST and would always hang on 5A or A5, can't remember (which is "display F2 setup prompt" - according to Intel's error codes).   As soon as the disk was ejected from the drive, the system would IMMEDIATELY boot into windows.

    Thinking it was a firmware problem I updated both my board's BIOS and the DVDRW firmware to the latest versions - still no luck.

    I have not had a single problem with this Samsung drive and I did successfully installed Vista using it and upgrading in Windows XP.

    OK, so I replaced the drive (because I want to format my existing partition and use the work-around to get a fresh copy of Vista on my system) and put a Plextor SATA DVDRW in it's place - now after several more hours of troubleshooting, I am attempting to get Vista to install on my four drive Raptor RAID 0 array.  I finally found the driver for the array and now I'm stuck with "Windows is unable to find a system volume that meets its criteria for installation."

    I must say this whole thing has been an utter trainwreck from the beginning.  As a technology consultant and system builder I am extremely hesitate to recommend Vista to my clients.

    If anyone has any suggestions on how to get Vista on a four drive RAID 0 array or why my Samsung DVDRW doesn't work, please let me know.

    Thanks,
    Daniel
    Monday, February 5, 2007 11:01 AM

All replies

  • I am having the same exact problem with a Lite-On LH-20A1H.

    I have a date later today with MS level 2 support.

    I may try swapping other DVD players I have lying around to make it work.
    Friday, February 9, 2007 6:52 PM
  • Vista was unable to run my Samsung SH-S162L (TS-H652L) drive too. I've been trying for almost 2 weeks to get it to work. And I thought I had thought of everything. Then I was looking through this forum and came across the following fix. It is for a different dvd drive manufacturer but I was desperate for a fix so I went ahead and tried it. IT WORKED! I have no idea why doing this works, but I am just so happy that it did work. So here's the magic fix... (thanks to Gerrit_31)

    Gerrit_31


    Posts 1
    Re: dvd-rw not working!!!!
    Was this post helpful ?

    Open RegEdit

    FindKey: HKEY_LOCAL_MACHINE/System/Currentcontrolset/Control/Class/
    Right click on key: {4d36e965-e325-11ce-bfc1-08002be10318}

    Export it to a safe place

    Now go to the right pane, and delete the keys named: UpperFilters and LowerFilters

    Close RegEdit and restart computer, windows will now reinstall drive, maybe this will help. If not, you can import back your safety copy you made earlier.




    Hobbyist Extraordinaire

    Monday, February 12, 2007 2:40 AM
  • Hello. I have the same problem. Vista + Samsung SH-S162L. Can't recognize DVD RW. CD RW works.

    I have tried the solution you suggested without success.

    Further experience on that problem?

    Thanks for help.

    Claudio, Italy
    Tuesday, July 21, 2009 9:06 PM