none
Bug copying .eml-Files, time stamp changed

    Question

  •  

    When copying eml-files for backup from a non-vista system (XP-PC, Qnap-Server) to a Vista Home Premium machine, the time stamp "modified" of the files is changed to the current date / time of the Vista PC.

     

    This effect exists since some Vista update about 2 weeks ago.

    It makes backups more difficult because they are based on the modified-time-stamps.

     

    Why is this happening, and will there be an update to change this back ?

    Tuesday, December 2, 2008 11:47 AM

Answers

  • Martin

    I had this same problem using the English version of Vista.  I was able to delete the .eml key by first changing the permissions on the key.  Right click on it and choose Permissions, then Advanced, and set the owner to the current user or Administrators.  Then check the Allow box for Full Control for the permissions of Administrator and click OK.  I was then able to delete the key.  Hope that helps.
    • Marked as answer by Martin_BU Monday, October 12, 2009 2:45 PM
    Sunday, October 4, 2009 9:27 PM

All replies

  • This is a really bad problem for me, can someone help ?

     

    Wednesday, December 10, 2008 9:12 AM
  • What update(s) did this Vista machine install and since then the issue occured?

     

    Wednesday, December 10, 2008 11:16 AM
    Moderator
  •  

    Thank you for paying attention to this problem.

     

    I cannot say exactly. Somebody else in our firm does the backups, he saw it first, he says maybe from the middle of november it appears.

     

    Someone in the german vista newsgroup posted about it at September, 20:

    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.de.windows.vista.sonstiges&mid=6536a15f-9888-4246-b062-f320abe38045

     

    We are online all day and run updates automatically. It can not be said after which update the problem began.

    All Computers are Vista Home Premium.

    We are running Vista since beginning of this year, and up to the mentioned point of time, the problem did not occur.

     

     

    Thursday, December 11, 2008 3:47 PM
  • I am sorry but I can not see any other solution to this problem than to bring it up again by posting something so that maybe someone will see it.

    Monday, January 5, 2009 10:57 AM
  • Hi Martin
    Are you on Vista SP2? How exactly are you doing the copy? Are you doing it like a local network copy? If you could provide the steps that you do, we can repro it here and investigate it further.

    Thanks
    Wasil
    Tuesday, January 6, 2009 2:59 AM
  • Hi Wasil,

    we have Vista Home Premium Systems with Service Pack 1 (Build 6001) in German language.
    (We would rather like to wait for the final release of service pack 2.)

    We make backups from a Qnap server or from a Windows XP machine to a Windows Vista computer.
    We have a standard local ethernet network.

    The problem is happening only with Windows Mail "*.eml" - files.

    It does not matter if we do the copy with Windows Explorer, Speedcommander, our backup-tool Backer, or with copy / xcopy / robocopy.

    When copying the file(s) in two explorer-windows, you can see the effect in the time-modified-column.
    The file shows its original time-modified-stamp for about one second, than it is automatically changed to the current time of the target system.

    We work with many eml-files, and this issue makes our backup quite uncomfortable.

    Would you recommend installing SP2 ?

    Thank you,
    Martin
    Tuesday, January 6, 2009 6:13 PM
  • Hi Martin
    Could you move to SP2 and tell us if you still see the issue happening? I did try copying Windows mail *.eml files from an XPSP3 machine to a Vista SP1 machine and I did not see the modified timestamp getting changed.
    Wednesday, January 7, 2009 5:37 AM
  • Unfortunately my boss does not allow to install sp2 before it is finally released.

    I looked at our XP-PC, it has sp3, too. So, in a similar configuration as yours the problem occurs on our machines.
    I tried from vista to vista, here the problem does not appear.

    So the copying from non-vista-machines to vista is affected in our case.

    Maybe some idea ?


    Wednesday, January 7, 2009 3:42 PM
  • I have exactly the same problem. Vista SP1.

    Brand new machine, only pre-installed standard software, Norton, Adobe, some MS own s/w, all MS updates applied.

    I would never apply a beta service pack.

    Lack of a decent import for OE folder structures AND this bug are driving me crazy.

    Saturday, January 17, 2009 9:03 AM
  • I started this thread in the service packs forum because I thought it had to do something with updates, and I coud not find a better one. Maybe the forum experts would rather like us to install SP2, but on office pc's used for daily work this seems too risky for me.

    Wasil said he tried to reproduce the problem and it did not occur. So I thought maybe it has to do with the language version of Windows Vista (German in my case) ? 
    Monday, January 19, 2009 7:56 AM
  • Me too, exactly the same problem when copying an eml files from XPSP3 to Vista.
    This eml file was initialy created with outlook express.
    If I rename this eml to txt before copy, no problem, then on vista I try to rename it as eml and the date change to now.

    3 weeks old computer with vista familly premium SP1 6001.
    Very enoying feature for backup.

    I think I will remove vista and install again XP pro


    Thursday, February 5, 2009 2:30 PM
  •  

    Hi,

    Thanks for reporting this issue. We would like to delve more on to this issue.

    Please log a bug report using http://connect.microsoft.com/InvitationUse.aspx?ProgramID=2730&SiteID=749&InvitationID=CPP-G93D-QDHH
    Do post back the feedback ID for our reference.


    Thanks,
    Sachin

    • Marked as answer by Sachin Trivedi Friday, February 6, 2009 10:44 PM
    • Unmarked as answer by Martin_BU Tuesday, February 10, 2009 7:55 AM
    Friday, February 6, 2009 10:43 PM

  • Hi Sachin,

    I don't understand, I have clicked on your link, created an account, and after, where do I log a bug report for this eml date bug?

    On your link, there is WS08 SP2/Vista SP2 Beta, why, I don't care, I'm on Vista SP1.
    Friday, February 6, 2009 11:49 PM
  • Hi,

    I made a feedback using the data collector, disregarding the sp2-topic in the headline.
    So I was not sure about the build revisision number I was asked so I clicked on the only one that was offered.
    The feedback ID is 412579.

    Thank you all,
    Martin.

    Sunday, February 8, 2009 3:26 PM
  • Hi Sachin,


    it's nice to be invited to a special bug report, but this is the result of the feedback after installing and running that feedback collector software and report the same things that were described here already:


    "For SP2 RC the bug bar has been raised for this test cycle"

    "Field Status changed from [Active] to [Resolved]"

    "Field Resolution changed from [Not set] to [Won't fix]"

    "Field Status changed from [Resolved] to [Closed]"


    At least, the issue has been answered very fast.


    As I mentioned above maybe this is the wrong sub-forum for this thread, because it is not SP2, but I could not find a better one.

    I think the only way is to wait for the final release of SP2 and hope that the problem will be gone.

    Best regards,
    Martin







    Monday, February 9, 2009 10:41 AM
  • I tried to use some of the interesting features of this forum and felt free to press the "Unmark as answer" button in Sachins post.

    I read about what it means that "the bug bar has been raised". It means that this bug is too trivial to be looked at in the "SP2" process.

    Maybe it is trivial, but this should not be a reason not to fix it.


    "Can we fix it ? ...."


    Tuesday, February 10, 2009 8:00 AM
  •  
    Perhaps a light at the end of the tunnel ...
     
    My status. Two PC on my desk: the old one, XP-OutlookExpress, and the new one Vista x64 SP1. Net connection.
    When I copy .eml files from XP-machine to Vista-machine, soon (few seconds) or later (4 days) a devil "touches" these files and changes the timestamp. It doesn't matter which mail-application is installed (e.g. either Windows Mail or Mozilla Thunderbird), nor which drive I write to (either C:\ or E:\ on a second physical disk). Very very uncomfortable and unfair behavior of Vista OS.
     
    The idea: the file indexing service! Go to ControlPanel -> IndexingOptions -> Advanced -> FileTypes, and un-check the extension ".eml" from the list. I've done that 40 hours ago, I copied a folder of mail messages, and the timestamp is not changed yet.
     
    I'm not much confident yet, but I'll be pleased if someone else could try this remedy and confirm me that the trouble is definitely fit.
     
    Thursday, March 5, 2009 10:03 AM
  • Hello Bruco,

    thank you for contributing.

    As far as I remember in the long time we have this problem, I tried the indexing deactivation too.

    Please look at the files in the target destination (Vista) and move mouse pointer over them and click on some.

    It would be interesting to see if the time stamps changes then. Please report !

    Martin
    Thursday, March 5, 2009 10:25 AM
  • No, it doesn't change, after 48 hours the devil still sleeps ...

    And you? did you try it again?

    Bruco
    Thursday, March 5, 2009 4:38 PM
  • It's the same on our machines as it was earlier. When I follow your instructions, the time stamp does not change automatically. 

    But when the eml-file is opened or even the mouse cursor is slowly moved over the file in the Explorer, it changes again to current date.

    Wasil tried earlier to reproduce the problem, with no "success".

    I still believe somehow it has to do with the language version.

    Is there someone lucky with sp2 rc installation who can say if the problem exists there ?
    Friday, March 6, 2009 11:35 AM
  • Hello Martin,

    Because of another problem with Vista I had to refresh the OS installation. I turned off immediately any indexing service. I also applied SP2 RC.

    However, the timestamp-changing problem appeared again exactly as you say. Awful.

    I went back to XP, happily!

    Bruco
    Thursday, May 7, 2009 5:50 AM
  • Hello everybody,

    Windows Vista Service Pack 2 final arrived, and regarding the problem here nothing changed.
    It seems very few people regard it as a problem.
    But there will be more.

    Martin
    • Proposed as answer by rsposto Saturday, June 6, 2009 8:58 PM
    • Unproposed as answer by Martin_BU Monday, June 8, 2009 1:01 PM
    Thursday, May 28, 2009 4:10 PM
  • I have not used Vista, but encountered this problem with Windows 7 RC, and I have been unable to use W7 because it messed up my .EML archive.  I thought this was related to Windows Live Mail, as the problem did not exist when I uninstalled WLM. 

    However, while investigating this further, I discovered the following:

    1. The problem with .EML date stamp exists out of the box with a fresh install of Windows 7, without installing any applications, and in particular without installing WLM.

    2. The problem continues to exist when WLM was installed.

    3. The problem stops when WLM is uninstalled.

    Comparisons of the registries for these three situations revealed that in (1) and (2), a .eml entry exists under

    \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers

    This .eml entry is gone once WLM is uninstalled.

    After reinstalling WLM, this key entry reappears, and the date stamp problem starts again.  However, deleting this key entry and rebooting causes the date stamp problem to stop.  Adding back the registry key makes the problem start up again.

    The PropertyHandlers key seems to be related to search, but I haven't noticed any problem resulting from its deletion, admittedly with limited experience.

    This workaround may have solved the problem in Windows 7 RC, at least so far.  Perhaps this also applies to Vista.



    Saturday, June 6, 2009 9:15 PM
  • Hi Rsposto,

    I tried uninstall, reinstall, reuninstall everything with windows live in it, always with reboot, the registry-key mentioned by rsposto did not disappear, and it cannot be removed manually.

    When unchecking eml-files in indexing options, the problem seems to disappear, but time stamps are changed when clicking or moving cursor over them. Maybe it is the same here.

    I am sorry to mark my last post as "unpropose as answer". Maybe it was a misunderstanding to propose it as answer.

    Martin
    Monday, June 8, 2009 1:10 PM
  • Hi, Martin

    Yes, at first I mistakenly checked "Propose as answer" rather than reply, because I intended to propose an answer.

    When you say that the .eml entry cannot be removed, do you mean that you cannot delete it from the registry, as that is all that I did, (hit "delete" on the .eml entry under PropertyHandlers, getting just the usual warning asking whether to proceed).

    This is an odd problem, as one respondent in a windows 7 forum could not even duplicate that a problem exists.  In any case, at the moment my Windows 7 install no longer has the problem with WLM installed, after deleting the registry entry I noted above.


    R Sposto





    Monday, June 8, 2009 3:07 PM
  • Also, I may not be using the registry terminology accurately-- e.g., what are considered "keys" and which are not "keys".  I am referring to simply the .eml branch under 

    \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers

    in the Windows 7 registry.

    R Sposto
    Monday, June 8, 2009 3:13 PM
  • The registry entry looks exactly the same in Vista, but Windows Vista says ".eml cannot be deleted. Error while deleting key" (in my personal translation from German).

    Did you try clicking the copied files if the time stamp change takes place then ?

    Some Posts earlier I thought that the language version of Windows has influence on the problem. Do you have a localized version ?

    Martin
    Monday, June 8, 2009 3:34 PM
  • I am in the U.S., and am using an English version of Windows 7 RC.  

    The .eml files behave now in my Windows 7 install as they did in XP -- I can open them in explorer (double-click to open in WLM) without changing the modify date.  I can also drag them from WLM to an explorer folder and they retain the date the email was sent as the modify date, as is the case in XP with Outlook Express.  

    Before deleting this registry entry, mouse-over would bring up an information window that summarized some properties of the file (e.g., size) .  After deleting the registry entry, an information box no longer appears.  This seems to reinforce the notion that the problem may be in the Property Handler for these files, where the act of retrieving this file information for display would modify the file. (Note I am not a programmer so have only a superficial understanding of these things).

    R Sposto
    Monday, June 8, 2009 5:32 PM
  • I have the same problem server 2008 standard x64English version.
    Unfortunately I too cannot delete the eml key from the registry to test this.
    It is really annoying me and mucks around with my backups something terrible.
    Date modified must be the last date the file was modified. If the file is an exact copy, the date modified should NOT be changed. I suspect the property handler is in fact modifying the file..so the file system updates the date modified as it should.
    I cannot understand why Microsoft has not paid more attention to this as the issue has been known for more than 8 months now.
    Thursday, July 30, 2009 10:46 AM
  • Any update on this?  I have the same problem using a desktop and laptop computer, both running Vista x64.

    The timestamp is not updated when I copy-and-paste in Windows Explorer, but the timestamp is touched when I use a third-party synchronisation tool like SyncToy.  This odd behaviour only occurs for EML files (whose filenames all start with numbers, by the way).

    Thanks.

    Saturday, September 26, 2009 4:59 AM
  • Martin

    I had this same problem using the English version of Vista.  I was able to delete the .eml key by first changing the permissions on the key.  Right click on it and choose Permissions, then Advanced, and set the owner to the current user or Administrators.  Then check the Allow box for Full Control for the permissions of Administrator and click OK.  I was then able to delete the key.  Hope that helps.
    • Marked as answer by Martin_BU Monday, October 12, 2009 2:45 PM
    Sunday, October 4, 2009 9:27 PM
  • Unfortunately, changing permissions doesn't work for me.  No matter what I try, I get the message "Unable to save permission changes on .eml.  Access is denied."

    So it seems the only solution is to install Windows Live Mail simply for the purpose of uninstalling it, and hope the registry key goes away.


    Edit:  Doh!  Once I found the "Owner" tab and changed the owner from TrustedInstaller to my (admin) ID, I was able to delete the key.  Now to see if the system stops messing with my email files...

    Thanks, Martin!
    • Edited by dbls00 Monday, October 12, 2009 2:49 PM Palm-to-forehead moment
    Monday, October 12, 2009 2:40 PM
  • Paccc,

    I think for me it is the solution of this item. Thank you very much.


    dbls00,

    did you exactly follow the description of Paccc ?
    it is important to do all the settings from the "advanced" dialogue and its sub-menus.
    Then, in my case, it worked. .eml key erased, computer restarted, ok.

    Martin
    Monday, October 12, 2009 2:51 PM
  • Thank you all for the hard work you've put into this.  I just yesterday upgraded to Windows 7 x64 and found this issue, also when I went to perform my usual backup and my app told me that the date stamps for my EML files had all changed.

    This is a SHOWSTOPPER!! I can not believe this has actually never been fixed since Vista!

    Just a bit more info after my own research.

    This is related to %SystemRoot%\system32\inetcomm.dll and affects EML files AND NWS files (though I guess most of us don't have any NWS files, never heard of that extension before myself)

    I think that deleting all registry entries relating to GUID {5FA29220-36A1-40f9-89C6-F4B384B7642E} would be safest bet, or alternatively, maybe deleting the DLL?

    A reboot doesn't seem to be necessary for the changes to take effect :)
    Tuesday, December 29, 2009 11:43 AM
  • I have an apparent solution , but first I must vent.

    I can't believe Microsoft has not seriously addressed this issue.  It's been going on since Vista and continues with Windows 7.  It destroys the sanctity of file timestamps which affects so many things.  Either the system is modifying the files when it shouldn't or manipulating date stamps when it shouldn't.  But enough venting.  We all know this.

    I found this solution on another site:  Tech Support Guy on the thread "Old File Dates Change to TODAY" (Tech Support Guy Forums > Operating Systems > Windows Vista >) at http://forums.techguy.org/windows-vista/704204-old-file-dates-change-today.html.

    Basically, unlink the EML file association with Windows Live .  I changed the association to Thunderbird, and so far, the dates aren't changing.

    I also changed the attribute of the files to Read Only.  Without elminating the association to Live, the dates would still be changed (which is unforgivable that the OS allows this to happen ).  So you must change the association and make the files Read Only.

    Before this fix, on my Windows 7 machine, practically the minute I copied an EML file either from an external hard drive over an internal network, the date and time were changed to the present.
    • Proposed as answer by alecamiga Sunday, January 31, 2010 6:04 AM
    Thursday, January 21, 2010 8:15 AM
  • My findings/guesses regarding this issue (which I experience with Windows 7):

    Windows 7 derives certain file properties from the file content, and caches these inside an NTFS alternate data stream (ADS) on the file called OECustomProperty.  The available properties, and the method of generating them from the file content, is dependent upon the file type, determined from the filename extension.

    When the properties are accessed, the access goes through the caching mechanism and this will trigger the generation of the OECustomProperty ADS if it isn't already present.  Since this is a write operation to the ADS, the "last modified" timestamp of the file is updated (there is no separate timestamp for an ADS).

    The properties may be accessed by the Windows 7 indexing system (for fast searches), probably so it can index based on those attributes.  The indexing is triggered almost instantly when a file is added to the filesystem, so this can cause the timestamps to change immediately when the files are created.  This would result in the problem where files copied from an external source (a non-NTFS source or via a transfer mechanism that doesn't copy ADS) have their timestamp corrupted immediately.

    But even if you disable indexing (maybe for a specific directory), windows explorer makes use of these file properties.  In detail view, some columns may display these properties, and clicking on a file also appears to access the properties (not sure why - perhaps it's making sure they are cached before the user asks for the file properties?).  So windows explorer can also trigger the creation of the ADS and the update of the file timestamp.

    Once the ADS is there, it usually isn't updated except when the file contents are updated, so you usually won't see the timestamp reset again after the first time for a given file.

    Sorry if any of that is incorrect, and thanks for the tip about the .eml registry key.

    I'm not yet sure I want to do that though, because I don't want to break the facility to index .eml files based on the properties from the email header.

    Friday, March 19, 2010 6:31 AM
  • My findings/guesses regarding this issue (which I experience with Windows 7):

    Windows 7 derives certain file properties from the file content, and caches these inside an NTFS alternate data stream (ADS) on the file called OECustomProperty.  The available properties, and the method of generating them from the file content, is dependent upon the file type, determined from the filename extension.

    When the properties are accessed, the access goes through the caching mechanism and this will trigger the generation of the OECustomProperty ADS if it isn't already present.  Since this is a write operation to the ADS, the "last modified" timestamp of the file is updated (there is no separate timestamp for an ADS).

    The properties may be accessed by the Windows 7 indexing system (for fast searches), probably so it can index based on those attributes.  The indexing is triggered almost instantly when a file is added to the filesystem, so this can cause the timestamps to change immediately when the files are created.  This would result in the problem where files copied from an external source (a non-NTFS source or via a transfer mechanism that doesn't copy ADS) have their timestamp corrupted immediately.

    But even if you disable indexing (maybe for a specific directory), windows explorer makes use of these file properties.  In detail view, some columns may display these properties, and clicking on a file also appears to access the properties (not sure why - perhaps it's making sure they are cached before the user asks for the file properties?).  So windows explorer can also trigger the creation of the ADS and the update of the file timestamp.

    Once the ADS is there, it usually isn't updated except when the file contents are updated, so you usually won't see the timestamp reset again after the first time for a given file.

    Sorry if any of that is incorrect, and thanks for the tip about the .eml registry key.

    I'm not yet sure I want to do that though, because I don't want to break the facility to index .eml files based on the properties from the email header.

    Friday, March 19, 2010 6:32 AM
  • The current state of my workaround:

    • Uninstall Windows Live Mail, use Windows Mail instead
    • disable indexing
    • use a non-windows server
    Friday, March 19, 2010 7:38 AM
  • Hi, Martin

    So deletion of the registry key that I proposed last June did not work for you afterall?  This has worked for me, both in W7RC and in W7 Professional, with WLM and indexing etc -- no other changes were necessary.

    R Sposto

    Tuesday, March 30, 2010 2:33 PM
  • Hi R Sposto,

    I am sorry but at the moment I have no time for research on that. At the moment, uninstalling WLM removes the .eml-entry, and I do not use WLM, and I do not necessarily have to use indexing service. Maybe some time I will try out, and send a post.

    Martin

    Tuesday, March 30, 2010 6:22 PM
  • Hi !

    Today Microsoft decided to kill Windows Mail by update. Because of Security.

    So I installed WLM, removed the .eml-entry as R Sposto described, rebooted, and everything was fine.
    As far as I can see.

    Martin

     

    Wednesday, May 12, 2010 12:44 PM
  • I still have this problem on Vista ultimate, newest updates. To make sure I understand the information in this thread:

    1) the .eml files change to the present date when they are indexed by the search indexer; this is, a few seconds after creation. Thus, backup/restore/sync will not work properly, but indexing.

    2) if you delete that mentioned registry key, then the indexing of .eml files no longer works, i.e. you cannot find them in a full-text search. However, backup works now.

    3) it is unknown whether the other solution, proposed by alecamiga, to link .eml to thunderbird and write lock the files, does the same or works better.

    I have some 10000 .eml from 20 years, and I need search indexing and automatic backup. Maybe I have to switch to linux.

    Monday, September 27, 2010 12:33 AM
  • Hello Peter

    I am on Windows 7 Professional 32, and I simply delete the registry key, which solves the changing date stamp problem.  The .eml files still are indexed, with the CLSID_WLMCMimeFilter, and I can find them by name or by content.  I don't remember, though, whether I had to go into indexing advanced options and reestablish this filter for .eml file. I don't think so, but perhaps check if .eml appear in the files types being indexed.

     

    RSposto

    Saturday, October 2, 2010 6:18 PM
  • Thank you! I deleted the key, and the MIME filter for .eml indexing was still in place. Full text is still found in the e-mails, as far as i can say so far. Sorry for the late response, I lived for half a year without complete backup.

    And, by the way, I have to develop a shell script to restore the modification date of my 10,000 e-mails. Thank you, microsoft, for this feature.


    Peter Steier
    Thursday, March 31, 2011 7:17 PM
  • Hello,

    our company already made an software caled EML Atributer, it can fix it back (works on Vista, 7,...). You just chose the folder with .eml files and click OK, our SW find all .eml files and fix the date. You can find it on our page: http://lizard-sw.com/sw.html

    or here: http://www.stahuj.centrum.cz/utility_a_ostatni/zjednoduseni_prace/automatizace/eml-atributer-lizard-software/

    or direct download: http://lizard-sw.com/sw/eml.zip

    For personal úse it is FREE... for comercial use you have to pay for it (price by mail)

    Kind regards

    Lizard Software


    • Proposed as answer by LadislavTT Monday, May 2, 2011 2:41 PM
    Monday, May 2, 2011 2:23 PM
  • I consider using your software to fix the dates (just sent an e-mail; unfortunately I cannot read your czech website). Will the program use the "received" date from within the e-mail?

    I'm still fighting with my own shell script, since changing the acess date confuses file sychronization with my server, which always wants to copy the files with the newer dates over the older ones. Since my shell script is very slow, I would appreciate a faster program, if I need several tries until the original dates get hold again.


    Peter Steier
    Monday, May 2, 2011 4:27 PM
  • Dear Peter,

     

    we already made an english version of EML Atributer, you can download it right now from here: http://lizard-sw.com/en/sw/eml.zip

    other information about EML Atributer you can find on our english website http://lizard-sw.com/en/sw.html or here http://lizard-sw.com/en/

     

    Kind regards

    Ladislav Motl - Lizard Software s.r.o.  Czech Republic


    • Proposed as answer by Helicofan Monday, November 5, 2012 11:41 AM
    • Unproposed as answer by Helicofan Monday, November 5, 2012 11:41 AM
    Tuesday, June 21, 2011 8:59 AM
  • Since the new version of WLM, deleting the eml registry key doesn't work any more because WLM will create it again if you delete it.

    Only solution for now and very good solution is to use the software proposed by LadislavTT http://lizard-sw.com/en/sw.html

    As this soft is not in english, just follow these steps :
    - run it
    - click on the button on the top to choose a directory
    - click OK

    This soft will retrieve original dates for all eml files found in this directory and its sub directories.

    Thanks to Lizard company and LadislavTT

    • Proposed as answer by Helicofan Monday, November 5, 2012 12:05 PM
    Monday, November 5, 2012 12:05 PM
  • Hello,
    I've the same problem:
    I've many emails (.eml files) stored in a folder on my PC and I use a program to synchronize this folder on an external hard disk. But, every time I do the synchronization, these .eml files always seem to be modified, even though they have never been opened or modified by me!
    But the files are really different: the modified date of .eml files is constantly and automatically (not by me) changed.
    So I've to synchronize these files each time uselessly transferring many GBs and losing a lot of time...
    I want to say that I have this problem only with Windows 7 64 bit and .eml files. Instead in Windows XP everything is working correctly.
    How can I avoid this annoying problem?
    Thank you.

    Tuesday, November 6, 2012 11:14 AM
  • Solved!!! By a suggestion from Mr. Spigolo, on the Microsoft Support site.

    Simply remove the .eml extension from the Indexing Options Advanced page,

    in the Control Panel! It DOES work!

    Thanks, Mr. Spigolo!

    Marco254

    Friday, April 21, 2017 8:20 PM