none
MDT/WDS network credentials prompt RRS feed

  • Question

  • Hi All,

    Working through a Windows 10 deployment scenario using WDT and WDS using the following as a guide:

    Deploy a Windows 10 image using MDT

    This was working a few months ago and I had to leave it for another task. I have just picked it up again and noticed that after the deployment splash screen starts I get a network credentials prompt, populated with the username and the domain name.

    All the credentials are in the customsettings.ini and I notice that even if I type the credentials in the prompt they fail.

    I have checked for logs but nothing, recreated the deployment share, task sequence and boot images but get the same message.

    Any suggestions on where to look next would be greatly appreciated!

    Thanks in advance,

    Matt

    Monday, September 9, 2019 12:09 PM

Answers

  • Thanks for all your suggestions. I never did get to the bottom of the issue but strangely it has started working again - even litetouch.vbs.

    Thanks again Matt

    • Marked as answer by Mattps2 Thursday, September 12, 2019 12:18 PM
    Thursday, September 12, 2019 12:17 PM

All replies

  • Any chance that this user account is locked in AD or has an expired password?
    Monday, September 9, 2019 12:27 PM
  • Nope, checked that.

    Thanks anyway.

    Monday, September 9, 2019 12:33 PM
  • Maybe try generating a new boot file and update it in your WDS.
    Monday, September 9, 2019 1:06 PM
  • Thanks, already tried that as well.
    Monday, September 9, 2019 1:09 PM
  • Have you tried to execute the custom deployment with same credentials? Please verify whether is it working properly before moving ahead.

    If you're getting prompt for entering credentials, Make Sure you have added Username, Password & Domain inside Bootstrap.ini files.

    Don't forget to completely regenerate the boot Image and Insert newly created files to WDS.

    Monday, September 9, 2019 2:27 PM
  • Hi, Yes I am trying a custom deployment. The credentials are in bootstrap.ini and the boot image has been regenerated and replaced on WDS.
    Monday, September 9, 2019 2:40 PM
  • If you manually type in the creds and it still fails, I would lean toward the account and not MDT.

    Are you able to map to the server from another pc using the same credentials?

    Monday, September 9, 2019 2:46 PM
  • I have tried using the domain admin creds, as well as my own account details. Both have UNC access from other devices and both accounts are not locked out and both fail with WDS.
    Monday, September 9, 2019 2:54 PM
  • This may not be your issue but I've been reading how MS updates break WDS.
    The solution for this is (which you can revert back if it doesn't fix your problem):

    Open Windows Deployment Services console / Right-click your WDS server in the left pane and open Properties
    Open tab “TFTP” and  uncheck “Enable Variable Windows Extension”

    Reset WDS service.

    See if that makes a difference...

    Monday, September 9, 2019 3:01 PM
  • Thanks I've come across this before and can confirm that it's already unchecked.
    Monday, September 9, 2019 3:21 PM
  • For Validation, Could you please try to initiate litetouch.vbs for custom deployment in any reference machines!

    How you have put your credentials specifically Username, use IP address, FQDN 

    Monday, September 9, 2019 4:57 PM
  • This is the custom settings ini file:

    [Settings]
    Priority=Default
    [Default]
    _SMSTSORGNAME=********
    OSInstall=YES
    UserDataLocation=AUTO
    TimeZoneName=GMT Standard Time 
    AdminPassword=********
    JoinDomain=********
    DomainAdmin=********
    DomainAdminPassword=********
    MachineObjectOU=OU=Computers,DC=********,DC=********
    ScanStateArgs=/ue:*\* /ui:********\*
    USMTMigFiles001=MigApp.xml
    USMTMigFiles002=MigUser.xml
    HideShell=YES
    ApplyGPOPack=NO
    WSUSServer=********:8530
    SkipAppsOnUpgrade=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerName=NO
    SkipDomainMembership=YES
    SkipUserData=YES
    SkipLocaleSelection=YES
    SkipTaskSequence=NO
    SkipTimeZone=YES
    SkipApplications=NO
    SkipBitLocker=YES
    SkipSummary=YES
    SkipCapture=YES
    SkipFinalSummary=NO

    This is the bootstrap ini file:

    [Settings]
    Priority=Default

    [Default]
    DeployRoot=\\********\deploymentShare$
    UserDomain=*********

    Userpassword=********

    UserID=********
    SkipBDDWelcome=YES

    Tuesday, September 10, 2019 7:26 AM
  • Are you using the full domain name?  I had an issue where domain = domainname, wouldn't let me login.  But domain = domainname.com would.

    Tuesday, September 10, 2019 9:38 AM
  • Hi, tried the FQDN as well. no joy.

    Thanks anyway.

    Tuesday, September 10, 2019 9:48 AM
  • So I'm guessing that you cannot image any computers at this time since you cannot get credentials to kick off the vbs.

    Obvious things, but have you checked the permissions on your Share? I'd say either something is wrong in AD or you don't have permissions to access the Share. Clearly it could be anything, just things popping into my head.

    Tuesday, September 10, 2019 12:12 PM
  • Thanks the1rickster,

    I have tried opening up the share to Authenticated users and Domain users but to no avail. I think I am going to have to flatten the deployment share and start again - it's just that it took me the best part of 3 days to download and structure all the drivers for each machine type!

    Never mind.

    Thanks for your suggestions everyone.


    Tuesday, September 10, 2019 12:43 PM
  • I do have one question.....I see you have in your CS file an AdminPassword and a domainadminpassword.

    Just out of curiosity, use this as a template and see if it works.

    JoinDomain=***.***.***.us
    DomainAdmin=name of admin account which joins to the domain
    DomainAdminDomain=domain that domainadmin is part of (probably the same domain)
    DomainAdminPassword=*****

    MachineObjectOU=OU=Computers

    FinishAction=Reboot

    (Try to delete the AdminPassword= line)

    I do realize that this portion is for domain join so it likely won't help. Just grasping at thoughts.



    • Edited by the1rickster Tuesday, September 10, 2019 1:13 PM
    Tuesday, September 10, 2019 1:04 PM
  • Thanks for all your suggestions. I never did get to the bottom of the issue but strangely it has started working again - even litetouch.vbs.

    Thanks again Matt

    • Marked as answer by Mattps2 Thursday, September 12, 2019 12:18 PM
    Thursday, September 12, 2019 12:17 PM