locked
Configure SharePoint Workflow 2010 Infrastructure on SharePoint 2013 RRS feed

  • Question

  • Hi,

    have a cloudshare SharePoint 2013 Environment.
    There I want to use "SharePoint 2010 Workflows" on a standard list.
    When I try to creat a workflow with SharePoint Designer 2013 I get the following error:

    "The list of workflow actions on the server references an assembly that dies not exist. Some actions
    will not be avaiable. The assembly strong name is Microsoft.SharePoint.WorkflowActions, Version=15.0.0.0,
    Culture=neutral, PublicKeyToken=..."

    I have no idea how to fix the problem. After asking the support at cloudshare they told me
    I have to configure the workflow 2010 infrastructure on the virtual server.

    How can I manage that, in standard installation workflow engine 2010 is already installed.

    Thank you very much
    Stephan

    Wednesday, August 27, 2014 12:42 PM

Answers

  • The 2010 workflows are part of the base product, there is nothing to configure per se. Can you try clearing your SharePoint Designer cache?

    http://www.myspblog.com/2011/07/clear-sharepoint-designer-cache.html


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by PrasadWT Friday, August 29, 2014 6:35 PM
    • Marked as answer by Victoria Xia Thursday, September 4, 2014 8:30 AM
    Thursday, August 28, 2014 12:52 PM

All replies

  • Do you have Service Pack 1 for SharePoint 2013 installed and configured? You do not need Workflow Manager to support SharePoint 2010 Workflows on 2013.

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 27, 2014 1:14 PM
  • Hi Trevor,

    Service Pack 1 has been installed. How can I install SharePoint Workflow 2010 afterward, or what do I have to stup to fix the problem.

    Thank you

    Stephan

    Wednesday, August 27, 2014 5:05 PM
  • Is this impacting all sites, or specific sites? Do you still get the assembly error when trying to create a SharePoint 2010 workflow?

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 27, 2014 6:44 PM
  • Hi Trevor,

    it impacts all site collections. At the moment it is not possible to create any workflow, I get the error ehen I try to create a workflow in SharePoint Designer.

    Cloudshare Support told me, they do a minimal configuration so that the customer can install every feature he needs.

    But I have no clue how to install workflow 2010 feature afterwarts. There are only 1000s of tutorials how to install Workflows 2013 on a SharePoint 2013 afterwards.

    Thanks

    Stephan

    Thursday, August 28, 2014 6:28 AM
  • The 2010 workflows are part of the base product, there is nothing to configure per se. Can you try clearing your SharePoint Designer cache?

    http://www.myspblog.com/2011/07/clear-sharepoint-designer-cache.html


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by PrasadWT Friday, August 29, 2014 6:35 PM
    • Marked as answer by Victoria Xia Thursday, September 4, 2014 8:30 AM
    Thursday, August 28, 2014 12:52 PM