locked
Registering DLL's for WMI RRS feed

  • Question

  • Hi,

    In regards to rebuilding the repository by removing the Repository folder within the wbem structure, two commands need to be executed in order for the WMI components to be re-registered.

    The commands are as follows:

    ---------------------------------------------

    for %i in (*.dll) do RegSvr32 -s %i

    for %i in (*.exe) do %i /RegServer

    ---------------------------------------------

    Just so that I understand, could these commands please be broken down to explain what they do? Also, could each part of the command be explained so I know why "%i" is being used for example. It's one thing to execute the commands, it's another thing to understand what they actually do and why.

    Thanks.

    Sunday, June 15, 2014 6:48 PM

Answers

  • Are you trying to fix WMI ?

    Run this :

    winmgmt /verifyrepository
    If Output of this will be: WMI Repository is INCONSISTENT. 

    Then run this command :

    winmgmt /salvagerepository


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, June 17, 2014 9:51 AM
    Moderator

All replies

  • Are you trying to fix WMI ?

    Run this :

    winmgmt /verifyrepository
    If Output of this will be: WMI Repository is INCONSISTENT. 

    Then run this command :

    winmgmt /salvagerepository


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, June 17, 2014 9:51 AM
    Moderator
  • I'm aware of how to do this, but this is not what I'm asking.

    Please read my question again.

    Wednesday, June 18, 2014 6:49 AM