locked
Windows 7 won't wake up from sleep RRS feed

  • Question

  • I just installed a new copy of Windows 7 Pro 32-bit on my desktop and reformatted my harddrive a few days ago. Everything worked fine until I tried to put it to sleep, which it never did. My computer fans and harddrive was still going but my monitors immediately went blank (standby mode). Now after unplugging it, resetting it, powering down and back up multiple times, my monitors are still blank. In addition, after restarting it with the screens still blank, my fans would run full speed and then my BIOS would beep at me 3 times before the fans go back down to "normal" speeds. Anyone help please?
    Friday, August 13, 2010 11:37 PM

Answers

  • Hi ,

    Based on your description, first, I suggest you should best update your BIOS ,chipset and display adapter driver to the latest version .

    Then, Please first uninstall all unnecessary devices and see if the issue can be resolved. Also, test in Clean Boot.

     If the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Besides, please use Powercfg command to check this issue. To do that, refer to the steps below:

     

    1. Click the Start Button, type "cmd" (without quotation marks), right click on the "Cmd.exe" in the search result list and select "Run as administrator".

    2. Type "powercfg -devicequery wake_armed" (without quotation marks) in the open window and press Enter Key.

     

    3. A list of the configured devices to wake the computer will be received, then please type the following command to disable them one by one and see if the culprit can be found. (We may test the result after disabling each device.)

     

    Powercfg -devicedisablewake "devicename"

     

    Note: "devicename" is a device name listed as a result of running the first command.

     

    For example, if the network card "Broadcom NetXtreme Gigabit Ethernet" is listed, we can type the following command to disable it and press Enter.

     

    Powercfg -devicedisablewake "Broadcom NetXtreme Gigabit Ethernet"

     

    4. Please repeat the steps for other devices in the list.

    5. Reboot the computer and check this issue again.

     

    What's the result now?

     

    For more information, please refer to Powercfg Command-Line Options.

     

    If the issue persists, please refer to the following articles for more troubleshooting suggestions:

     

    Sleep and hibernation: frequently asked questions

     

    Windows 7 does not go to sleep

     

    Hope it helps.

     

    Regards ,

    Alex

    • Marked as answer by Linda Yan Monday, August 23, 2010 8:44 AM
    Monday, August 16, 2010 8:48 AM