locked
Exchange 2010 Recurring Meetings declines all if conflicts on some RRS feed

  • Question

  • Hi

    I hope someone can help please.  I have read a number of related threads - heres the technet blog ive read http://blogs.technet.com/b/exchange/archive/2011/02/07/3411956.aspx, however none explain the exact setting I need to apply through the gui rather than using powershell.

    Basically I have setup resource scheduling in Exchange 2010- all users can setup meetings to the resource but it does not allow ANY conflicts.  Which is what we want.  However when setting up recurring meetings, the whole series is declined because of 1 or two conflicts.

    We would much prefer the system to accept all non conflict meetiings, and decline the rest.

    I have read that using powershell cmdlet and set the following:

    • AutomateProcessing: Must be set to AutoAccept to allow automatic booking of any meeting requests, recurring or not. Note, the default is AutoUpdate.
    • AllowRecurringMeetings: Set to True by default. If it's changed to False, all recurring meeting requests are rejected.
    • AllowConflicts: The parameter determines whether conflicting meeting requests are allowed.

    Will allow for exactly what I need.  However when I run the following syntax in powershell:

    Set-CalendarProcessing -"Meeting Room - Training Room" -AutomateProcessing AutoAccept

    I receive the error:

    The term 'Set-CalendarProcessing' is not recognized as the name of a cmdlet, function, script file, or operable program
    . Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At line:1 char:23
    + Set-CalendarProcessing <<<<  -"Meeting Room - Training Room" -AutomateProcessing AutoAccept
        + CategoryInfo          : ObjectNotFound: (Set-CalendarProcessing:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    This just stops me right in my tracks and I cannot progress any further - I have only ever used powershell once or twice during a training course so I have limited knowledge - is there a simpler way I can achieve what I need to in the EMC?

    Many Thanks for your help

    ps: many apologies - the forum category/forum is incorrect but I could not find Exchange 2010 in the list when posting this thread...

    Carla

    Thursday, May 30, 2013 2:49 PM

All replies

  • *Bump*

    Can anyone help? :)

    Many Thanks

    Carla

    Thursday, June 6, 2013 7:56 AM
  • Set-CalendarProcessing -"Meeting Room - Training Room" -AutomateProcessing AutoAccept

    I receive the error:

    The term 'Set-CalendarProcessing' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.


    Hi,
    Make sure you type the command in Exchange Management Console (EMS) and not in Windows PowerShell.

    Also, the syntax above is wrong.
    Try this:
    Set-CalendarProcessing "Meeting Room - Training Room" -AutomateProcessing AutoAccept
    (without a dash after Set-Calendarprocessing)

    The forum for legacy versions of Exchange (including EX10), is found here

    Martina Miskovic

    Thursday, June 6, 2013 5:58 PM
  • Hi

    Thanks very much for your help.

    The syntax you have given me - is this the only syntax I need apply to allow my scenario to work correctly?

    Thanks

    Carla

    Monday, June 10, 2013 8:19 AM
  • Hi

    Thanks very much for your help.

    The syntax you have given me - is this the only syntax I need apply to allow my scenario to work correctly?

    Thanks

    Carla


    No,
    You need to configure the settings ConflictPercentageAllowed and MaximumConflictInstances as described in the blog post you posted the link to above.

    Personally, I often use the settings:
    -ConflictPercentageAllowed 99 -MaximumConflictInstances 4

    ...but that is me. You need to find settings that works best for you

    Martina Miskovic

    Monday, June 10, 2013 3:40 PM