none
MultiValue Fields in MSOP 2007 RRS feed

  • Question

  • Is there a way to turn off Multi Value fields in MSOP 2007.  I have files in MSOP 2003 that have text fields populated with mapping to Customer information (Client WBS, etc...).  However when I open one of these MSOP 2003 files in MSOP 2007 all the text fields are empty.  How can I share customer text field informtion from 2003 to 2007. 

    Applications used are MSOP 2003 and MSOP 2007 Standard.

     

    Tuesday, April 26, 2011 1:27 PM

Answers

  • BlueAngel42,

    I'm a little confused by the message you saw. It sounds like Text29 is a customized field with a value list, but the error message you get is not the error message associated with an incorrect input into a customized field with a value list. Multi-valued fields are associated with enterprise resource fields, but you say you are using Project standard which means you cannot be using Project Server.

    Okay, try this. Double click on the header for Text29. What is the field name? What is the title? If indeed the field name is Text29 then go to Tools/Customize/Fields. Scroll down the list to Text29. On the Custom Attributes, what option is selected (i.e. none, value list, or formula)?

    John

    • Marked as answer by BlueAngel42 Tuesday, April 26, 2011 6:44 PM
    Tuesday, April 26, 2011 6:19 PM

All replies

  • BlueAngel42,

    What exactly do you mean by, "...text fields populated with mapping..."? Did you customize an extra text field with a value list?

    I created a simple one task file in Project 2003. I customized Text1 with a value list. I then opened that file in Project 2007. Text1 displayed the same value list values. In other words I can't reproduce what I think you have.

    More information would be helpful.

    John

    Tuesday, April 26, 2011 3:14 PM
  • Hi John,

    I mean that I have inserted Text29 Field and added the customers corresponding wbs in that field.

    Example

    Text29       Task

    1.1             Project XYZ

    1.1.1          Summary Task 1

    1.1.1.1       Task 1

     

    When I open this same file up in MSOP 2007 all the entries in Text29 are empty.  Any ideas?  Is there a setting in MSOP 2007. 

    If I try to enter in 1.1 in Text29 in SMOP 2007 I get the following error "

    The Input into the Multi-Values field is invalid

    One of the following might be wrong:

    You have not separated you individual values withtghe Multi-Value list separator ,

    You have entered an invalid individual value

    You have entered the same value more than once

    The current value is too long to be displayed and must be edited through the dropdown

    If I open up a blank project in MSOP 2007 and insert a text field, it will let me enter whatever data I choose without giving any errors.  This only seems to happen if I am tring to open a file that already has a text field populated with data.

    Any ideas?

    Tuesday, April 26, 2011 5:28 PM
  • BlueAngel42,

    I'm a little confused by the message you saw. It sounds like Text29 is a customized field with a value list, but the error message you get is not the error message associated with an incorrect input into a customized field with a value list. Multi-valued fields are associated with enterprise resource fields, but you say you are using Project standard which means you cannot be using Project Server.

    Okay, try this. Double click on the header for Text29. What is the field name? What is the title? If indeed the field name is Text29 then go to Tools/Customize/Fields. Scroll down the list to Text29. On the Custom Attributes, what option is selected (i.e. none, value list, or formula)?

    John

    • Marked as answer by BlueAngel42 Tuesday, April 26, 2011 6:44 PM
    Tuesday, April 26, 2011 6:19 PM
  • John,

    You are correct, I am not using the server version.

    That seems to have been the problem.  I am not sure where/how this got selected as a value list in 2003.  I guess I just didn't notice it as in 2003 it will still allow me to enter any data even with the value list selected.  Strange......  I changed this in the 2003 version and we were able to open it on the other machine that is running 2007.

    Thanks for talking me through this.

     

    Tuesday, April 26, 2011 6:44 PM
  • BlueAngel42,

    You're welcome and thanks for the feedback.

    I still don't understand the error message you received, but I guess it's mute since the problem is solved. Just for reference there is a setting when you set up or edit the value list that allows (or prevents) values other than those in the list from being entered.

    John

    Tuesday, April 26, 2011 7:47 PM