locked
Windows 10 does not ask me for password to access NAS RRS feed

  • Question

  • Hi,

    I just added a QNAP TS-451+ to my setup, so now I have a Windows 10 Pro 64b (updated from Win 7 pro), Windows XP, and the NAS. Using the web interface to the NAS, I logged in as its admin and set stuff up, then logged out. However, if I used windows file manager to access the nas via \\mynas I had full admin access to it without being asked for the password again.

    If I logged off my pc or rebooted it, then restarted it, I still had full admin access through the file manager.

    The credential manager does not show any credentials for the NAS.

    net use says "New connections will be remembered. There are no entries in the list."

    When I boot in safe mode with networking I still have access to the NAS.

    How do I control this behavior? For now, I would like it to ask me for the name and password the first time I try to access the nas in any given login session. In the future I may want to restore this behavior, or maybe there are other options available that I will like better. But I can't figure out how to control this.

    Thanks for your help.

    Friday, December 30, 2016 10:03 PM

Answers

  • Hi,

    When I first asked the question, what it was doing was giving me the permissions of the last successful login. However, I continued experimenting and now it is functioning as I expect.  I'll provide details so later people who run into this can read what I learned. Thank you for responding to me.

    I had two users defined, neither of which was the Windows login (call them notMe1 and notMe2). Whichever user I last logged in as with the web interface, those were the permissions I was getting when I accessed via the file manager, whether or not I was still logged into the web interface. It maintained that behavior even if I logged off of Windows.

    As part of experimenting based on these latest two suggestions, I created a third user with the same name and password as the Windows login (call it Me3). Now, when I use the file manager, the permissions are that of Me3, no matter what login I used via the web interface. It also doesn't ask me to provide a user name and password for the NAS.

    So then I deleted Me3 from the NAS, leaving notMe1 and notMe2. Now, the first time I use the file manager after logging into windows, the NAS asks me for a user name and password. It remembers that user name and password and gives me access to the NAS as much as I would like until I log off of Windows. Then, because I am not checking "remember me" it asks me to log in to the NAS again next time I log into Windows. This was the behavior I wanted and was expecting all along.

    It seems that, in order to trigger it, I had to create the account Me3 on the NAS to match my Windows account. This is the resolution to the issue.

    • Marked as answer by racketteer Monday, January 2, 2017 8:08 AM
    Monday, January 2, 2017 8:08 AM

All replies

  • Hi racketteer,

    If you use "Map Network Drive", uncheck [Reconnect at sign-in].
        

    Regards,
    Ashidacchi
    Saturday, December 31, 2016 5:34 AM
  • Hi Ashidacchi,

    Thank you for responding. I am not using "map network drive." I am typing \\mynas in the address box of windows file manager.

    Daniel

    Saturday, December 31, 2016 8:51 AM
  • Hi,

    Please let me know if you choose "Remember me" or some option like this when you logon to NAS at the first time.

    Consider if your credential is remember into cookies, please find if there is any corresponding cookie under here for your NAS:

    C:\Users\[YOUR NAME]\AppData\Local\Microsoft\Windows\INetCache

    If so, remove it and check the results.

    Also, I would like to confirm if you use same user name and password for your Windows 10 logon and NAS logon. If so, you can also check if you change any of these password to see the results.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 2, 2017 5:42 AM
  • Hi,

    I went through your suggestions. I didn't think to check them before I posted the question, so thank you for the list. I don't think any of them are relevant, but here is what I did to check. Let me know if I misunderstood:

    • I did not choose remember me or automatic sign in when I used the web interface to log into the NAS. I checked that it asks me to log in with name and password.
    • I use FireFox rather than internet explorer. I checked the FireFox cookies and found them for the NAS maker's website but not for my NAS itself. Also, since I am accessing the NAS through the file manager rather than a browser I didn't think that cookies would be relevant.
    • I have not yet created an account on the NAS that has the same name as my Windows 10 logon.

    Any other suggestions?

    Monday, January 2, 2017 6:33 AM
  • Hi racketteer,

    I'm using (QNAP)ST-410, and have created some users on it.
      
    At the first time when I use/map a folder in it, it requires User Name and Passoword.

    Please try to create a User and give him/her permission for some folders on NAS.
    and check how Windows File Manager will behave, when you type "\\mynas"?

    # I suppose Windows Account has no relation with User on QNAP NAS.

    Regards,
    Ashidacchi

    • Edited by Ashidacchi Monday, January 2, 2017 7:23 AM
    Monday, January 2, 2017 7:22 AM
  • Hi,

    When I first asked the question, what it was doing was giving me the permissions of the last successful login. However, I continued experimenting and now it is functioning as I expect.  I'll provide details so later people who run into this can read what I learned. Thank you for responding to me.

    I had two users defined, neither of which was the Windows login (call them notMe1 and notMe2). Whichever user I last logged in as with the web interface, those were the permissions I was getting when I accessed via the file manager, whether or not I was still logged into the web interface. It maintained that behavior even if I logged off of Windows.

    As part of experimenting based on these latest two suggestions, I created a third user with the same name and password as the Windows login (call it Me3). Now, when I use the file manager, the permissions are that of Me3, no matter what login I used via the web interface. It also doesn't ask me to provide a user name and password for the NAS.

    So then I deleted Me3 from the NAS, leaving notMe1 and notMe2. Now, the first time I use the file manager after logging into windows, the NAS asks me for a user name and password. It remembers that user name and password and gives me access to the NAS as much as I would like until I log off of Windows. Then, because I am not checking "remember me" it asks me to log in to the NAS again next time I log into Windows. This was the behavior I wanted and was expecting all along.

    It seems that, in order to trigger it, I had to create the account Me3 on the NAS to match my Windows account. This is the resolution to the issue.

    • Marked as answer by racketteer Monday, January 2, 2017 8:08 AM
    Monday, January 2, 2017 8:08 AM