none
Network folders slow after Windows 10 1803 update RRS feed

  • Question

  • Greetings!

    After installing 1803 upgrade for our Windows 10 Enterprise PC, we got some strange bug:

    When user or application try to open file from shared folder with a thousands of files, it takes almost 1 minute.

    We found same problem here:

    https://partnersupport.microsoft.com/en-us/par_clientsol/forum/par_win/network-folders-slow-after-windows-10-1803-update/5c622107-46d5-43b3-a98c-9ae480968e77

    Some manipulations with regestry help us, but it's weird:

    Regedit

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

    add 

    DirectoryCacheLifetime Dword=0

    FileInfoCacheLifetime Dword=0

    FileNotFoundCacheLifetime Dword=0

    Don't forget to reboot.



    How about official fix?

    Monday, June 18, 2018 2:03 PM

All replies

  • Is the server in question Windows Server 2008?
    Monday, June 18, 2018 5:38 PM
  • Hi,

    This is a helpful workaround and don't forget to back up the registry before you modify it.

    Since there is some similar issue like "can't access exe file in shared folder","application in shared SQL not work", that is because the smb is changed in windows 1803.

    We have talk to product group to confirm your issue, if there is any update , I will let you know.

    And make sure that you have installed all windows update, which may released fixes in the following days.

    Thanks for your feedback and understanding.

    Best regards,

    Vivian


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 19, 2018 3:22 AM
  • Hi, The_Techguy.

    No, it's about 2012R2 server.

    Tuesday, June 19, 2018 5:14 AM
  • Hi, vivian_zhou.

    Thank you. We will wait for fix.

    Can you give more info about SMB changes in 1803?
    Tuesday, June 19, 2018 6:16 AM
  • Hi,

    Here are some smb issue in Technet Forum recently after windows 10 1803 released. These are part of hot issue, if you want to know more, search the key word in the forum.

    https://social.technet.microsoft.com/Forums/office/en-US/80d86b3b-28ff-4abe-945f-a1efccb5cf8e/rs41803windows-10-1803-wont-run-odbc-sql-connected-application-from-network?forum=windowsgeneraldevelopmentissues

    https://social.technet.microsoft.com/Forums/windows/en-US/4c2a029b-327a-4ad7-a2ce-7bd4fcc25226/windows-10-after-update-1803-odbc-sql-server-connect-problem?forum=win10itprogeneral

    https://social.msdn.microsoft.com/Forums/en-US/2ac7057f-27cd-4e35-9533-d8e020ed123e/possible-bug-windows-10-1803-blocks-network-access-to-programs-running-from-shared-network-folders?forum=win10itprogeneral


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 19, 2018 7:17 AM
  • helps for me ... it took me 3 days even to know it was 1803 that caused the problem 

    made the keys and now working fine

    Wednesday, August 8, 2018 10:34 AM
  • Alexey, you are awesome!  Thanks for this!  We have an old app which relies on an SMB share and slowed way down with 1803.  Most SMB issues out there are surrounding the v1 problem, but ours is v2.1 and was concerning slowness.  These cache timeout settings are the golden ticket!  Thank you, thank you, thank you!
    Tuesday, October 23, 2018 8:41 PM
  • I agree.

    File copying worked way better in even Windows 3.x - the newer the Windows, the slower the copy.

    I wonder if Microsoft will ever dare say $10 for every bug found...

    Thursday, December 6, 2018 7:20 PM
  • Any update please? 
    Wednesday, January 9, 2019 9:42 PM
  • Many thanks for this solution.  Worked great.  
    Wednesday, January 30, 2019 7:04 PM
  • Thanks, I can confirm that adding these registry keys fixed the problem for me.

    I had several network folders with Gigabytes of files in each and they would take ages to open while using windows 10. opening on windows 7 was fine. this was causing an application to hang frequently. 

    After adding these registry Dword values i could click on folders and they would instantly open. 

    I copied the below text into a .reg file and double click to merge. 

    ****************************

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
    "DirectoryCacheLifetime"=dword:00000000
    "FileInfoCacheLifetime"=dword:00000000
    "FileNotFoundCacheLifetime"=dword:00000000



    Wednesday, July 3, 2019 9:49 AM
  • Thanks for sharing the solution. It works in my lab as well. It seems Microsoft has released an official solution: https://support.microsoft.com/en-us/help/4504548/slow-network-share-performance-using-windows-10-1803s
    Friday, November 8, 2019 8:46 PM