none
HyperV Network Adapters causing issues for the guest OS RRS feed

  • Question

  • Intro

    I work for a managed IT services company that takes care of a large amount remote sites for a single organisation, each site larger than a certain size gets a Hyper-V Server running Server 2008r2 with one Guest OS running windows server 2008r2, this Server provides File, Print, DC and SCCM Content Distribution services for that site. Whilst we're migrating a new site into our system the Guest OS has two Virtual NICs - one that is connected the new network the other is connected to the old network, this is achieved using VLANs and allows us to move data easily between the Old and the New.

    The initial Problem

    Recently we installed a new server at a site and migrated it into our system. All has been going fine for the last two weeks but today just as we were doing the final shutdown of the old equipment and moving our gear into the cabinet something happened. The Hypervisor and Guest came up after a shutdown during the move and for some reason the Virtual NICs that were attached to the Guest didn't seem to be working. So, a few things were tried.

    These are the steps we've taken so far.

    1. Tried to uninstall/reinstall the NIC on the guest, this resulted in the device manager sitting at the "uninstalling" window for at least an hour, so it was assumed that this step failed
    2. Tried Shutting down the Guest, it sat at "Stopping" for about half an hour, So it was assumed that this step failed
    3. Tried Shutting down the Host, it sat at "Shutting Down Hyper-V Management Services" for about another half an hour, so it was assumed this step failed
    4. Triggered a Hard reset
    5. The Hypervisor comes back up, the Guest OS autoboots, tried shutting down and it stalls again, tried editing the settings but they take.
    6. Repeat of Steps 2-4
    7. The Hypervisor comes back up, the Guest OS autoboots, before trying to shut down the guest change the Guest OS settings so that it will not boot automatically, tried shutting down the guest and it stalls again
    8. Repeat of Steps 2-4
    9. The Hypervisor comes back up, the Guest OS does not autoboot, try removing the NICs and Add back in one
    10. Start the Guest
    11. The Guest OS still has issues with the adapter
    12. Try shutting down the Guest OS and it hangs again
    13. Repeat of Steps 2-4
    14. The Hypervisor comes back up, the Guest OS does not autoboot, Removed the NIC from the Guest
    15. Start the Guest
    16. No issues with the Network and sharing center but also no NICs
    17. Start DevMgr and remove the disconnected devices hoping that it is just them causing the issues
    18. Shut down the Guest OS, it shuts down cleanly
    19. Add in a NIC again
    20. Start the Guest
    21. Guest OS has issues
    22. Repeat of Steps 2-4
    23. The Hypervisor comes back up, the Guest OS does not autoboot, Removed the NICs from the Guest
    24. Repeat of Steps 15-18
    25. Decide to try using a legacy adapter instead of a normal one
    26. Boot Guest
    27. The Guest OS doesn't have any issues
    28. It appears that everything works

    The Issue Now (and my questions)

    This fix is about as temporary as it gets, Legacy Network Adapters only allow 100mbps and this will cause issues further down the road with this site, its size and how intensively our users use the File sharing Services on the server.

    Has there been any recorded occurrences of the Hyper-V adapters causing issues for the Guest OS?
    Does anyone have an idea how I could fix this issue?
    Is there some kind of patch that will fix this issue?

    If all else fails we can rebuild the Guest OS but the amount of effort and pain that would take is quite unattractive....

    Thursday, July 10, 2014 1:49 PM

All replies