none
Empty DeployR landing page after installation RRS feed

  • Question

  • I am struggling to get DeployR Open installed on Windows 7 64-bit.

    I have followed the instructions on Installing & Configuring DeployR, but the DeployR landing page gives a HTTP 404 "Not found" error.

    At first, I had another issue with DeployR reporting missing prerequisites:

    A supported version of R or MRO could not be found.
    DeployR Rserve package could not be found.

    This, I could work around by installing R Open for R Server 2016 / R Open for RRE - Windows rather than Microsoft R Open 3.2.4,to which the installation guide links.

    Installation then proceeds normally, the log file DeployR-configuration.log looks fine and services RServe7.4 and MongoDB-for-DeployR-8.0 have status Started.

    I had a look at the diagnostics. Diagnostics.bat reports:

    exception: login failed
    DEPLOYR DIAGNOSTIC LOG
    Mon May  9 14:07:24 W. Europe Daylight Time 2016
    -------------------------
    CHECKING: Is MongoDB running?
    Yes, MongoDB is running.
    -------------------------
    MongoDB INFO:
    MongoDB shell version: 2.6.7
    -------------------------
    MongoDB CONFIG:
    host  localhost
    port  8003
    dbpath C:/PROGRA~1/MIE74D~1/DEPLOY~1.0//deployr/database
    exception: login failed
    -------------------------
    CHECKING: Is DeployR running?
    Yes, DeployR is running.
    -------------------------
    DEPLOYR INFO:
    Product release  Open
    -------------------------
    DEPLOYR HOST:
    OS Name                    Microsoft Windows 7 Enterprise
    Memory
    total      3.979 MB
    free   1.006 MB
    Filesystem Size
    Total # of free bytes        : 6480187392
    Total # of bytes             : 127509983232
    Total # of avail free bytes  : 6480187392
    -------------------------
    DEPLOYR CONFIG:
    deployr.rengine.rserve.port 8004
    deployr.rengine.console.socket.server.port 8006
    Server Web Context:
    -------------------------
    CHECKING: DeplopyR Script Execution
    Script execution successful.
    -------------------------
    R INFO:
    R version 3.2.2 (2015-08-14) -- "Fire Safety"
    [1] "R version 3.2.2 (2015-08-14)"
    exception: login failed
    exception: login failed
    let: GRID_COUNT = 2016-05-09T14: value too great for base (remainder of expression is "09T14")
    -------------------------
    ENVIRONMENT INFO: JAVA
    java version "1.8.0_91"
    Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)
    -------------------------
    ENVIRONMENT INFO: TOMCAT
    "8000" protocol
    "8001" protocol
    "8002" shutdown
    doc-base C:/PROGRA~1/MIE74D~1/DEPLOY~1.0/www/apps  path /apps
    -------------------------
    Gathering files, logs, and other details (ports, tomcat context, ...)
    Diagnostic CHECKING is complete. Zipping files. Please check logs/diagnostics.log for more details.
    -------------------------
    diagnostics.zip created

    and catalina.out:

    org.springframework.data.mongodb.CannotGetMongoDbConnectionException: 
    Failed to authenticate to database [deployr], username = [deployr], password = [G**********Y]

    My questions:

    1. Is it correct to install R Open for RRE, rather than R Open 3.2.4?
    2. How can I best troubleshoot this issue?


    • Edited by rs23771 Monday, May 9, 2016 12:17 PM Added more detailed log info.
    Monday, May 9, 2016 11:33 AM

Answers

  • I found a solution to this issue. Delving further in the log files on one machine, I found messages about insufficient disk space.

    I decided to reinstall DeployR. However, this is not quite straightforward. Simply uninstalling, restarting and installing didn't solve my issue. Finally, I got it working by performing the following steps:

    1. Uninstall DeployR.
    2. Remove the service for Mongo DB entering the following command in a cmd window running as admin: sc delete MongoDB-for-DeployR-8.0.
    3. Remove the complete directory C:\Program Files\Microsoft\DeployR-8.0.
    4. Reinstall DeployR.

    Now, the landing page opens and, after changing the default password, the status tab shows both DeployR Server and DeployR Default Node as active.

    I noticed in the succesful installation that I didn't have to confirm the DeployR post installation configuration steps Populate database and Configure database.

    • Marked as answer by rs23771 Friday, October 7, 2016 8:39 AM
    Monday, May 9, 2016 2:03 PM
  • DeployR 8.0.0 OPEN  works with the following versions of R open:

    You can read more here.  Make sure you look at the instructions for DeployR Open, not enterprise.

    • Marked as answer by rs23771 Friday, October 7, 2016 8:39 AM
    Thursday, October 6, 2016 4:39 PM
    Moderator

All replies

  • I found a solution to this issue. Delving further in the log files on one machine, I found messages about insufficient disk space.

    I decided to reinstall DeployR. However, this is not quite straightforward. Simply uninstalling, restarting and installing didn't solve my issue. Finally, I got it working by performing the following steps:

    1. Uninstall DeployR.
    2. Remove the service for Mongo DB entering the following command in a cmd window running as admin: sc delete MongoDB-for-DeployR-8.0.
    3. Remove the complete directory C:\Program Files\Microsoft\DeployR-8.0.
    4. Reinstall DeployR.

    Now, the landing page opens and, after changing the default password, the status tab shows both DeployR Server and DeployR Default Node as active.

    I noticed in the succesful installation that I didn't have to confirm the DeployR post installation configuration steps Populate database and Configure database.

    • Marked as answer by rs23771 Friday, October 7, 2016 8:39 AM
    Monday, May 9, 2016 2:03 PM
  • I'm glad you were able to work it out.

    Microsoft R Open 3.2.4 is not a supported version of R for DeployR 8.0.0.

    Sunday, May 15, 2016 7:51 PM
    Moderator
  • Could you please also comment on:

    At first, I had another issue with DeployR reporting missing prerequisites:
    A supported version of R or MRO could not be found.
    DeployR Rserve package could not be found.

    This, I could work around by installing R Open for R Server 2016 / R Open for RRE - Windows rather than Microsoft R Open 3.2.4,to which the installation guide links.

    I am trying to do another installation and run into the same issue again. I see that the Installing & Configuring DeployR page has been updated, but it still references Microsoft R Open. Should it work with that version?






    Thursday, October 6, 2016 1:02 PM
  • DeployR 8.0.0 OPEN  works with the following versions of R open:

    You can read more here.  Make sure you look at the instructions for DeployR Open, not enterprise.

    • Marked as answer by rs23771 Friday, October 7, 2016 8:39 AM
    Thursday, October 6, 2016 4:39 PM
    Moderator
  • Now I think I understand what I did wrong. On Installing & Configuring DeployR 8.0.0, the links Revolution R Open point to http://mran.microsoft.com/. If you then navigate Microsoft R Open - Download now, you will get https://mran.revolutionanalytics.com/install/mro/3.3.1/microsoft-r-open-3.3.1.msi, which is not supported.

    Also, it is important to note that on the release history page, there are some versions of Microsoft R Open and some versions of Revolution R Open. Apparantly, only the latter work with DeployR Open 8.0.0.

    Friday, October 7, 2016 8:38 AM