none
Documents Not Redirecting with User Configuration\Policies\Windows Settings\Folder redirection

    Question

  • I have a problem with server 2008r2 and windows 7 Enterprise.

    I set the Folder redirection for Documents to go to %homedir% (This is because our users documents are set in different locations)

    When I log onto the machine it does not go to the %homedir% as set in Active directory, it goes to a folder two levels above their individual one. This is how it used to be but I have changed the policy location.

    The users have access to the homedir. I double check this by resetting the home folder in Active Directory. 

    I have run the GPresult on the machine for the user. It shows other folder redirections apart from the documents one (start menu and app data - both correct).

    It does the same if I re image the machine with a fresh image with no Group policy. So this cant be a legacy policy. I have tried also running gpupdate /force /sync

    Heres the GPResult

    User Configuration
    Policies
    Windows Settings
    Folder Redirection
    Application Data
    Winning GPO All User Policy
    Setting: Basic (Redirect everyone's folder to the same location)
    Path: \\SERVERNAME\profiles$\studenttest\AppData\Roaming
    Options
    Grant user exclusive rights to Application Data Disabled
    Move the contents of Application Data to the new location Enabled
    Also apply redirection policy to Windows 2000, Windows 2000 server, Windows XP, and Windows Server 2003 operating systems Disabled
    Policy Removal Behavior Leave contents
    Start Menu
    Winning GPO All User Policy
    Setting: Advanced (Specify locations for various user groups)
    Group Path
    APPLEFIELDS\Students \\SERVERNAME\netlogon\start_menu\students
    Options
    Grant user exclusive rights to Start Menu Disabled
    Move the contents of Start Menu to the new location Disabled
    Also apply redirection policy to Windows 2000, Windows 2000 server, Windows XP, and Windows Server 2003 operating systems Enabled
    Policy Removal Behavior Restore contents


    So as you can see there is no Documents being applied but if I look at the machine I can see the properties of the documents folder and it points to a different location on the server.
    • Edited by beancole Tuesday, March 10, 2015 3:28 PM
    Tuesday, March 10, 2015 3:26 PM

Answers

  • > I set the Folder redirection for Documents to go to %homedir% (This is
    > because our users documents are set in different locations)
     
    Better use %homeshare%%homepath% as redirection target.
     
    BTW: I do not recognize %homedir% as an environment variable on my
    testing lab. Who creates this variable?
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    • Marked as answer by beancole Wednesday, March 11, 2015 1:46 PM
    Wednesday, March 11, 2015 10:06 AM

All replies

  • > I set the Folder redirection for Documents to go to %homedir% (This is
    > because our users documents are set in different locations)
     
    Better use %homeshare%%homepath% as redirection target.
     
    BTW: I do not recognize %homedir% as an environment variable on my
    testing lab. Who creates this variable?
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    • Marked as answer by beancole Wednesday, March 11, 2015 1:46 PM
    Wednesday, March 11, 2015 10:06 AM
  • tried homeshare home path still doesnt work?
    Wednesday, March 11, 2015 10:51 AM
  • > tried homeshare home path still doesnt work?
     
    What are your exact settings? Please add the output of "set home" for a
    test user.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Wednesday, March 11, 2015 11:28 AM
  • The setting is;-

    Advanced - specify locations for various user groups

    Group = DOMAIN\Students
    Target Folder Location = Redirect to users home directory (which resolves to path = %HOMESHARE%%HOMEPATH%)

    The user is in the correct group the OUs etc are all correct, The start menu also applies to separate groups but this is working fine as shown above.

    There is not a GPO conflict or anything like that so why else could this happen. I think it is likely something on server 2008R2. 

    Wednesday, March 11, 2015 12:02 PM
  • Deleted the policy and started again it now works. I have compared both policies and they are exactly the same. 
    Wednesday, March 11, 2015 1:34 PM
  • > Deleted the policy and started again it now works. I have compared both
    > policies and they are exactly the same.
     
    Oops - ok, solved anyway :)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Wednesday, March 11, 2015 3:35 PM