locked
Office 2010 Activation issue when deploying with ConfigMgr RRS feed

  • Question

  • Good Morning all,

    As I'm not sure if this is an Office issue or a ConfigMgr one, I've also posted this in the ConfigMgr forum, please let me know if this is a problem.

    I'm deploying Office 2010 with ConfigMgr and I've run into an activation issue.  I used the OCT to create an MSP file which is supposed to activate the software in a post-installation step.  It successfully installs the software, and runs the MSP.  The issue is that is is still asking for activation when the user first runs the program.  I have added in the registry key which allows non-administrators to activate, but that didn't help.  If I run the msp file by itself, it also fails to activate, but if I run the command line for activation that is in the post-install step, it activates successfully. The program is set to run with administrator rights.  The command I run to activate is:

    Target:

    [WindowsFolder]\System32\cscript.exe

    Arguments:

    c:\"Program Files\Microsoft Office\Office14\OSPP.VBS" /act

    I have tried a few variations on this syntax, but none of them have worked. 

    Clients are both Win7 and XP. 

     

    Does anyone have any ideas as to why it isn't activating?

    Thanks!

    Monday, October 18, 2010 4:12 PM

Answers

  • When using a MAK key in the OCT, see the note below in the following article:

    http://technet.microsoft.com/en-us/library/cc179097.aspx#Licensing_and_user_interface


    Note:

    You can also activate Office 2010 at the time that you install a MAK key by setting the AUTO_ACTIVATE property value. To do this, follow these steps:

    1. In the OCT, select Modify Setup properties on the left pane, and then click Add in the right pane.

    2. In the Add Property Value dialog box, in the Name box, type AUTO_ACTIVATE. Note that property names must be uppercase.

    3. In the Value box, type 1, and then click OK.

    For information about configuring the AUTO_ACTIVATE property by using the Config.xml file, see Setting element in Config.xml file in Office 2010.

    Thanks,
    Darryl

     

    • Proposed as answer by DarrylMo Tuesday, October 19, 2010 9:47 PM
    • Marked as answer by Sally Tang Wednesday, October 20, 2010 5:52 AM
    Tuesday, October 19, 2010 4:23 PM

All replies

  • Any thoughts?  Anyone?

    The more I look at this, the more I'm convinced it's an Office issue.  If I run the MSP file (created by the OCT) from an elevated command prompt, it still doesn't activate. That pretty much takes SCCM out of the picture.

    Anyone used the OCT to silently distribute and activate Office 2010?

     

    Thanks

    Tuesday, October 19, 2010 2:40 PM
  • Are you running the installation as a Task Sequence or a chained program installation?
    Tuesday, October 19, 2010 3:08 PM
  • I'm running it as a standard program install.  The OCT creates an MSP file which I put in th updates folder.  According to the documentation, the install runs the updates in the folder after installation. 

     

    Tuesday, October 19, 2010 3:17 PM
  • That is correct with the MSP file.  All MSP's (custom or Microsoft Updates) that you place in the updates folder will be applied to the installation after the main program installation completes.  Be careful to only use one configured MSP file with the OCT if you allow setup.exe to automatically determine which custom MSP file to use.  If you have multiples, you will need to tell setup.exe which file to use with the /adminfile switch. 

    With using a VBS file, you have to run it as a seperate program and not apart of a task sequence as the task sequence environment uses its own script environment and is running a script based shell, so it has a problem with running a script file within a script shell.

    In most cases we are able to use the "Run another program first:" option to run a VBS command after our primary program to complete whatever changes we need.  However, for some reason or another we have had to periodically use a .CMD file to execute the .VBS file to get around this.  Particularly a .CMD file over a batch file because it will report the correct exit code to SCCM in most cases.

    It appears that your KMS server is responding to activation requests, but I am puzzled as to why the Office installation is not able to automatically activate without any intervention.  Maybe query the KMS server for polling intervals and ensure your count is over 5.

    The other configration question about your SCCM environment is whether or not your SCCM installation is being run with system level permissions or with user level permissions.  I would suggest logging into a computer with your SCCM account and running the activation command to see if it is able to do so with standard permissions or if it requires elevated rights.  I would think that if the SCCM account was unable to run the command, your installation would error with a permission error code.  You could also confirm this with lowering or disabling UAC on the system to see if the command will run.

    Tuesday, October 19, 2010 4:00 PM
  • When using a MAK key in the OCT, see the note below in the following article:

    http://technet.microsoft.com/en-us/library/cc179097.aspx#Licensing_and_user_interface


    Note:

    You can also activate Office 2010 at the time that you install a MAK key by setting the AUTO_ACTIVATE property value. To do this, follow these steps:

    1. In the OCT, select Modify Setup properties on the left pane, and then click Add in the right pane.

    2. In the Add Property Value dialog box, in the Name box, type AUTO_ACTIVATE. Note that property names must be uppercase.

    3. In the Value box, type 1, and then click OK.

    For information about configuring the AUTO_ACTIVATE property by using the Config.xml file, see Setting element in Config.xml file in Office 2010.

    Thanks,
    Darryl

     

    • Proposed as answer by DarrylMo Tuesday, October 19, 2010 9:47 PM
    • Marked as answer by Sally Tang Wednesday, October 20, 2010 5:52 AM
    Tuesday, October 19, 2010 4:23 PM