locked
Word 2010 does not input in Russian when language is switched from English to Russian. RRS feed

  • Question

  • I have Word 2010 with Russian language pack.

    When I switch language from English to Russian Word does not allow any input of Russian symbols until I press any symbol from English keyboard like any number, space or backspace. After that I can input Russian symbols.

    This does not happen when I switch from Russian to English.

    This does not happen in any other Office program (like Excel).

    This does not happen with any other program like notepad or wordpad.

    Thursday, February 26, 2015 5:53 AM

Answers

  • Hi,

    To troubleshoot this issue, please try to run Word in Safe Mode:

    Press Win + R, type "winword.exe /safe" in the blank box, press Enter.

    Then Word will start in Safe Mode, try to type and check if the problem persists. If no, the issue may probably be caused by some add-ins, disable the suspicious add-ins to verify which one caused the issue.

    Regards,

    Melon Chen
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs. Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Jacobkurl Friday, March 6, 2015 4:27 AM
    Friday, March 6, 2015 2:21 AM

All replies

  • Hi,

    Have you tried playing with Word button|Word options|Language and setting Russian as a default editing language?

    Also, please look here. Not quite your problem, but the effects sound similar.


    Well this is the world we live in And these are the hands we're given...


    Thursday, February 26, 2015 10:50 AM
  • Yes I did. Nothing help.

    And I have another system with the same Word 2010 and I have no issue there.

    Friday, February 27, 2015 2:47 AM
  • Exotic,

    Tried all suggestions that you pointed to. They look similar but not one helped.

    Friday, February 27, 2015 3:11 AM
  • Another thing I've found out is that along with Standard PS/2 Keyboard I have installed HID Keyboard Device.

    Can it be somehow related to my issue?

    Friday, February 27, 2015 3:45 AM
  • Another thing I've found out is that along with Standard PS/2 Keyboard I have installed HID Keyboard Device.

    Can it be somehow related to my issue?

    Hi,

    How about on the system without this issue? Do you have HID Keyboard Device installed on it too?

    You can try to install the HID Keyboard Device on the system with no issue, then check if the problem will start to occur. If the issue occurs after the installation of the device, the issue is probably caused by a conflict caused by the device.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here
    Monday, March 2, 2015 6:04 AM
  • Hi,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here
    Thursday, March 5, 2015 1:06 AM
  • I have HID device installed on the system where I don't have any issue.

    I've found even more interesting thing.

    Let suppose I open new document and switched to Russian. I cannot type anything in Russian so I press space and begin to type in Russian. Then I press multiple times backspace and erase everything I typed.

    At this point I cannot input anything in Russian again.

    Then I press space one time, backspace one time and I still can type in Russian.

    Then again erase everything with back space, press space once and backspace twice. After this I cannot Type in Russian again.

    Based on all this I come to conclusion that this issue is not related to directly to keyboard but has some other reason.

    Thursday, March 5, 2015 3:22 AM
  • Hi,

    To troubleshoot this issue, please try to run Word in Safe Mode:

    Press Win + R, type "winword.exe /safe" in the blank box, press Enter.

    Then Word will start in Safe Mode, try to type and check if the problem persists. If no, the issue may probably be caused by some add-ins, disable the suspicious add-ins to verify which one caused the issue.

    Regards,

    Melon Chen
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs. Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Jacobkurl Friday, March 6, 2015 4:27 AM
    Friday, March 6, 2015 2:21 AM
  • Thanks Melon.

    It was indeed PDFComplete add-in.

    Friday, March 6, 2015 4:27 AM
  • Add-Ins in Microsoft Word

    Charles Kenyon Madison, WI

    Friday, March 6, 2015 8:25 PM
  • Thanks Charles.

    I've resolved my issue already by turning off PDFComplete add-in.

    But anyways it's useful that you provide extensive look on related problems.

    Regards.

    Jacob

    Saturday, March 7, 2015 9:06 PM